Bump to net-im/psi-0.11.
[underlay.git] / net-im / psi / psi-0.11.ebuild
blobc3e3f7e812e20314e2165021e6feef0788ee1770
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 inherit eutils multilib qt4
7 DESCRIPTION="QT 4.x Jabber Client, with Licq-like interface"
8 HOMEPAGE="http://psi-im.org/"
9 SRC_URI="http://downloads.sourceforge.net/${PN}/${P}.tar.bz2"
10 RESTRICT="mirror"
12 IUSE="crypt doc kernel_linux spell ssl xscreensaver"
13 SLOT="0"
14 LICENSE="GPL-2"
15 KEYWORDS="~amd64 ~x86"
17 DEPEND="$(qt4_min_version 4.2.3)
18 =app-crypt/qca-2*
19 media-libs/libpng
20 spell? ( app-text/aspell )
21 ssl? ( dev-libs/openssl )
22 xscreensaver? ( x11-libs/libXScrnSaver )"
24 RDEPEND="${DEPEND}
25 crypt? ( >=app-crypt/qca-gnupg-0.1_p20070904 )
26 ssl? ( >=app-crypt/qca-ossl-0.1_p20070904 )"
28 DEPEND="${DEPEND}
29 doc? ( app-doc/doxygen )"
31 pkg_setup() {
32 if ! built_with_use x11-libs/qt qt3support ; then
33 eerror
34 eerror "In order to compile Psi, you will need to recompile"
35 eerror "qt4 with 'qt3support' USE flag enabled."
36 eerror
37 die "Recompile qt4 with USE=\"qt3support\""
41 src_compile() {
42 # growl is mac osx extension only - maybe someday we will want this
43 local myconf="--disable-growl --disable-bundled-qca"
44 use kernel_linux || myconf="${myconf} --disable-dnotify"
45 use ssl || myconf="${myconf} --disable-openssl"
46 use spell || myconf="${myconf} --disable-aspell"
47 use xscreensaver || myconf="${myconf} --disable-xss"
49 QTDIR=/usr/$(get_libdir) ./configure \
50 --prefix=/usr ${myconf} \
51 || die "configure failed"
53 eqmake4 ${PN}.pro
54 emake || die "emake failed"
56 if use doc; then
57 cd doc
58 make api_public || die "make api_public failed"
62 src_install() {
63 emake INSTALL_ROOT="${D}" install || die "emake install failed"
65 # this way the docs will be installed in the standard gentoo dir
66 newdoc iconsets/roster/README README.roster
67 newdoc iconsets/system/README README.system
68 newdoc certs/README README.certs
69 dodoc README
71 if use doc; then
72 cd doc
73 dohtml -r api || die "dohtml failed"