Bumped media-video/stk11xx to version 1.1.0.
[underlay.git] / net-im / psi / psi-0.11_pre20070915.ebuild
blobd253423d089ae1aa5b2f62d4ae9de9cd454ad2ee
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 inherit eutils multilib qt4
7 MY_PV="${PV:8:4}-${PV:12:2}-${PV:14:2}"
8 MY_P="${PN}-dev-snapshot-${MY_PV}"
10 DESCRIPTION="QT 4.x Jabber Client, with Licq-like interface"
11 HOMEPAGE="http://psi-im.org/"
12 SRC_URI="http://psi-im.org/files/snapshot/${MY_P}.tar.bz2"
13 RESTRICT="mirror"
15 IUSE="crypt doc kernel_linux spell ssl xscreensaver"
16 SLOT="0"
17 LICENSE="GPL-2"
18 KEYWORDS="~amd64 ~x86"
20 S="${WORKDIR}/${MY_P}"
22 DEPEND="$(qt4_min_version 4.2.3)
23 >=app-crypt/qca-2.0.0_rc4
24 media-libs/libpng
25 spell? ( app-text/aspell )
26 ssl? ( dev-libs/openssl )
27 xscreensaver? ( x11-libs/libXScrnSaver )"
29 RDEPEND="${DEPEND}
30 crypt? ( >=app-crypt/qca-gnupg-0.1_p20070904 )
31 ssl? ( >=app-crypt/qca-ossl-0.1_p20070904 )"
33 DEPEND="${DEPEND}
34 doc? ( app-doc/doxygen )"
36 pkg_setup() {
37 if ! built_with_use x11-libs/qt qt3support ; then
38 eerror
39 eerror "In order to compile Psi, you will need to recompile"
40 eerror "qt4 with 'qt3support' USE flag enabled."
41 eerror
42 die "Recompile qt4 with USE=\"qt3support\""
46 src_compile() {
47 # growl is mac osx extension only - maybe someday we will want this
48 local myconf="--disable-growl --disable-bundled-qca"
49 use kernel_linux || myconf="${myconf} --disable-dnotify"
50 use ssl || myconf="${myconf} --disable-openssl"
51 use spell || myconf="${myconf} --disable-aspell"
52 use xscreensaver || myconf="${myconf} --disable-xss"
54 QTDIR=/usr/$(get_libdir) ./configure \
55 --prefix=/usr ${myconf} \
56 || die "configure failed"
58 eqmake4 ${PN}.pro
59 emake || die "emake failed"
61 if use doc; then
62 cd doc
63 make api_public || die "make api_public failed"
67 src_install() {
68 emake INSTALL_ROOT="${D}" install || die "emake install failed"
70 # this way the docs will be installed in the standard gentoo dir
71 newdoc iconsets/roster/README README.roster
72 newdoc iconsets/system/README README.system
73 newdoc certs/README README.certs
74 dodoc README
76 if use doc; then
77 cd doc
78 dohtml -r api || die "dohtml failed"