SoQt-1.4.1-r1: check for qt3support when USE="qt4".
[underlay.git] / media-libs / SoQt / SoQt-1.4.1-r1.ebuild
blobb5853546d8a05528905fcd8ca64918cb82928ebf
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/media-libs/SoQt/SoQt-1.4.1.ebuild,v 1.1 2007/10/21 13:19:51 carlo Exp $
5 EAPI=1
7 inherit flag-o-matic eutils
9 DESCRIPTION="SoQt provides the glue between Coin high-level 3D visualization library and Qt 2D GUI library"
10 SRC_URI="ftp://ftp.coin3d.org/pub/coin/src/all/${P}.tar.gz"
11 HOMEPAGE="http://www.coin3d.org/"
13 SLOT="0"
14 LICENSE="|| ( GPL-2 PEL )"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="doc qt4"
18 RDEPEND="qt4? ( x11-libs/qt:4 )
19 !qt4? ( x11-libs/qt:3 )
20 >=media-libs/coin-2.4.4"
21 DEPEND="${RDEPEND}
22 doc? ( app-doc/doxygen )"
24 use qt4 && QT4_BUILT_WITH_USE_CHECK="qt3support"
26 src_compile() {
27 if use qt4; then
28 export QTDIR="/usr"
29 export PATH="/usr/bin/:${PATH}"
30 append-ldflags $(pkg-config --libs QtCore QtGui)
31 else
32 export QTDIR="/usr/qt/3"
35 filter-ldflags -Wl,--as-needed
37 econf --with-coin \
38 --disable-html-help \
39 $(use_enable doc html) \
40 htmldir="${ROOT}"usr/share/doc/${PF}/html \
41 || die "configure failed"
43 emake || die "emake failed"
46 src_install() {
47 emake DESTDIR="${D}" install || die "installation failed"
48 dodoc AUTHORS BUGS.txt ChangeLog FAQ NEWS README