1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
10 DESCRIPTION
="TLS, S/MIME, PKCS#12, crypto algorithms plugin for QCA"
11 HOMEPAGE
="http://delta.affinix.com/qca/"
12 SRC_URI
="http://delta.affinix.com/download/qca/${QCA_VER/-*/}/${QCA_VER/*-/}/${MY_P}.tar.bz2"
16 KEYWORDS
="~amd64 ~x86"
19 RDEPEND
="=app-crypt/qca-2*
23 S
="${WORKDIR}/${MY_P}"
26 if use debug
&& ! built_with_use
'=app-crypt/qca-2*' debug
; then
28 einfo
"You are trying to compile ${PN} package with active USE=\"debug\""
29 einfo
"while qca is build without this particular flag. It will not"
32 einfo
"Possible solutions to this problem are:"
33 einfo
"a) install package ${PN} without debug USE flag"
34 einfo
"b) re-emerge qca with debug USE flag"
36 die
"can't emerge ${PN} with debug USE flag"
41 local myconf
="--release"
42 use debug
&& myconf
="--debug"
46 --no-separate-debug-info \
47 ${myconf} || die
"configure failed"
50 emake || die
"emake failed"
54 emake INSTALL_ROOT
="${D}" install || die
"emake install failed"