New ebuilds: net-im/psi-0.13_rc1 and net-libs/psimedia-1.0.2.
[underlay.git] / net-im / psi / psi-0.13_rc1.ebuild
blob05232ee92ba0384f6377bdd3393e46918c07667d
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 EAPI="2"
7 inherit eutils multilib qt4
9 MY_P=${P/_/-}
10 LANGPACK_VER="20090217"
12 DESCRIPTION="Qt4 Jabber client, with Licq-like interface"
13 HOMEPAGE="http://psi-im.org/"
14 SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2
15 mirror://gentoo/${PN}-langs-${LANGPACK_VER}.tar.bz2"
17 LICENSE="GPL-2"
18 SLOT="0"
19 KEYWORDS="~amd64 ~x86"
20 IUSE="crypt dbus debug doc jingle spell ssl xscreensaver"
21 RESTRICT="test"
23 LANGS="cs de eo es_ES fr it mk pl pt_BR ru uk ur_PK vi zh zh_TW"
24 for LNG in ${LANGS}; do
25 IUSE="${IUSE} linguas_${LNG}"
26 #SRC_URI="${SRC_URI} http://psi-im.org/download/lang/psi_${LNG/ur_PK/ur_pk}.qm"
27 done
29 RDEPEND=">=x11-libs/qt-gui-4.4:4[qt3support,dbus?]
30 app-crypt/qca:2
31 spell? ( app-text/aspell )
32 xscreensaver? ( x11-libs/libXScrnSaver )"
33 DEPEND="${RDEPEND}
34 doc? ( app-doc/doxygen )"
35 PDEPEND="crypt? ( app-crypt/qca-gnupg:2 )
36 jingle? ( net-libs/psimedia )
37 ssl? ( app-crypt/qca-ossl:2 )"
39 S="${WORKDIR}"/${MY_P}
41 src_configure() {
42 # cannot use econf because of non-standard configure script
43 # disable growl as it is a MacOS X extension only
44 local confcmd="./configure
45 --prefix=/usr
46 --qtdir=/usr
47 --disable-bundled-qca
48 --disable-growl
49 $(use dbus || echo '--disable-qdbus')
50 $(use debug && echo '--enable-debug')
51 $(use spell || echo '--disable-aspell')
52 $(use xscreensaver || echo '--disable-xss')"
54 echo ${confcmd}
55 ${confcmd} || die "configure failed"
57 eqmake4
60 src_compile() {
61 SUBLIBS="-L/usr/$(get_libdir)/qca2" emake || die "emake failed"
63 if use doc; then
64 cd doc && mkdir -p api # 259632
65 einfo "Generating API documentation"
66 make api_public || die "make api_public failed"
70 src_install() {
71 emake INSTALL_ROOT="${D}" install || die "emake install failed"
73 # this way the docs will be installed in the standard gentoo dir
74 newdoc iconsets/roster/README README.roster || die
75 newdoc iconsets/system/README README.system || die
76 newdoc certs/README README.certs || die
77 dodoc README || die
79 if use doc; then
80 cd doc
81 dohtml -r api || die "dohtml failed"
84 # install translations
85 cd "${WORKDIR}"/${PN}-langs
86 insinto /usr/share/${PN}
87 for LNG in ${LANGS}; do
88 if use linguas_${LNG}; then
89 doins ${PN}_${LNG/ur_PK/ur_pk}.qm || die
91 done