Updated net-im/psi SVN snapshot.
[underlay.git] / media-sound / qmpdclient / qmpdclient-1.0.8.ebuild
blobd0903c0a4e214ce7aec345818152d66d2b6406ce
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/media-sound/qmpdclient/qmpdclient-1.0.8.ebuild,v 1.4 2007/08/01 03:59:24 angelos Exp $
5 inherit eutils qt4
7 DESCRIPTION="An easy to use MPD client written in Qt4"
8 HOMEPAGE="http://havtknut.tihlde.org/qmpdclient"
9 SRC_URI="http://havtknut.tihlde.org/${PN}/files/${P}.tar.gz"
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~hppa ~ppc ~x86"
14 IUSE="dbus"
16 DEPEND="$(qt4_min_version 4.2)"
18 RDEPEND="${DEPEND}
19 dbus? ( >=sys-apps/dbus-1.0.2 )"
21 pkg_setup() {
22 if use dbus && ! built_with_use x11-libs/qt dbus ; then
23 echo
24 eerror "In order to enable dbus notifications support in qmpdclient"
25 eerror "you have to rebuild qt4 with 'dbus' USE flag enabled."
26 echo
27 die "Re-emerge qt4 with USE=\"dbus\""
31 src_unpack() {
32 unpack ${A}
33 cd "${S}"
35 # Fix a crasher for amd64 and possibly others. Bug #183593.
36 epatch "${FILESDIR}"/${PV}-argc-ref-fix.patch
38 # Fix the install path
39 sed -i -e "s:PREFIX = /usr/local:PREFIX = /usr:" qmpdclient.pro \
40 || die 'sed failed'
42 # Disable dbus notifications if USE="-dbus"
43 use dbus || epatch "${FILESDIR}"/${PN}-no-dbus.patch
46 src_compile() {
47 eqmake4 qmpdclient.pro
48 emake || die "make failed"
51 src_install() {
52 dodoc README AUTHORS THANKSTO Changelog
53 for res in 16 22 32 64 128 ; do
54 insinto /usr/share/icons/hicolor/${res}x${res}/apps/
55 newins icons/qmpdclient${res}.png ${PN}.png
56 done
58 dobin qmpdclient || die "dobin failed"
59 make_desktop_entry qmpdclient "QMPDClient" ${PN} "Qt;AudioVideo;Audio"