debian: ugit is now debianized
[ugit.git] / debian / rules
bloba10569a652a6d6e92e6a5f885fea9449726e714d
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
9 # Uncomment this to turn on verbose mode.
10 #export DH_VERBOSE=1
12 # We run configure + make install twice:
13 # once for every supported Python version
14 configure: configure-stamp
15 configure-stamp:
16 ./configure \
17 --prefix=/usr \
18 --blddir=$(CURDIR)/debian/bld \
19 --destdir=$(CURDIR)/debian/ugit
21 build: build-stamp
22 build-stamp: configure-stamp
23 $(MAKE)
25 clean:
26 dh_testdir
27 dh_testroot
28 dh_clean
30 install: build
32 # Build architecture-independent files here.
33 binary-indep: build install
34 dh_testdir
35 dh_testroot
36 dh_clean -k
37 dh_installdirs
38 $(MAKE) DESTDIR=$(CURDIR)/debian/ugit install
39 dh_fixperms
40 dh_installdeb
41 dh_gencontrol
42 dh_md5sums
43 dh_builddeb
45 binary: binary-indep
46 .PHONY: build clean binary-indep binary install configure