Merge branch 'l10n'
[trojita.git] / trojita.spec
bloba94873872aac573680888d7c37d78de6997e4025
2 # spec file for package trojita
4 # Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
6 # All modifications and additions to the file contributed by third parties
7 # remain the property of their copyright owners, unless otherwise agreed
8 # upon. The license for this file, and modifications and additions to the
9 # file, is the same license as for the pristine package itself (unless the
10 # license for the pristine package is not an Open Source License, in which
11 # case the license is the MIT License). An "Open Source License" is a
12 # license that conforms to the Open Source Definition (Version 1.9)
13 # published by the Open Source Initiative.
15 # Please submit bugfixes or comments via http://bugs.opensuse.org/
18 Name: trojita
19 Version: 0.3
20 Release: 1
21 # Almost everything: dual-licensed under the GPLv2 or GPLv3
22 # src/src/XtConnect: BSD
23 # src/Imap/Parser/3rdparty/kcodecs.*: LGPLv2
24 # src/Imap/Parser/3rdparty/qmailcodec.*: LGPLv2.1 or GPLv3
25 # src/Imap/Parser/3rdparty/rfccodecs.cpp: LGPLv2+
26 # src/qwwsmtpclient/: GPLv2
27 License: (GPLv2 or GPLv3) and BSD and LGPLv2 and (LGPLv2.1 or GPLv3) and LGPLv2+ and GPLv2
28 Summary: Qt IMAP e-mail client
29 Url: http://trojita.flaska.net/
30 Group: Productivity/Networking/Email/Clients
31 Source: http://sourceforge.net/projects/trojita/files/src/%{name}-%{version}.tar.bz2
32 %if 0%{?fedora}
33 BuildRequires: qt-webkit-devel >= 4.6
34 BuildRequires: libstdc++-devel gcc-c++
35 %define qmake_command qmake-qt4
36 %endif
37 %if 0%{?rhel_version} || 0%{?centos_version}
38 BuildRequires: qtwebkit-devel >= 4.6
39 BuildRequires: libstdc++-devel gcc-c++
40 %define qmake_command qmake-qt4
41 %endif
42 %if 0%{?suse_version} || 0%{?sles_version}
43 BuildRequires: pkgconfig(QtGui) >= 4.6
44 BuildRequires: pkgconfig(QtWebKit) >= 4.6
45 BuildRequires: libQtWebKit-devel
46 BuildRequires: update-desktop-files
47 %define qmake_command qmake
48 %endif
49 BuildRoot: %{_tmppath}/%{name}-%{version}-build
51 %description
52 Trojita is a Qt IMAP e-mail client:
53 * a pure Qt4 application with no additional dependencies
54 * robust IMAP core implemented using Qt's Model-View framework
55 * standards compliance is a design goal
56 * on-demand message list and body part loading
57 * offline IMAP support (you can access data you already have; there's no complete "offline mail access" yet, though)
58 * support for bandwidth-saving mode aimed at mobile users with expensive connection
59 * IMAP over SSH -- in addition to usual SSL/TLS connections, the server could be accessed via SSH
60 * safe dealing with HTML mail (actually more robust than Thunderbird's)
62 %prep
63 %setup -q
65 %build
66 %qmake_command CONFIG+=debug PREFIX=/usr
67 make %{?_smp_mflags}
69 %install
70 make %{?_smp_mflags} INSTALL_ROOT=%{buildroot} install
71 %if 0%{?suse_version} || 0%{?sles_version}
72 %suse_update_desktop_file %{buildroot}/%{_datadir}/applications/trojita.desktop
73 %endif
75 %clean
76 %{?buildroot:rm -rf "%{buildroot}"}
78 %files
79 %defattr(-,root,root)
80 %doc LICENSE README
81 %{_bindir}/trojita
82 %{_datadir}/applications/trojita.desktop
83 %dir %{_datadir}/icons/hicolor
84 %dir %{_datadir}/icons/hicolor/*
85 %dir %{_datadir}/icons/hicolor/*/apps
86 %{_datadir}/icons/hicolor/32x32/apps/trojita.png
87 %{_datadir}/icons/hicolor/scalable/apps/trojita.svg
89 %check
90 make test
92 %changelog