Let's call this the 0.3.93 -- too many changes are in already
[trojita.git] / packaging / obs-trojita / trojita.spec
blobefdfcaaa20cf925eb2b80ee2048368180f8b7355
2 # spec file for package trojita
4 # Copyright (c) 2011 SUSE LINUX Products GmbH, Nuernberg, Germany.
6 # All modifications and additions to the file contributed by third parties
7 # remain the property of their copyright owners, unless otherwise agreed
8 # upon. The license for this file, and modifications and additions to the
9 # file, is the same license as for the pristine package itself (unless the
10 # license for the pristine package is not an Open Source License, in which
11 # case the license is the MIT License). An "Open Source License" is a
12 # license that conforms to the Open Source Definition (Version 1.9)
13 # published by the Open Source Initiative.
15 # Please submit bugfixes or comments via http://bugs.opensuse.org/
18 Name: trojita
19 Version: 0.3.93
20 Release: 1
21 # Almost everything: dual-licensed under the GPLv2 or GPLv3
22 # (with KDE e.V. provision for relicensing)
23 # src/XtConnect: BSD
24 # src/Imap/Parser/3rdparty/kcodecs.*: LGPLv2
25 # Nokia imports: LGPLv2.1 or GPLv3
26 # src/Imap/Parser/3rdparty/rfccodecs.cpp: LGPLv2+
27 # src/qwwsmtpclient/: GPLv2
28 License: (GPLv2 or GPLv3) and BSD and LGPLv2 and (LGPLv2.1 or GPLv3) and LGPLv2+ and GPLv2
29 Summary: Qt IMAP e-mail client
30 Url: http://trojita.flaska.net/
31 Group: Productivity/Networking/Email/Clients
32 Source: http://sourceforge.net/projects/trojita/files/src/%{name}-%{version}.tar.bz2
33 %if 0%{?fedora}
34 BuildRequires: qt-webkit-devel >= 4.6
35 BuildRequires: libstdc++-devel gcc-c++
36 BuildRequires: xorg-x11-server-Xvfb
37 %define qmake_command qmake-qt4
38 %endif
39 %if 0%{?rhel_version} || 0%{?centos_version}
40 BuildRequires: qtwebkit-devel >= 2.1
41 BuildRequires: libstdc++-devel gcc-c++
42 BuildRequires: xorg-x11-server-Xvfb
43 %define qmake_command qmake-qt4
44 %endif
45 %if 0%{?suse_version} || 0%{?sles_version}
46 BuildRequires: pkgconfig(QtGui) >= 4.6
47 BuildRequires: pkgconfig(QtWebKit) >= 4.6
48 BuildRequires: libQtWebKit-devel
49 BuildRequires: update-desktop-files
50 BuildRequires: xorg-x11-Xvfb xkeyboard-config
51 %define qmake_command qmake
52 %endif
53 %define X_display ":98"
54 BuildRoot: %{_tmppath}/%{name}-%{version}-build
56 %description
57 Trojita is a Qt IMAP e-mail client which:
58 * Enables you to access your mail anytime, anywhere.
59 * Does not slow you down. If we can improve the productivity of an e-mail user, we better do.
60 * Respects open standards and facilitates modern technologies. We value the vendor-neutrality that IMAP provides and are committed to be as interoperable as possible.
61 * Is efficient — be it at conserving the network bandwidth, keeping memory use at a reasonable level or not hogging the system's CPU.
62 * Can be used on many platforms. One UI is not enough for everyone, but our IMAP core works fine on anything from desktop computers to cell phones and big ERP systems.
63 * Plays well with the rest of the ecosystem. We don't like reinventing wheels, but when the existing wheels quite don't fit the tracks, we're not afraid of making them work.
65 %prep
66 %setup -q
68 %build
69 %qmake_command CONFIG+=debug PREFIX=/usr
70 make %{?_smp_mflags}
72 %install
73 make %{?_smp_mflags} INSTALL_ROOT=%{buildroot} install
74 %if 0%{?suse_version} || 0%{?sles_version}
75 %suse_update_desktop_file %{buildroot}/%{_datadir}/applications/trojita.desktop
76 %endif
78 %clean
79 %{?buildroot:rm -rf "%{buildroot}"}
81 %files
82 %defattr(-,root,root)
83 %doc LICENSE README
84 %{_bindir}/trojita
85 %{_datadir}/applications/trojita.desktop
86 %dir %{_datadir}/icons/hicolor
87 %dir %{_datadir}/icons/hicolor/*
88 %dir %{_datadir}/icons/hicolor/*/apps
89 %{_datadir}/icons/hicolor/32x32/apps/trojita.png
90 %{_datadir}/icons/hicolor/scalable/apps/trojita.svg
91 %dir %{_datadir}/trojita
92 %dir %{_datadir}/trojita/locale
93 %{_datadir}/trojita/locale/trojita_common_*.qm
95 %check
96 export DISPLAY=%{X_display}
97 Xvfb %{X_display} &
98 trap "kill $! || true" EXIT
99 make test
101 %changelog