Merge branch 'master' of ssh://git@git-rw.torproject.org/tor
[tor/rransom.git] / debian / patches / 02_add_debian_files_in_manpage.dpatch
blobac87f438212558d60909e3e618d4d25fbf1f4976
1 #! /bin/sh -e
2 ## 02_add_debian_files_in_manpage.dpatch by <weasel@debian.org>
3 ##
4 ## All lines beginning with `## DP:' are a description of the patch.
5 ## DP: Change the FILES section of the manpage to properly describe the situation on Debian systems.
7 if [ $# -lt 1 ]; then
8 echo "`basename $0`: script expects -patch|-unpatch as argument" >&2
9 exit 1
12 [ -f debian/patches/00patch-opts ] && . debian/patches/00patch-opts
13 patch_opts="${patch_opts:--f --no-backup-if-mismatch} ${2:+-d $2}"
15 case "$1" in
16 -patch) patch -p1 ${patch_opts} < $0;;
17 -unpatch) patch -R -p1 ${patch_opts} < $0;;
19 echo "`basename $0`: script expects -patch|-unpatch as argument" >&2
20 exit 1;;
21 esac
23 exit 0
25 @DPATCH@
26 diff -urNad tor-0.1.1.5/doc/tor.1.in /tmp/dpep.E9VjWB/tor-0.1.1.5/doc/tor.1.in
27 --- tor-0.1.1.12/doc/tor.1.in
28 +++ /tmp/dpep.E9VjWB/tor-0.1.1.12/doc/tor.1.in
29 @@ -700,9 +700,15 @@
30 .TP
31 .B @LOCALSTATEDIR@/lib/tor/
32 The tor process stores keys and other data here.
33 +.TP
34 +.B /var/log/tor/
35 +The tor server logs to this directory.
36 +.TP
37 +.B /var/run/tor/tor.pid
38 +The PID of the tor (master) process is stored in this file.
39 .LP
40 .TP
41 -.B \fIDataDirectory\fP/approved-routers
42 +.B /var/lib/tor/approved-routers
43 Only for naming authoritative directory servers
44 (see \fBNamingAuthoritativeDirectory\fP).
45 This file lists nickname to identity bindings. Each line lists a