3 # Sample debian/rules that uses debhelper.
4 # GNU copyright 1997 to 1999 by Joey Hess.
6 # Uncomment this to turn on verbose mode.
9 # These are used for cross-compiling and for saving the configure script
10 # from having to guess our platform (since we know it already)
11 DEB_HOST_GNU_TYPE ?
= $(shell dpkg-architecture
-qDEB_HOST_GNU_TYPE
)
12 DEB_BUILD_GNU_TYPE ?
= $(shell dpkg-architecture
-qDEB_BUILD_GNU_TYPE
)
17 include /usr
/share
/dpatch
/dpatch.make
19 ifneq (,$(findstring noopt
,$(DEB_BUILD_OPTIONS
)))
24 #ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
25 # INSTALL_PROGRAM += -s
28 configure
: patch-stamp
29 config.status
: configure
31 CFLAGS
="$(CFLAGS)" .
/configure \
32 --host
=$(DEB_HOST_GNU_TYPE
) \
33 --build
=$(DEB_BUILD_GNU_TYPE
) \
35 --mandir=\
$${prefix}/share
/man \
36 --infodir=\
$${prefix}/share
/info \
37 --localstatedir
=/var \
43 build-stamp
: config.status
69 $(MAKE
) install DESTDIR
=$(CURDIR
)/debian
/tor
70 # move tor to where it belongs
71 mv
$(CURDIR
)/debian
/tor
/etc
/tor
/torrc.sample
$(CURDIR
)/debian
/tor
/etc
/tor
/torrc
72 mv
$(CURDIR
)/debian
/tor
/usr
/bin
/tor
$(CURDIR
)/debian
/tor
/usr
/sbin
/tor
73 install -m
755 contrib
/torify
$(CURDIR
)/debian
/tor
/usr
/bin
74 install -m
644 contrib
/torify
.1 $(CURDIR
)/debian
/tor
/usr
/share
/man
/man1
75 install -m
644 contrib
/tor-tsocks.conf
$(CURDIR
)/debian
/tor
/etc
/tor
77 install -m
644 debian
/tor.lintian-override
$(CURDIR
)/debian
/tor
/usr
/share
/lintian
/overrides
/tor
80 # Build architecture-independent files here.
81 binary-indep
: build
install
82 # We have nothing to do by default.
84 # Build architecture-dependent files here.
85 binary-arch
: build
install
88 dh_installchangelogs ChangeLog
109 binary
: binary-indep binary-arch
110 .PHONY
: build
clean binary-indep binary-arch binary
install