Document the rest of main.c
[tor.git] / debian / rules
blob31aeb9ddb51900ea9f3cb25314890953cc2ef02e
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Sample debian/rules that uses debhelper.
4 # GNU copyright 1997 to 1999 by Joey Hess.
6 # Uncomment this to turn on verbose mode.
7 #export DH_VERBOSE=1
9 # These are used for cross-compiling and for saving the configure script
10 # from having to guess our platform (since we know it already)
11 DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
12 DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
14 CFLAGS = -Wall -g
16 export PACKAGE=tor
17 include /usr/share/dpatch/dpatch.make
19 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
20 CFLAGS += -O0
21 else
22 CFLAGS += -O2
23 endif
24 #ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
25 # INSTALL_PROGRAM += -s
26 #endif
28 configure: patch-stamp
29 config.status: configure
30 dh_testdir
31 CFLAGS="$(CFLAGS)" ./configure \
32 --host=$(DEB_HOST_GNU_TYPE) \
33 --build=$(DEB_BUILD_GNU_TYPE) \
34 --prefix=/usr \
35 --mandir=\$${prefix}/share/man \
36 --infodir=\$${prefix}/share/info \
37 --localstatedir=/var \
38 --sysconfdir=/etc
41 build: build-stamp
43 build-stamp: config.status
44 dh_testdir
46 $(MAKE)
47 @echo
48 @echo
49 src/or/test
50 @echo
52 touch build-stamp
54 clean: unpatch
55 dh_testdir
56 dh_testroot
57 rm -f build-stamp
59 -$(MAKE) distclean
61 dh_clean
63 install: build
64 dh_testdir
65 dh_testroot
66 dh_clean -k
67 dh_installdirs
69 $(MAKE) install DESTDIR=$(CURDIR)/debian/tor
70 # move tor to where it belongs
71 mv $(CURDIR)/debian/tor/etc/tor/torrc.sample $(CURDIR)/debian/tor/etc/tor/torrc
72 mv $(CURDIR)/debian/tor/usr/bin/tor $(CURDIR)/debian/tor/usr/sbin/tor
73 install -m 755 contrib/torify $(CURDIR)/debian/tor/usr/bin
74 install -m 644 contrib/torify.1 $(CURDIR)/debian/tor/usr/share/man/man1
75 install -m 644 contrib/tor-tsocks.conf $(CURDIR)/debian/tor/etc/tor
77 install -m 644 debian/tor.lintian-override $(CURDIR)/debian/tor/usr/share/lintian/overrides/tor
80 # Build architecture-independent files here.
81 binary-indep: build install
82 # We have nothing to do by default.
84 # Build architecture-dependent files here.
85 binary-arch: build install
86 dh_testdir
87 dh_testroot
88 dh_installchangelogs ChangeLog
89 dh_installdocs
90 dh_installexamples
91 # dh_install
92 # dh_installdebconf
93 dh_installlogrotate
94 # dh_installemacsen
95 # dh_installmime
96 dh_installinit
97 # dh_installcron
98 dh_installman
99 dh_link
100 #dh_strip
101 dh_compress
102 dh_fixperms
103 dh_installdeb
104 dh_shlibdeps
105 dh_gencontrol
106 dh_md5sums
107 dh_builddeb
109 binary: binary-indep binary-arch
110 .PHONY: build clean binary-indep binary-arch binary install