"fix" the unit tests on openbsd/netbsd
[tor.git] / debian / rules
blob9ac9da1706f4cd51140ef71e59e4ee9dc0521baa
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Sample debian/rules that uses debhelper.
4 # GNU copyright 1997 to 1999 by Joey Hess.
6 # Uncomment this to turn on verbose mode.
7 #export DH_VERBOSE=1
9 export PACKAGE=tor
10 include /usr/share/dpatch/dpatch.make
12 # These are used for cross-compiling and for saving the configure script
13 # from having to guess our platform (since we know it already)
15 # See /usr/share/doc/autotools-dev/README.Debian.gz which suggests
16 # this way of passing --build and --host. Also see the thread on
17 # debian-devel './configure in debian/rules' from February/March 2006,
18 # starting with <43FF212C.5020800@xs4all.nl> by Pjotr Kourzanov.
19 export DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
20 export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
21 ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
22 confflags += --build $(DEB_HOST_GNU_TYPE)
23 else
24 confflags += --build $(DEB_BUILD_GNU_TYPE) --host $(DEB_HOST_GNU_TYPE)
25 endif
27 CFLAGS ?= -Wall -g
29 LOCALHOST_IP ?= $(shell getent hosts localhost | awk '{print $$1}')
31 # Do not optimize the build with "noopt"
32 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
33 CFLAGS += -O0
34 else
35 CFLAGS += -O2
36 endif
38 # Do not strip the binary with "nostrip"
39 #ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
40 # INSTALL_PROGRAM += -s
41 #endif
43 # Prevent the unit tests from being run with "nocheck"
44 ifneq (,$(findstring nocheck,$(DEB_BUILD_OPTIONS)))
45 RUN_TEST = no
46 endif
47 ifneq (,$(findstring notest,$(DEB_BUILD_OPTIONS)))
48 RUN_TEST = no
49 endif
51 CONF_OPTIONS =
52 # build against libdmalloc4 - it better be installed
53 ifneq (,$(findstring with-dmalloc,$(DEB_BUILD_OPTIONS)))
54 CONF_OPTIONS += --with-dmalloc
55 endif
57 configure: patch-stamp
58 config.status: configure
59 @if [ "$(LOCALHOST_IP)" != "127.0.0.1" ]; then echo; echo; echo; echo; echo; echo "######################################################################"; echo "WARNING: This system does not think localhost is 127.0.0.1. Will ignore result of testsuite. Please fix your system/chroot."; echo "######################################################################"; echo; echo; echo; echo; echo "Note: 'getent hosts localhost' should return '127.0.0.1 localhost'"; echo; fi
60 dh_testdir
61 CFLAGS="$(CFLAGS)" ./configure \
62 $(confflags) \
63 --prefix=/usr \
64 --mandir=\$${prefix}/share/man \
65 --infodir=\$${prefix}/share/info \
66 --localstatedir=/var \
67 --sysconfdir=/etc \
68 $(CONF_OPTIONS)
71 build: build-stamp
73 build-stamp: config.status
74 dh_testdir
76 $(MAKE)
77 @echo
78 @echo
79 # Running unit tests
80 @if [ "$(RUN_TEST)" != "no" ]; then \
81 if [ "$(LOCALHOST_IP)" != "127.0.0.1" ]; then \
82 echo; echo; echo "######################################################################"; echo "WARNING: This system does not think localhost is 127.0.0.1. Will ignore result of testsuite. Please fix your system/chroot."; echo "######################################################################"; echo; echo; \
83 echo "src/or/test || true"; \
84 src/or/test || true; \
85 else \
86 echo "src/or/test"; \
87 src/or/test; \
88 fi; \
89 else \
90 echo -e "\n\nSkipping unittests\n\n"; \
92 @echo
94 # XXX
95 # So, gs-gpl on s390 is broken (#457568) and fails to properly build
96 # .pdf files from .fig files using fig2dev. Therefore we ship them
97 # until this bug is fixed.
99 # of course we can always give it a try
101 # the hexdumps were built using something like
102 # perl -e 'while (<>) { print unpack ("H*", $_); }' interaction.pdf | fold > hexdump-interaction.pdf
103 if [ "$(DEB_BUILD_GNU_TYPE)" = "s390-linux-gnu" ] || \
104 [ "$(DEB_BUILD_GNU_TYPE)" = "sparc-linux-gnu" ] || \
105 [ "$(DEB_BUILD_GNU_TYPE)" = "mipsel-linux" ]; then \
106 cd doc/design-paper; \
107 fig2dev -L pdf cell-struct.fig cell-struct.pdf || \
108 ( echo "** Using shipped pdf file because fig2dev failed"; \
109 perl -e 'while (<>) { chomp; print pack ("H*", $$_); }' ../../debian/hexdump-cell-struct.pdf > cell-struct.pdf ); \
110 fig2dev -L pdf interaction.fig interaction.pdf || \
111 ( echo "** Using shipped pdf file because fig2dev failed"; \
112 perl -e 'while (<>) { chomp; print pack ("H*", $$_); }' ../../debian/hexdump-interaction.pdf > interaction.pdf ); \
114 # XXX ends
116 make -C doc/design-paper tor-design.ps tor-design.pdf
118 touch build-stamp
120 clean: unpatch
121 dh_testdir
122 dh_testroot
123 rm -f build-stamp
125 -$(MAKE) distclean
127 dh_clean
129 install: build
130 dh_testdir
131 dh_testroot
132 dh_clean -k
133 dh_installdirs
135 $(MAKE) install DESTDIR=$(CURDIR)/debian/tor
136 # move tor to where it belongs
137 mv $(CURDIR)/debian/tor/etc/tor/torrc.sample $(CURDIR)/debian/tor/etc/tor/torrc
138 mv $(CURDIR)/debian/tor/usr/bin/tor $(CURDIR)/debian/tor/usr/sbin/tor
139 install -d $(CURDIR)/debian/tor/usr/share/man/man8
140 mv $(CURDIR)/debian/tor/usr/share/man/man1/tor.1 $(CURDIR)/debian/tor/usr/share/man/man8/tor.8
142 install -m 755 contrib/torify $(CURDIR)/debian/tor/usr/bin
143 install -m 644 contrib/torify.1 $(CURDIR)/debian/tor/usr/share/man/man1
144 install -m 644 contrib/tor-tsocks.conf $(CURDIR)/debian/tor/etc/tor
146 install -m 644 debian/tor.lintian-override $(CURDIR)/debian/tor/usr/share/lintian/overrides/tor
148 install -d -m 755 $(CURDIR)/debian/tor/usr/share/doc/tor/spec
149 for i in doc/spec/*txt; do \
150 install -m 644 $$i $(CURDIR)/debian/tor/usr/share/doc/tor/spec || exit 1; \
151 done
153 dh_link usr/share/man/man8/tor.8 usr/share/man/man5/torrc.5
155 rm -f $(CURDIR)/debian/tor/usr/bin/tor-control.py
157 install -d -m 755 $(CURDIR)/debian/tor-dbg/usr/share/doc
158 ln -s tor $(CURDIR)/debian/tor-dbg/usr/share/doc/tor-dbg
161 # Build architecture-independent files here.
162 binary-indep: build install
163 # We have nothing to do by default.
165 # Build architecture-dependent files here.
166 binary-arch: build install
167 dh_testdir
168 dh_testroot
169 dh_installchangelogs ChangeLog
170 dh_installdocs
171 dh_installexamples
172 # dh_install
173 # dh_installdebconf
174 dh_installlogrotate
175 # dh_installemacsen
176 # dh_installmime
177 dh_installinit
178 # dh_installcron
179 dh_installman
180 dh_link
181 # Change this for debhelper compatibility level 5 or later!
182 dh_strip --dbg-package=tor
183 dh_compress
184 dh_fixperms
185 dh_installdeb
186 dh_shlibdeps
187 dh_gencontrol
188 dh_md5sums
189 dh_builddeb
190 @if [ "$(LOCALHOST_IP)" != "127.0.0.1" ]; then echo; echo; echo; echo; echo; echo "######################################################################"; echo "WARNING: This system does not think localhost is 127.0.0.1. Result of testsuite has been ignored. Please fix your system/chroot."; echo "######################################################################"; echo; echo; echo; echo; echo "Note: 'getent hosts localhost' should return '127.0.0.1 localhost'"; echo; fi
192 binary: binary-indep binary-arch
193 .PHONY: build clean binary-indep binary-arch binary install