3 # Sample debian/rules that uses debhelper.
4 # GNU copyright 1997 to 1999 by Joey Hess.
6 # Uncomment this to turn on verbose mode.
10 include /usr
/share
/dpatch
/dpatch.make
12 # These are used for cross-compiling and for saving the configure script
13 # from having to guess our platform (since we know it already)
15 # See /usr/share/doc/autotools-dev/README.Debian.gz which suggests
16 # this way of passing --build and --host. Also see the thread on
17 # debian-devel './configure in debian/rules' from February/March 2006,
18 # starting with <43FF212C.5020800@xs4all.nl> by Pjotr Kourzanov.
19 export DEB_HOST_GNU_TYPE ?
= $(shell dpkg-architecture
-qDEB_HOST_GNU_TYPE
)
20 export DEB_BUILD_GNU_TYPE ?
= $(shell dpkg-architecture
-qDEB_BUILD_GNU_TYPE
)
21 ifeq ($(DEB_BUILD_GNU_TYPE
), $(DEB_HOST_GNU_TYPE
))
22 confflags
+= --build
$(DEB_HOST_GNU_TYPE
)
24 confflags
+= --build
$(DEB_BUILD_GNU_TYPE
) --host
$(DEB_HOST_GNU_TYPE
)
29 LOCALHOST_IP ?
= $(shell getent hosts localhost | awk
'{print $$1}')
31 # Do not optimize the build with "noopt"
32 ifneq (,$(findstring noopt
,$(DEB_BUILD_OPTIONS
)))
38 # Do not strip the binary with "nostrip"
39 #ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
40 # INSTALL_PROGRAM += -s
43 # Prevent the unit tests from being run with "nocheck"
44 ifneq (,$(findstring nocheck
,$(DEB_BUILD_OPTIONS
)))
47 ifneq (,$(findstring notest
,$(DEB_BUILD_OPTIONS
)))
52 # build against libdmalloc4 - it better be installed
53 ifneq (,$(findstring with-dmalloc
,$(DEB_BUILD_OPTIONS
)))
54 CONF_OPTIONS
+= --with-dmalloc
57 configure
: patch-stamp
58 config.status
: configure
59 @if
[ "$(LOCALHOST_IP)" != "127.0.0.1" ]; then echo
; echo
; echo
; echo
; echo
; echo
"######################################################################"; echo
"WARNING: This system does not think localhost is 127.0.0.1. Will ignore result of testsuite. Please fix your system/chroot."; echo
"######################################################################"; echo
; echo
; echo
; echo
; echo
"Note: 'getent hosts localhost' should return '127.0.0.1 localhost'"; echo
; fi
61 CFLAGS
="$(CFLAGS)" .
/configure \
64 --mandir=\
$${prefix}/share
/man \
65 --infodir=\
$${prefix}/share
/info \
66 --localstatedir
=/var \
73 build-stamp
: config.status
80 @if
[ "$(RUN_TEST)" != "no" ]; then \
81 if
[ "$(LOCALHOST_IP)" != "127.0.0.1" ]; then \
82 echo
; echo
; echo
"######################################################################"; echo
"WARNING: This system does not think localhost is 127.0.0.1. Will ignore result of testsuite. Please fix your system/chroot."; echo
"######################################################################"; echo
; echo
; \
83 echo
"src/or/test || true"; \
84 src
/or
/test || true
; \
90 echo
-e
"\n\nSkipping unittests\n\n"; \
95 # So, gs-gpl on s390 is broken (#321435) and fails to properly build
96 # .pdf files from .fig files using fig2dev. Therefore we ship them
97 # until this bug is fixed.
99 # of course we can always give it a try
101 # the hexdumps were built using something like
102 # perl -e 'while (<>) { print unpack ("H*", $_); }' interaction.pdf | fold > hexdump-interaction.pdf
103 if
[ "$(DEB_BUILD_GNU_TYPE)" = "s390-linux-gnu" ]; then \
104 cd doc
/design-paper
; \
105 fig2dev
-L pdf cell-struct.fig cell-struct.pdf || \
106 ( echo
"** Using shipped pdf file because fig2dev failed"; \
107 perl
-e
'while (<>) { chomp; print pack ("H*", $$_); }' ..
/..
/debian
/hexdump-cell-struct.pdf
> cell-struct.pdf
); \
108 fig2dev
-L pdf interaction.fig interaction.pdf || \
109 ( echo
"** Using shipped pdf file because fig2dev failed"; \
110 perl
-e
'while (<>) { chomp; print pack ("H*", $$_); }' ..
/..
/debian
/hexdump-interaction.pdf
> interaction.pdf
); \
114 make
-C doc
/design-paper tor-design.ps tor-design.pdf
133 $(MAKE
) install DESTDIR
=$(CURDIR
)/debian
/tor
134 # move tor to where it belongs
135 mv
$(CURDIR
)/debian
/tor
/etc
/tor
/torrc.sample
$(CURDIR
)/debian
/tor
/etc
/tor
/torrc
136 mv
$(CURDIR
)/debian
/tor
/usr
/bin
/tor
$(CURDIR
)/debian
/tor
/usr
/sbin
/tor
137 install -d
$(CURDIR
)/debian
/tor
/usr
/share
/man
/man8
138 mv
$(CURDIR
)/debian
/tor
/usr
/share
/man
/man1
/tor
.1 $(CURDIR
)/debian
/tor
/usr
/share
/man
/man8
/tor
.8
140 install -m
755 contrib
/torify
$(CURDIR
)/debian
/tor
/usr
/bin
141 install -m
644 contrib
/torify
.1 $(CURDIR
)/debian
/tor
/usr
/share
/man
/man1
142 install -m
644 contrib
/tor-tsocks.conf
$(CURDIR
)/debian
/tor
/etc
/tor
144 install -m
644 debian
/tor.lintian-override
$(CURDIR
)/debian
/tor
/usr
/share
/lintian
/overrides
/tor
146 install -d
-m
755 $(CURDIR
)/debian
/tor
/usr
/share
/doc
/tor
/spec
147 for i in doc
/spec
/*txt
; do \
148 install -m
644 $$i $(CURDIR
)/debian
/tor
/usr
/share
/doc
/tor
/spec || exit
1; \
151 dh_link usr
/share
/man
/man8
/tor
.8 usr
/share
/man
/man5
/torrc
.5
153 rm -f
$(CURDIR
)/debian
/tor
/usr
/bin
/tor-control.py
155 install -d
-m
755 $(CURDIR
)/debian
/tor-dbg
/usr
/share
/doc
156 ln
-s tor
$(CURDIR
)/debian
/tor-dbg
/usr
/share
/doc
/tor-dbg
159 # Build architecture-independent files here.
160 binary-indep
: build
install
161 # We have nothing to do by default.
163 # Build architecture-dependent files here.
164 binary-arch
: build
install
167 dh_installchangelogs ChangeLog
179 # Change this for debhelper compatibility level 5 or later!
180 dh_strip
--dbg-package
=tor
188 @if
[ "$(LOCALHOST_IP)" != "127.0.0.1" ]; then echo
; echo
; echo
; echo
; echo
; echo
"######################################################################"; echo
"WARNING: This system does not think localhost is 127.0.0.1. Result of testsuite has been ignored. Please fix your system/chroot."; echo
"######################################################################"; echo
; echo
; echo
; echo
; echo
"Note: 'getent hosts localhost' should return '127.0.0.1 localhost'"; echo
; fi
190 binary
: binary-indep binary-arch
191 .PHONY
: build
clean binary-indep binary-arch binary
install