Run test after build
[tor.git] / debian / rules
blobaef6fa784a19adf6c44ce07ebab8074014f68fc2
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Sample debian/rules that uses debhelper.
4 # GNU copyright 1997 to 1999 by Joey Hess.
6 # Uncomment this to turn on verbose mode.
7 #export DH_VERBOSE=1
9 # These are used for cross-compiling and for saving the configure script
10 # from having to guess our platform (since we know it already)
11 DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
12 DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
14 CFLAGS = -Wall -g
16 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
17 CFLAGS += -O0
18 else
19 CFLAGS += -O2
20 endif
21 ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
22 INSTALL_PROGRAM += -s
23 endif
25 config.status: configure
26 dh_testdir
27 CFLAGS="$(CFLAGS)" ./configure \
28 --host=$(DEB_HOST_GNU_TYPE) \
29 --build=$(DEB_BUILD_GNU_TYPE) \
30 --prefix=/usr \
31 --mandir=\$${prefix}/share/man \
32 --infodir=\$${prefix}/share/info \
33 --localstatedir=/var \
34 --sysconfdir=/etc
37 build: build-stamp
39 build-stamp: config.status
40 dh_testdir
42 $(MAKE)
43 @echo "Expect one assertion failure during test_buffers."
44 # Right now test doesn't even fail when tests fail, so
45 # no - needed.
46 src/or/test
48 touch build-stamp
50 clean:
51 dh_testdir
52 dh_testroot
53 rm -f build-stamp
55 -$(MAKE) distclean
57 dh_clean
59 install: build
60 dh_testdir
61 dh_testroot
62 dh_clean -k
63 dh_installdirs
65 $(MAKE) install DESTDIR=$(CURDIR)/debian/tor
68 # Build architecture-independent files here.
69 binary-indep: build install
70 # We have nothing to do by default.
72 # Build architecture-dependent files here.
73 binary-arch: build install
74 dh_testdir
75 dh_testroot
76 dh_installchangelogs ChangeLog
77 dh_installdocs
78 dh_installexamples
79 # dh_install
80 # dh_installdebconf
81 dh_installlogrotate
82 # dh_installemacsen
83 # dh_installmime
84 dh_installinit
85 # dh_installcron
86 dh_installman
87 dh_link
88 dh_strip
89 dh_compress
90 dh_fixperms
91 dh_installdeb
92 dh_shlibdeps
93 dh_gencontrol
94 dh_md5sums
95 dh_builddeb
97 binary: binary-indep binary-arch
98 .PHONY: build clean binary-indep binary-arch binary install