3 # Sample debian/rules that uses debhelper.
4 # GNU copyright 1997 to 1999 by Joey Hess.
6 # Uncomment this to turn on verbose mode.
9 # These are used for cross-compiling and for saving the configure script
10 # from having to guess our platform (since we know it already)
11 DEB_HOST_GNU_TYPE ?
= $(shell dpkg-architecture
-qDEB_HOST_GNU_TYPE
)
12 DEB_BUILD_GNU_TYPE ?
= $(shell dpkg-architecture
-qDEB_BUILD_GNU_TYPE
)
16 ifneq (,$(findstring noopt
,$(DEB_BUILD_OPTIONS
)))
21 ifeq (,$(findstring nostrip
,$(DEB_BUILD_OPTIONS
)))
25 config.status
: configure
27 CFLAGS
="$(CFLAGS)" .
/configure \
28 --host
=$(DEB_HOST_GNU_TYPE
) \
29 --build
=$(DEB_BUILD_GNU_TYPE
) \
31 --mandir=\
$${prefix}/share
/man \
32 --infodir=\
$${prefix}/share
/info \
33 --localstatedir
=/var \
39 build-stamp
: config.status
43 @echo
"Expect one assertion failure during test_buffers."
44 # Right now test doesn't even fail when tests fail, so
65 $(MAKE
) install DESTDIR
=$(CURDIR
)/debian
/tor
68 # Build architecture-independent files here.
69 binary-indep
: build
install
70 # We have nothing to do by default.
72 # Build architecture-dependent files here.
73 binary-arch
: build
install
76 dh_installchangelogs ChangeLog
97 binary
: binary-indep binary-arch
98 .PHONY
: build
clean binary-indep binary-arch binary
install