Log at level notice of higher, not warn or higher. Thanks arma
[tor.git] / debian / patches / 05_log_to_file.dpatch
blob75c87f5bf0b3f79e094eb55dd25b4df01fe20e74
1 #! /bin/sh -e
2 ## 05_log_to_file.dpatch by <weasel@debian.org>
3 ##
4 ## All lines beginning with `## DP:' are a description of the patch.
5 ## DP: No description.
7 if [ $# -lt 1 ]; then
8 echo "`basename $0`: script expects -patch|-unpatch as argument" >&2
9 exit 1
12 [ -f debian/patches/00patch-opts ] && . debian/patches/00patch-opts
13 patch_opts="${patch_opts:--f --no-backup-if-mismatch} ${2:+-d $2}"
15 case "$1" in
16 -patch) patch -p1 ${patch_opts} < $0;;
17 -unpatch) patch -R -p1 ${patch_opts} < $0;;
19 echo "`basename $0`: script expects -patch|-unpatch as argument" >&2
20 exit 1;;
21 esac
23 exit 0
25 @DPATCH@
26 diff -urNad cvs/src/config/torrc.sample.in /tmp/dpep.5IEZdW/cvs/src/config/torrc.sample.in
27 --- cvs/src/config/torrc.sample.in 2004-11-10 03:09:14.931082420 +0100
28 +++ /tmp/dpep.5IEZdW/cvs/src/config/torrc.sample.in 2004-11-10 04:34:35.090758448 +0100
29 @@ -19,6 +19,8 @@
31 # Logs go to stdout unless redirected by something else, like one of
32 # the below lines, or --logfile on the command line.
33 +### Send all messages of level 'notice' or higher to @LOCALSTATEDIR@/log/tor/log
34 +Log notice file @LOCALSTATEDIR@/log/tor/log
35 ### Send all messages of level 'warn' or higher to @LOCALSTATEDIR@/log/tor/warnings
36 #Log warn file @LOCALSTATEDIR@/log/tor/warnings
37 ### Send all debug and info messages to @LOCALSTATEDIR@/log/tor/debug