Modify 02_add_debian_files_in_manpage to still apply
[tor.git] / debian / patches / 01_uncomment_datadirectory.dpatch
blob112399b64b802518b981f2bdd2fdfff2018baefd
1 #! /bin/sh -e
2 ## 01_uncomment_datadirectory.dpatch by <weasel@debian.org>
3 ##
4 ## All lines beginning with `## DP:' are a description of the patch.
5 ## DP: No description.
7 if [ $# -lt 1 ]; then
8 echo "`basename $0`: script expects -patch|-unpatch as argument" >&2
9 exit 1
12 [ -f debian/patches/00patch-opts ] && . debian/patches/00patch-opts
13 patch_opts="${patch_opts:--f --no-backup-if-mismatch} ${2:+-d $2}"
15 case "$1" in
16 -patch) patch -p1 ${patch_opts} < $0;;
17 -unpatch) patch -R -p1 ${patch_opts} < $0;;
19 echo "`basename $0`: script expects -patch|-unpatch as argument" >&2
20 exit 1;;
21 esac
23 exit 0
25 @DPATCH@
26 diff -urNad /home/weasel/projects/tor/cvs/src/config/torrc.sample.in cvs/src/config/torrc.sample.in
27 --- /home/weasel/projects/tor/cvs/src/config/torrc.sample.in 2004-03-01 23:41:26.000000000 +0100
28 +++ cvs/src/config/torrc.sample.in 2004-03-03 13:47:25.000000000 +0100
29 @@ -11,7 +11,7 @@
30 ##################### Below is just for servers #####################
32 ## The directory for keeping all the keys/etc for this server
33 -#DataDirectory @LOCALSTATEDIR@/lib/tor
34 +DataDirectory @LOCALSTATEDIR@/lib/tor
36 #Nickname moria # A unique handle for this server
37 #Address moria.seul.org # The fqdn for this server