New upstream release.
[tor.git] / debian / rules
blob889406682af6b1c1ac860d82a34179fb4ca38ac7
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Sample debian/rules that uses debhelper.
4 # GNU copyright 1997 to 1999 by Joey Hess.
6 # Uncomment this to turn on verbose mode.
7 #export DH_VERBOSE=1
9 # These are used for cross-compiling and for saving the configure script
10 # from having to guess our platform (since we know it already)
11 DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
12 DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
14 CFLAGS = -Wall -g
16 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
17 CFLAGS += -O0
18 else
19 CFLAGS += -O2
20 endif
21 ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
22 INSTALL_PROGRAM += -s
23 endif
25 config.status: configure
26 dh_testdir
27 CFLAGS="$(CFLAGS)" ./configure \
28 --host=$(DEB_HOST_GNU_TYPE) \
29 --build=$(DEB_BUILD_GNU_TYPE) \
30 --prefix=/usr \
31 --mandir=\$${prefix}/share/man \
32 --infodir=\$${prefix}/share/info \
33 --localstatedir=/var \
34 --sysconfdir=/etc
37 build: build-stamp
39 build-stamp: config.status
40 dh_testdir
42 $(MAKE)
43 @echo
44 @echo
45 src/or/test
46 @echo
48 touch build-stamp
50 clean:
51 dh_testdir
52 dh_testroot
53 rm -f build-stamp
55 -$(MAKE) distclean
57 dh_clean
59 install: build
60 dh_testdir
61 dh_testroot
62 dh_clean -k
63 dh_installdirs
65 $(MAKE) install DESTDIR=$(CURDIR)/debian/tor
66 # move tor to where it belongs
67 mv $(CURDIR)/debian/tor/usr/bin/tor $(CURDIR)/debian/tor/usr/sbin/tor
68 install -m 755 contrib/torify $(CURDIR)/debian/tor/usr/bin
69 install -m 644 contrib/torify.1 $(CURDIR)/debian/tor/usr/share/man/man1
70 install -m 644 contrib/tor-tsocks.conf $(CURDIR)/debian/tor/etc/tor
72 install -m 644 debian/tor.lintian-override $(CURDIR)/debian/tor/usr/share/lintian/overrides/tor
75 # Build architecture-independent files here.
76 binary-indep: build install
77 # We have nothing to do by default.
79 # Build architecture-dependent files here.
80 binary-arch: build install
81 dh_testdir
82 dh_testroot
83 dh_installchangelogs ChangeLog
84 dh_installdocs
85 dh_installexamples
86 # dh_install
87 # dh_installdebconf
88 dh_installlogrotate
89 # dh_installemacsen
90 # dh_installmime
91 dh_installinit
92 # dh_installcron
93 dh_installman
94 dh_link
95 dh_strip
96 dh_compress
97 dh_fixperms
98 dh_installdeb
99 dh_shlibdeps
100 dh_gencontrol
101 dh_md5sums
102 dh_builddeb
104 binary: binary-indep binary-arch
105 .PHONY: build clean binary-indep binary-arch binary install