Use nick's patch against config. in the rc1 debian package
[tor.git] / debian / patches / 10_handle_no_units.dpatch
bloba60ea84d773aa9443c38564c8f416f2d47428e6e
1 #! /bin/sh -e
2 ## 10_handle_no_units.dpatch by <weasel@debian.org>
3 ##
4 ## All lines beginning with `## DP:' are a description of the patch.
5 ## DP: No description.
7 if [ $# -lt 1 ]; then
8 echo "`basename $0`: script expects -patch|-unpatch as argument" >&2
9 exit 1
12 [ -f debian/patches/00patch-opts ] && . debian/patches/00patch-opts
13 patch_opts="${patch_opts:--f --no-backup-if-mismatch} ${2:+-d $2}"
15 case "$1" in
16 -patch) patch -p1 ${patch_opts} < $0;;
17 -unpatch) patch -R -p1 ${patch_opts} < $0;;
19 echo "`basename $0`: script expects -patch|-unpatch as argument" >&2
20 exit 1;;
21 esac
23 exit 0
25 @DPATCH@
26 diff -urNad tor-0.0.8+0.0.9rc1/src/or/config.c /tmp/dpep.cCb7z4/tor-0.0.8+0.0.9rc1/src/or/config.c
27 --- tor-0.0.8+0.0.9rc1/src/or/config.c 2004-11-23 08:37:17.000000000 +0100
28 +++ /tmp/dpep.cCb7z4/tor-0.0.8+0.0.9rc1/src/or/config.c 2004-11-23 11:56:02.494532062 +0100
29 @@ -2237,6 +2237,7 @@
32 static struct unit_table_t memory_units[] = {
33 + { "", 1 },
34 { "b", 1<< 0 },
35 { "byte", 1<< 0 },
36 { "bytes", 1<< 0 },
37 @@ -2257,6 +2258,7 @@
40 static struct unit_table_t time_units[] = {
41 + { "", 1 },
42 { "second", 1 },
43 { "seconds", 1 },
44 { "minute", 60 },