Updates to Tomato RAF including NGINX && PHP
[tomato.git] / release / src / router / bridge / bridge-utils.spec
blobc6b79d15b344cb1994a34088b78685649a070cf7
1 Name: bridge-utils
2 Version: 1.0.6
3 Release: 1
4 Copyright: GPL
5 Group: System Environment/Base
6 Url: http://bridge.sourceforge.net
7 Summary: Utilities for configuring the linux ethernet bridge.
8 Buildroot: %{_tmppath}/%{name}-%{version}
9 Source: %{name}-%{version}.tar.gz
11 %description
12 This package contains utilities for configuring the linux ethernet
13 bridge. The linux ethernet bridge can be used for connecting multiple
14 ethernet devices together. The connecting is fully transparent: hosts
15 connected to one ethernet device see hosts connected to the other
16 ethernet devices directly.
18 Install bridge-utils if you want to use the linux ethernet bridge.
20 %package -n bridge-utils-devel
21 Summary: Utilities for configuring the linux ethernet bridge.
22 Group: Development/Libraries
24 %description -n bridge-utils-devel
25 The bridge-utils-devel package contains the header and object files
26 necessary for developing programs which use 'libbridge.a', the
27 interface to the linux kernel ethernet bridge. If you are developing
28 programs which need to configure the linux ethernet bridge, your
29 system needs to have these standard header and object files available
30 in order to create the executables.
32 Install bridge-utils-devel if you are going to develop programs which
33 will use the linux ethernet bridge interface library.
35 %prep
36 %setup -q
38 %build
39 CFLAGS="${RPM_OPT_FLAGS}" ./configure --prefix=/usr --mandir=%{_mandir}
40 make
42 %install
43 rm -rf %{buildroot}
45 mkdir -p %{buildroot}%{_sbindir}
46 mkdir -p %{buildroot}%{_includedir}
47 mkdir -p %{buildroot}%{_libdir}
48 mkdir -p %{buildroot}%{_mandir}/man8
49 install -m755 brctl/brctl %{buildroot}%{_sbindir}
50 gzip doc/brctl.8
51 install -m 644 doc/brctl.8.gz %{buildroot}%{_mandir}/man8
52 install -m 644 libbridge/libbridge.h %{buildroot}%{_includedir}
53 install -m 644 libbridge/libbridge.a %{buildroot}%{_libdir}
55 %clean
56 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
58 %files
59 %defattr (-,root,root)
60 %doc AUTHORS COPYING doc/FAQ doc/HOWTO doc/RPM-GPG-KEY
61 %{_sbindir}/brctl
62 %{_mandir}/man8/brctl.8.gz
64 %files -n bridge-utils-devel
65 %defattr (-,root,root)
66 %{_includedir}/libbridge.h
67 %{_libdir}/libbridge.a
69 %changelog
70 * Tue May 25 2004 Stephen Hemminger <shemminger@osdl.org>
71 - cleanup to work for 1.0 code
72 - add dependency on sysfs
74 * Wed Nov 07 2001 Matthew Galgoci <mgalgoci@redhat.com>
75 - initial cleanup of spec file from net release