dnsmasq: update to 2.73 (23.06.2015)
[tomato.git] / release / src / router / dnsmasq / PKGBUILD
blobc98e3b3885f1252841505333c7e2336382a135f4
1 # Maintainer: Sung Pae <self@sungpae.com>
2 pkgname=dnsmasq-nerv
3 pkgver=
4 pkgrel=1
5 pkgdesc="Custom dnsmasq build"
6 arch=('x86_64')
7 url="https://github.com/guns/dnsmasq"
8 license=('GPL')
9 groups=('nerv')
10 backup=('etc/dnsmasq/Rakefile'
11         'etc/dnsmasq/dnsmasq.conf'
12         'etc/dnsmasq/hosts'
13         'etc/dnsmasq/resolv.conf')
14 depends=('glibc' 'libidn')
15 install=dnsmasq.install
16 makedepends=('git')
17 provides=('dnsmasq')
18 conflicts=('dnsmasq')
19 replaces=('dnsmasq-guns')
21 envmake() {
22     DESTDIR="$pkgdir/" PREFIX=/usr BINDIR=/usr/bin RCDIR= \
23     make -e -j $(grep -c ^processor /proc/cpuinfo) "$@"
26 pkgver() {
27     printf %s "$(git describe --long | tr - .)"
30 build() {
31     cd "$startdir"
32     envmake all-i18n
35 package() {
36     cd "$startdir"
37     envmake install