1 Summary: ncurses
-examples
- example
/test programs from ncurses
4 %define AppProgram ncurses
-examples
5 %define AppVersion MAJOR.MINOR
6 %define AppRelease YYYYMMDD
7 # $Id: mingw-ncurses-examples.spec,v 1.3 2013/10/26 23:30:21 tom Exp $
8 Name: mingw32
-ncurses6
-examples
10 Release: %{AppRelease}
12 Group: Development
/Libraries
13 Source: ncurses
-examples
-%{release}.tgz
14 # URL: http://invisible-island.net/ncurses/
16 BuildRequires
: mingw32
-ncurses6
18 BuildRequires
: mingw32
-filesystem
>= 95
19 BuildRequires
: mingw32
-gcc
20 BuildRequires
: mingw32
-binutils
22 BuildRequires
: mingw64
-ncurses6
24 BuildRequires
: mingw64
-filesystem
>= 95
25 BuildRequires
: mingw64
-gcc
26 BuildRequires
: mingw64
-binutils
28 %define CC_NORMAL
-Wall
-Wstrict
-prototypes
-Wmissing
-prototypes
-Wshadow
-Wconversion
29 %define CC_STRICT
%{CC_NORMAL} -W
-Wbad
-function-cast
-Wcast
-align
-Wcast
-qual
-Wmissing
-declarations
-Wnested
-externs
-Wpointer
-arith
-Wwrite
-strings
-ansi
-pedantic
31 %description -n mingw32
-ncurses6
-examples
32 Cross
-compiling support
for ncurses to mingw32.
34 The ncurses library routines are a terminal
-independent method of
35 updating character screens with reasonable optimization.
37 This package is used
for testing ABI
6 with cross
-compiles to MinGW.
39 %package -n mingw64
-ncurses6
-examples
40 Summary: Curses library
for MinGW64
42 %description -n mingw64
-ncurses6
-examples
43 Cross
-compiling support
for ncurses to mingw64.
45 The ncurses library routines are a terminal
-independent method of
46 updating character screens with reasonable optimization.
48 This package is used
for testing ABI
6 with cross
-compiles to MinGW.
52 # override location of bindir, e.g., to avoid conflict with pdcurses
53 %global mingw32_bindir
%{mingw32_exec_prefix}/bin/%{AppProgram}
54 %global mingw64_bindir
%{mingw64_exec_prefix}/bin/%{AppProgram}
61 %define debug_package
%{nil}
62 %setup -q
-n ncurses
-examples
-%{release}
67 CFLAGS
="
%{CC_NORMAL}" \
69 %mingw32_configure %{CFG_OPTS}
70 cp config.status
/tmp
/ming32
-config.status
76 CFLAGS
="
%{CC_NORMAL}" \
78 %mingw64_configure %{CFG_OPTS}
79 cp config.status
/tmp
/ming64
-config.status
84 rm -rf $RPM_BUILD_ROOT
87 %{mingw32_make} install DESTDIR
=$RPM_BUILD_ROOT
91 %{mingw64_make} install DESTDIR
=$RPM_BUILD_ROOT
95 rm -rf $RPM_BUILD_ROOT
98 %defattr(-,root
,root
,-)
100 %files -n mingw32
-ncurses6
-examples
103 %files -n mingw64
-ncurses6
-examples
108 * Sat Oct
19 2013 Thomas E. Dickey