3 Summary: shared libraries
for terminal handling
8 Group: Development
/Libraries
9 Source: ncurses
-%{version}-%{release}.tgz
10 # URL: http://invisible-island.net/ncurses/
12 BuildRequires
: mingw32
-filesystem
>= 95
13 BuildRequires
: mingw32
-gcc
14 BuildRequires
: mingw32
-binutils
16 BuildRequires
: mingw64
-filesystem
>= 95
17 BuildRequires
: mingw64
-gcc
18 BuildRequires
: mingw64
-binutils
20 %define CC_NORMAL
-Wall
-Wstrict
-prototypes
-Wmissing
-prototypes
-Wshadow
-Wconversion
21 %define CC_STRICT
%{CC_NORMAL} -W
-Wbad
-function-cast
-Wcast
-align
-Wcast
-qual
-Wmissing
-declarations
-Wnested
-externs
-Wpointer
-arith
-Wwrite
-strings
-ansi
-pedantic
23 %description -n mingw32
-ncurses6
24 Cross
-compiling support
for ncurses to mingw32.
26 The ncurses library routines are a terminal
-independent method of
27 updating character screens with reasonable optimization.
29 This package is used
for testing ABI
6 with cross
-compiles to MinGW.
31 %package -n mingw64
-ncurses6
32 Summary: Curses library
for MinGW64
34 %description -n mingw64
-ncurses6
35 Cross
-compiling support
for ncurses to mingw64.
37 The ncurses library routines are a terminal
-independent method of
38 updating character screens with reasonable optimization.
40 This package is used
for testing ABI
6 with cross
-compiles to MinGW.
46 --disable
-db
-install \\\
48 --disable
-hard
-tabs \\\
51 --disable
-overwrite \\\
54 --enable-ext
-colors \\\
55 --enable-ext
-mouse \\\
56 --enable-ext
-putwin \\\
59 --enable-term
-driver \\\
65 --with
-fallbacks
=unknown
,rxvt \\\
67 --with
-tparm
-arg
=intptr_t \\\
69 --with
-xterm
-kbs
=DEL \\\
72 --with
-install-prefix
=$RPM_BUILD_ROOT \\\
73 --without
-manpages \\\
77 %define debug_package
%{nil}
78 %setup -q
-n ncurses
-%{version}-%{release}
83 CFLAGS
="
%{CC_NORMAL}" \
85 %mingw32_configure %{CFG_OPTS}
91 CFLAGS
="
%{CC_NORMAL}" \
93 %mingw64_configure %{CFG_OPTS}
98 rm -rf $RPM_BUILD_ROOT
100 mkdir -p $RPM_BUILD_ROOT
%{_bindir}
103 %{mingw32_make} install.libs
104 for name
in $RPM_BUILD_ROOT
%{mingw32_bindir}/*-config
; \
106 base
=`basename $name`
; \
107 ln
-v $name $RPM_BUILD_ROOT
%{_bindir}/%{mingw32_target}-$base
; \
112 %{mingw64_make} install.libs
113 for name
in $RPM_BUILD_ROOT
%{mingw64_bindir}/*-config
; \
115 base
=`basename $name`
; \
116 ln
-v $name $RPM_BUILD_ROOT
%{_bindir}/%{mingw64_target}-$base
; \
121 rm -rf $RPM_BUILD_ROOT
123 %files -n mingw32
-ncurses6
124 %defattr(-,root
,root
,-)
125 %{_bindir}/%{mingw32_target}-*
127 %{mingw32_includedir}/*
130 %files -n mingw64
-ncurses6
131 %defattr(-,root
,root
,-)
132 %{_bindir}/%{mingw64_target}-*
134 %{mingw64_includedir}/*
139 * Sat Sep
20 2014 Thomas E. Dickey
140 - adjust
install-rules
for ncurses
*-config
142 * Sat Aug
03 2013 Thomas E. Dickey
143 - initial version
, using mingw
-pdcurses package as a guide.