libncurses: updated to 6.0
[tomato.git] / release / src / router / libncurses / package / mingw-ncurses.spec
blob703d68597f80ee5059b45727141fe24f542ca0a0
1 %?mingw_package_header
3 Summary: shared libraries for terminal handling
4 Name: mingw32-ncurses6
5 Version: 6.0
6 Release: 20150808
7 License: X11
8 Group: Development/Libraries
9 Source: ncurses-%{version}-%{release}.tgz
10 # URL: http://invisible-island.net/ncurses/
12 BuildRequires: mingw32-filesystem >= 95
13 BuildRequires: mingw32-gcc
14 BuildRequires: mingw32-binutils
16 BuildRequires: mingw64-filesystem >= 95
17 BuildRequires: mingw64-gcc
18 BuildRequires: mingw64-binutils
20 %define CC_NORMAL -Wall -Wstrict-prototypes -Wmissing-prototypes -Wshadow -Wconversion
21 %define CC_STRICT %{CC_NORMAL} -W -Wbad-function-cast -Wcast-align -Wcast-qual -Wmissing-declarations -Wnested-externs -Wpointer-arith -Wwrite-strings -ansi -pedantic
23 %description -n mingw32-ncurses6
24 Cross-compiling support for ncurses to mingw32.
26 The ncurses library routines are a terminal-independent method of
27 updating character screens with reasonable optimization.
29 This package is used for testing ABI 6 with cross-compiles to MinGW.
31 %package -n mingw64-ncurses6
32 Summary: Curses library for MinGW64
34 %description -n mingw64-ncurses6
35 Cross-compiling support for ncurses to mingw64.
37 The ncurses library routines are a terminal-independent method of
38 updating character screens with reasonable optimization.
40 This package is used for testing ABI 6 with cross-compiles to MinGW.
42 %prep
44 %define CFG_OPTS \\\
45 --disable-echo \\\
46 --disable-db-install \\\
47 --disable-getcap \\\
48 --disable-hard-tabs \\\
49 --disable-leaks \\\
50 --disable-macros \\\
51 --disable-overwrite \\\
52 --disable-termcap \\\
53 --enable-const \\\
54 --enable-ext-colors \\\
55 --enable-ext-mouse \\\
56 --enable-ext-putwin \\\
57 --enable-interop \\\
58 --enable-sp-funcs \\\
59 --enable-term-driver \\\
60 --enable-warnings \\\
61 --enable-widec \\\
62 --verbose \\\
63 --with-cxx-shared \\\
64 --with-develop \\\
65 --with-fallbacks=unknown,rxvt \\\
66 --with-shared \\\
67 --with-tparm-arg=intptr_t \\\
68 --with-trace \\\
69 --with-xterm-kbs=DEL \\\
70 --without-ada \\\
71 --without-debug \\\
72 --with-install-prefix=$RPM_BUILD_ROOT \\\
73 --without-manpages \\\
74 --without-progs \\\
75 --without-tests
77 %define debug_package %{nil}
78 %setup -q -n ncurses-%{version}-%{release}
80 %build
81 mkdir BUILD-W32
82 pushd BUILD-W32
83 CFLAGS="%{CC_NORMAL}" \
84 CC=%{mingw32_cc} \
85 %mingw32_configure %{CFG_OPTS}
86 make
87 popd
89 mkdir BUILD-W64
90 pushd BUILD-W64
91 CFLAGS="%{CC_NORMAL}" \
92 CC=%{mingw64_cc} \
93 %mingw64_configure %{CFG_OPTS}
94 make
95 popd
97 %install
98 rm -rf $RPM_BUILD_ROOT
100 mkdir -p $RPM_BUILD_ROOT%{_bindir}
102 pushd BUILD-W32
103 %{mingw32_make} install.libs
104 for name in $RPM_BUILD_ROOT%{mingw32_bindir}/*-config; \
105 do \
106 base=`basename $name`; \
107 ln -v $name $RPM_BUILD_ROOT%{_bindir}/%{mingw32_target}-$base; \
108 done
109 popd
111 pushd BUILD-W64
112 %{mingw64_make} install.libs
113 for name in $RPM_BUILD_ROOT%{mingw64_bindir}/*-config; \
114 do \
115 base=`basename $name`; \
116 ln -v $name $RPM_BUILD_ROOT%{_bindir}/%{mingw64_target}-$base; \
117 done
118 popd
120 %clean
121 rm -rf $RPM_BUILD_ROOT
123 %files -n mingw32-ncurses6
124 %defattr(-,root,root,-)
125 %{_bindir}/%{mingw32_target}-*
126 %{mingw32_bindir}/*
127 %{mingw32_includedir}/*
128 %{mingw32_libdir}/*
130 %files -n mingw64-ncurses6
131 %defattr(-,root,root,-)
132 %{_bindir}/%{mingw64_target}-*
133 %{mingw64_bindir}/*
134 %{mingw64_includedir}/*
135 %{mingw64_libdir}/*
137 %changelog
139 * Sat Sep 20 2014 Thomas E. Dickey
140 - adjust install-rules for ncurses*-config
142 * Sat Aug 03 2013 Thomas E. Dickey
143 - initial version, using mingw-pdcurses package as a guide.