libncurses: updated to 6.0
[tomato.git] / release / src / router / libncurses / Ada95 / package / debian / rules
blob5805f8b7005baa99060fa27459617025518497db
1 #!/usr/bin/make -f
2 # MAde with the aid of dh_make, by Craig Small
3 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
4 # Some lines taken from debmake, by Cristoph Lameter.
6 # Uncomment this to turn on verbose mode.
7 #export DH_VERBOSE=1
9 # These are used for cross-compiling and for saving the configure script
10 # from having to guess our platform (since we know it already)
11 DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
12 DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
14 TARGET_DIR = $(CURDIR)/debian/adacurses
15 SAMPLE_DIR = $(TARGET_DIR)/usr/bin/AdaCurses
17 CFLAGS =
19 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
20 CFLAGS += -O0
21 else
22 CFLAGS += -O2
23 endif
24 ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
25 INSTALL_PROGRAM += -s
26 endif
29 configure: configure-stamp
30 configure-stamp:
31 dh_testdir
33 CFLAGS="$(CFLAGS)" ./configure \
34 --host=$(DEB_HOST_GNU_TYPE) \
35 --build=$(DEB_BUILD_GNU_TYPE) \
36 --prefix=/usr \
37 --disable-rpath-link \
38 --with-shared \
39 --with-ada-sharedlib \
40 --without-pkg-config
42 touch configure-stamp
44 build: build-stamp
45 build-stamp: configure-stamp
46 dh_testdir
48 $(MAKE)
50 touch build-stamp
52 clean:
53 dh_testdir
54 dh_testroot
56 [ ! -f makefile ] || $(MAKE) distclean
58 rm -f configure-stamp build-stamp install-stamp
60 dh_clean
62 install: install-stamp
63 install-stamp: build-stamp
64 dh_testdir
65 dh_testroot
66 dh_clean -k
67 dh_installdirs
69 $(MAKE) install DESTDIR=$(TARGET_DIR)
71 # FIXME: it would be nice to make these into separate packages
72 ( cd samples && $(MAKE) install.examples DESTDIR=$(TARGET_DIR) BINDIR=$(SAMPLE_DIR) )
73 ( cd doc && $(MAKE) install.html DESTDIR=$(TARGET_DIR) )
75 touch install-stamp
77 # Build architecture-independent files here.
78 binary-indep: build install
79 # No binary-indep target.
81 # Build architecture-dependent files here.
82 binary-arch: build install
83 dh_testdir
84 dh_testroot
85 dh_installdocs
86 dh_installexamples
87 dh_installchangelogs NEWS
88 dh_strip
89 dh_compress
90 dh_fixperms
91 dh_installdeb
92 dh_makeshlibs
93 dh_shlibdeps
94 dh_gencontrol
95 dh_md5sums
96 dh_builddeb
98 binary: binary-indep binary-arch
99 .PHONY: build clean binary-indep binary-arch binary install install-stamp