missing ncurses sources
[tomato.git] / release / src / router / libncurses / test / package / debian / rules
blob4d4146b8c98f6c948e0b650641d2f5fcd04b2000
1 #!/usr/bin/make -f
2 # MAde with the aid of dh_make, by Craig Small
3 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
4 # Some lines taken from debmake, by Cristoph Lameter.
6 # Uncomment this to turn on verbose mode.
7 #export DH_VERBOSE=1
9 # These are used for cross-compiling and for saving the configure script
10 # from having to guess our platform (since we know it already)
11 DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
12 DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
14 CFLAGS =
16 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
17 CFLAGS += -O0
18 else
19 CFLAGS += -O2
20 endif
21 ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
22 INSTALL_PROGRAM += -s
23 endif
26 configure: configure-stamp
27 configure-stamp:
28 dh_testdir
30 CFLAGS="$(CFLAGS)" ./configure \
31 --host=$(DEB_HOST_GNU_TYPE) \
32 --build=$(DEB_BUILD_GNU_TYPE) \
33 --bindir=\$${prefix}/bin/ncurses-examples \
34 --prefix=/usr \
35 --with-ncursesw \
36 --disable-rpath-hack
38 touch configure-stamp
40 build: build-stamp
41 build-stamp: configure-stamp
42 dh_testdir
44 $(MAKE)
46 touch build-stamp
48 clean:
49 dh_testdir
50 dh_testroot
52 [ ! -f makefile ] || $(MAKE) distclean
54 rm -f configure-stamp build-stamp install-stamp
56 dh_clean
58 install: install-stamp
59 install-stamp: build-stamp
60 dh_testdir
61 dh_testroot
62 dh_clean -k
63 dh_installdirs
65 $(MAKE) install DESTDIR=$(CURDIR)/debian/ncurses-examples
67 touch install-stamp
69 # Build architecture-independent files here.
70 binary-indep: build install
71 # No binary-indep target.
73 # Build architecture-dependent files here.
74 binary-arch: build install
75 dh_testdir
76 dh_testroot
77 dh_installdocs
78 dh_installexamples
79 dh_installchangelogs NEWS
80 dh_strip
81 dh_compress
82 dh_fixperms
83 dh_installdeb
84 dh_shlibdeps
85 dh_gencontrol
86 dh_md5sums
87 dh_builddeb
89 binary: binary-indep binary-arch
90 .PHONY: build clean binary-indep binary-arch binary install install-stamp