2 # MAde with the aid of dh_make, by Craig Small
3 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
4 # Some lines taken from debmake, by Cristoph Lameter.
6 # Uncomment this to turn on verbose mode.
9 # These are used for cross-compiling and for saving the configure script
10 # from having to guess our platform (since we know it already)
11 DEB_HOST_GNU_TYPE ?
= $(shell dpkg-architecture
-qDEB_HOST_GNU_TYPE
)
12 DEB_BUILD_GNU_TYPE ?
= $(shell dpkg-architecture
-qDEB_BUILD_GNU_TYPE
)
14 TARGET_DIR
= $(CURDIR
)/debian
/adacurses
15 SAMPLE_DIR
= $(TARGET_DIR
)/usr
/bin
/AdaCurses
19 ifneq (,$(findstring noopt
,$(DEB_BUILD_OPTIONS
)))
24 ifeq (,$(findstring nostrip
,$(DEB_BUILD_OPTIONS
)))
29 configure
: configure-stamp
33 CFLAGS
="$(CFLAGS)" .
/configure \
34 --host
=$(DEB_HOST_GNU_TYPE
) \
35 --build
=$(DEB_BUILD_GNU_TYPE
) \
37 --disable-rpath-link \
44 build-stamp
: configure-stamp
55 [ ! -f makefile
] ||
$(MAKE
) distclean
57 rm -f configure-stamp build-stamp install-stamp
61 install: install-stamp
62 install-stamp
: build-stamp
68 $(MAKE
) install DESTDIR
=$(TARGET_DIR
)
70 # FIXME: it would be nice to make these into separate packages
71 ( cd samples
&& $(MAKE
) install.examples DESTDIR
=$(TARGET_DIR
) BINDIR
=$(SAMPLE_DIR
) )
72 ( cd doc
&& $(MAKE
) install.html DESTDIR
=$(TARGET_DIR
) )
76 # Build architecture-independent files here.
77 binary-indep
: build
install
78 # No binary-indep target.
80 # Build architecture-dependent files here.
81 binary-arch
: build
install
86 dh_installchangelogs NEWS
96 binary
: binary-indep binary-arch
97 .PHONY
: build
clean binary-indep binary-arch binary
install install-stamp