dnscrypto-proxy: Update to release 1.3.0
[tomato.git] / release / src / router / pptpd / debian / rules
blobbca6b506733c8068dc6434c195dab27d2ff389f2
1 #!/usr/bin/make -f
2 # MAde with the aid of dh_make, by Craig Small
3 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
4 # Some lines taken from debmake, by Cristoph Lameter.
6 # Uncomment this to turn on verbose mode.
7 #export DH_VERBOSE=1
9 build: build-stamp
10 build-stamp:
11 dh_testdir
13 ./configure --prefix=/usr --mandir=/usr/share/man \
14 --with-libwrap --with-bcrelay
15 # Add here commands to compile the package.
16 $(MAKE)
18 touch build-stamp
20 clean:
21 dh_testdir
22 dh_testroot
23 rm -f build-stamp install-stamp
25 # Add here commands to clean up after the build process.
26 -$(MAKE) distclean
28 dh_clean
30 install: install-stamp
31 install-stamp: build-stamp
32 dh_testdir
33 dh_testroot
34 dh_clean -k
35 dh_installdirs
37 # Add here commands to install the package into debian/tmp.
38 $(MAKE) install prefix=`pwd`/debian/tmp/usr mandir=`pwd`/debian/tmp/usr/share/man
39 cp debian/pptpd.conf `pwd`/debian/tmp/etc
40 cp debian/pptpd-options `pwd`/debian/tmp/etc/ppp
41 #cp debian/pptpdconfig.pl `pwd`/debian/tmp/usr/sbin
42 touch install-stamp
44 # Build architecture-independent files here.
45 binary-indep: build install
46 # We have nothing to do by default.
48 # Build architecture-dependent files here.
49 binary-arch: build install
50 # dh_testversion
51 dh_testdir
52 dh_testroot
53 dh_installdocs
54 # mv `pwd`/debian/tmp/usr/share/doc/pptpd/html/*.txt `pwd`/debian/tmp/usr/share/doc/pptpd/
55 dh_installexamples
56 # dh_installmenu
57 # dh_installemacsen
58 dh_installinit
59 # dh_installcron
60 dh_installmanpages
61 # dh_installdebconf
62 # dh_undocumented
63 dh_installchangelogs -k ChangeLog
64 dh_strip
65 dh_compress
66 dh_fixperms
67 dh_installdeb
68 dh_shlibdeps
69 dh_gencontrol
70 # dh_makeshlibs
71 dh_md5sums
72 dh_builddeb
74 source diff:
75 @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
77 binary: binary-indep binary-arch
78 .PHONY: build clean binary-indep binary-arch binary