libsodium update: 1.0.0
[tomato.git] / release / src-rt-6.x.4708 / router / dnscrypt / packages / debian / rules
blobf814d1bd4a4a7cf82d78013d3b1609d0f1049c3d
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
9 # Uncomment this to turn on verbose mode.
10 #export DH_VERBOSE=1
13 dh $@ --with autotools-dev
15 override_dh_auto_configure:
16 dh_auto_configure -- --disable-ltdl-install --without-included-ltdl
18 # Tests may fail on build servers and aren't useful in release builds anyway
19 override_dh_auto_test:
22 # Install the AppArmor profile. Override dh_compress since it is
23 # sufficiently late in the package creation to do what we want.
24 # This method is copied from telepathy-mission-control-5 package.
25 override_dh_compress:
26 dh_compress
27 mkdir -p debian/dnscrypt-proxy/etc/apparmor.d
28 cp apparmor.profile.dnscrypt-proxy debian/dnscrypt-proxy/etc/apparmor.d/usr.sbin.dnscrypt-proxy
29 dh_apparmor --profile-name=usr.sbin.dnscrypt-proxy -pdnscrypt-proxy