Removed obsolete TTLC init file
[tcl-tlc.git] / debian / rules
blob775242b3393040fe7713b6ea73896c3232de5746
1 #!/usr/bin/make -f
2 # Sample debian/rules that uses debhelper.
3 # GNU copyright 1997 to 1999 by Joey Hess.
5 # Uncomment this to turn on verbose mode.
6 #export DH_VERBOSE=1
8 # This is the debhelper compatability version to use.
9 export DH_COMPAT=3
11 configure: configure-stamp
12 configure-stamp:
13 dh_testdir
14 # Add here commands to configure the package.
17 touch configure-stamp
19 build: build-stamp
21 build-stamp: configure-stamp
22 dh_testdir
24 # Add here commands to compile the package.
25 $(MAKE)
26 #/usr/bin/docbook-to-man debian/tlc.sgml > tlc.1
28 touch build-stamp
30 clean:
31 dh_testdir
32 dh_testroot
33 rm -f build-stamp configure-stamp
35 # Add here commands to clean up after the build process.
36 -$(MAKE) clean
38 dh_clean
40 install: build
41 dh_testdir
42 dh_testroot
43 dh_clean -k
44 dh_installdirs
46 # Add here commands to install the package into debian/tlc.
47 $(MAKE) install DESTDIR=$(CURDIR)/debian/tlc
50 # Build architecture-independent files here.
51 binary-indep: build install
52 # We have nothing to do by default.
54 # Build architecture-dependent files here.
55 binary-arch: build install
56 dh_testdir
57 dh_testroot
58 # dh_installdebconf
59 dh_installdocs
60 dh_installexamples
61 dh_installmenu
62 # dh_installlogrotate
63 # dh_installemacsen
64 # dh_installpam
65 # dh_installmime
66 # dh_installinit
67 dh_installcron
68 dh_installman
69 dh_installinfo
70 # dh_undocumented
71 dh_installchangelogs
72 dh_link
73 dh_strip
74 dh_compress
75 dh_fixperms
76 # dh_makeshlibs
77 dh_installdeb
78 # dh_perl
79 dh_shlibdeps
80 dh_gencontrol
81 dh_md5sums
82 dh_builddeb
84 binary: binary-indep binary-arch
85 .PHONY: build clean binary-indep binary-arch binary install configure