Fix debian/rules in places where the move to BUILD/ dir was not complete.
[tagua/yd.git] / debian / rules
blobb9668c63573dbc7589cb65cf9b0f00777887a27b
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Sample debian/rules that uses debhelper.
5 # This file was originally written by Joey Hess and Craig Small.
6 # As a special exception, when this file is copied by dh-make into a
7 # dh-make output file, you may use that output file without restriction.
8 # This special exception was added by Craig Small in version 0.37 of dh-make.
10 # Modified to make a template file for a multi-binary package with separated
11 # build-arch and build-indep targets by Bill Allombert 2001
13 # Uncomment this to turn on verbose mode.
14 #export DH_VERBOSE=1
16 # This has to be exported to make some magic below work.
17 export DH_OPTIONS
19 configure: BUILD/CMakeCache.txt
20 BUILD/CMakeCache.txt:
21 dh_testdir
22 rm -rf CMakeCache.txt BUILD
23 mkdir BUILD
24 cd BUILD && cmake \
25 -DSYSTEM_LUA=yes \
26 -DCMAKE_INSTALL_PREFIX:PATH=/usr \
27 -DQT_QMAKE_EXECUTABLE:FILEPATH=/usr/bin/qmake-qt4 ..
30 #Architecture
31 build: build-arch build-indep
33 build-arch: build-stamp
34 build-stamp: BUILD/CMakeCache.txt
36 $(MAKE) -C BUILD
37 touch $@
39 build-indep:
40 # nothing to do here
42 clean:
43 dh_testdir
44 dh_testroot
45 rm -f build-stamp
47 rm -rf BUILD
49 dh_clean
51 install: SHELL=/bin/bash
52 install:
53 dh_testdir
54 dh_testroot
55 dh_clean -k
57 $(MAKE) -C BUILD DESTDIR=$(CURDIR)/debian/tmp install
58 cd debian/tmp && mv usr/bin usr/games
60 dh_movefiles
61 test -z "$$(find debian/tmp ! -type d | tee >(cat >&2))"
63 dh_install
65 # Must not depend on anything. This is to be called by
66 # binary-arch/binary-indep
67 # in another 'make' thread.
68 binary-common:
69 dh_testdir
70 dh_testroot
71 dh_installchangelogs CHANGELOG
72 dh_installdocs
73 dh_installexamples
74 dh_installmenu
75 # dh_installdebconf
76 # dh_installmime
77 # dh_python
78 # dh_installinfo
79 dh_installman
80 dh_link
81 dh_strip
82 dh_compress
83 dh_fixperms
84 # dh_perl
85 dh_makeshlibs
86 dh_installdeb
87 dh_shlibdeps
88 dh_gencontrol
89 dh_md5sums
90 dh_builddeb
92 # Build architecture independant packages using the common target.
93 binary-indep: build-indep install
94 $(MAKE) -f debian/rules DH_OPTIONS=-i binary-common
96 # Build architecture dependant packages using the common target.
97 binary-arch: build-arch install
98 $(MAKE) -f debian/rules DH_OPTIONS=-s binary-common
100 binary: binary-arch binary-indep
101 .PHONY: build clean binary-indep binary-arch binary install configure