3 # Sample debian/rules that uses debhelper.
5 # This file was originally written by Joey Hess and Craig Small.
6 # As a special exception, when this file is copied by dh-make into a
7 # dh-make output file, you may use that output file without restriction.
8 # This special exception was added by Craig Small in version 0.37 of dh-make.
10 # Modified to make a template file for a multi-binary package with separated
11 # build-arch and build-indep targets by Bill Allombert 2001
13 # Uncomment this to turn on verbose mode.
16 # This has to be exported to make some magic below work.
19 configure
: BUILD
/CMakeCache.txt
22 rm -rf CMakeCache.txt BUILD
26 -DCMAKE_BUILD_TYPE
:STRING
=debugfull \
27 -DCMAKE_INSTALL_PREFIX
:PATH
=/usr \
28 -DQT_QMAKE_EXECUTABLE
:FILEPATH
=/usr
/bin
/qmake-qt4 ..
32 build
: build-arch build-indep
34 build-arch
: build-stamp
35 build-stamp
: BUILD
/CMakeCache.txt
52 install: SHELL
=/bin
/bash
58 $(MAKE
) -C BUILD DESTDIR
=$(CURDIR
)/debian
/tmp
install
59 cd debian
/tmp
&& mv usr
/bin usr
/games
62 test -z
"$$(find debian/tmp ! -type d | tee >(cat >&2))"
66 # Must not depend on anything. This is to be called by
67 # binary-arch/binary-indep
68 # in another 'make' thread.
72 dh_installchangelogs CHANGELOG
82 dh_strip
--dbg-package
=tagua-dbg
93 # Build architecture independant packages using the common target.
94 binary-indep
: build-indep
install
95 $(MAKE
) -f debian
/rules DH_OPTIONS
=-i binary-common
97 # Build architecture dependant packages using the common target.
98 binary-arch
: build-arch
install
99 $(MAKE
) -f debian
/rules DH_OPTIONS
=-s binary-common
101 binary
: binary-arch binary-indep
102 .PHONY
: build
clean binary-indep binary-arch binary
install configure