Update copyright dates in debian packaging.
[tagua/yd.git] / debian / rules
blobe6565f7fbe6344ac905ebe6a404c08e5b1f32b41
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Sample debian/rules that uses debhelper.
5 # This file was originally written by Joey Hess and Craig Small.
6 # As a special exception, when this file is copied by dh-make into a
7 # dh-make output file, you may use that output file without restriction.
8 # This special exception was added by Craig Small in version 0.37 of dh-make.
10 # Modified to make a template file for a multi-binary package with separated
11 # build-arch and build-indep targets by Bill Allombert 2001
13 # Uncomment this to turn on verbose mode.
14 #export DH_VERBOSE=1
16 # This has to be exported to make some magic below work.
17 export DH_OPTIONS
19 # drop leading "v", replace the 1st hyphen with a ~ to sort lower than 1.0
20 # use debian revision 0 to sort lower than an official package
21 GITVERSION=$(shell git describe | sed -e s/^v// -e s/-/~/)-0
23 configure: BUILD/CMakeCache.txt
24 BUILD/CMakeCache.txt:
25 dh_testdir
26 rm -rf CMakeCache.txt BUILD
27 mkdir BUILD
28 cd BUILD && cmake \
29 -DSYSTEM_LUA=yes \
30 -DCMAKE_INSTALL_PREFIX:PATH=/usr \
31 -DQT_QMAKE_EXECUTABLE:FILEPATH=/usr/bin/qmake-qt4 ..
34 #Architecture
35 build: build-arch build-indep
37 build-arch: build-stamp
38 build-stamp: BUILD/CMakeCache.txt
40 $(MAKE) -C BUILD
41 ./extract-messages.sh
42 touch $@
44 build-indep:
45 # nothing to do here
47 clean:
48 dh_testdir
49 dh_testroot
50 rm -f build-stamp
52 rm -rf BUILD
54 dh_clean
56 install: SHELL=/bin/bash
57 install:
58 dh_testdir
59 dh_testroot
60 dh_clean -k
62 $(MAKE) -C BUILD DESTDIR=$(CURDIR)/debian/tmp install
63 cd debian/tmp && mv usr/bin usr/games
65 dh_movefiles
66 test -z "$$(find debian/tmp ! -type d | tee >(cat >&2))"
68 dh_install
70 # Must not depend on anything. This is to be called by
71 # binary-arch/binary-indep
72 # in another 'make' thread.
73 binary-common:
74 dh_testdir
75 dh_testroot
76 dh_installchangelogs CHANGELOG
77 dh_installdocs
78 dh_installexamples
79 dh_installmenu
80 # dh_installdebconf
81 # dh_installmime
82 # dh_python
83 # dh_installinfo
84 dh_installman
85 dh_link
86 dh_strip
87 dh_compress
88 dh_fixperms
89 # dh_perl
90 dh_makeshlibs
91 dh_installdeb
92 dh_shlibdeps
93 dh_gencontrol -u '-v$(GITVERSION)'
94 dh_md5sums
95 dh_builddeb
97 # Build architecture independant packages using the common target.
98 binary-indep: build-indep install
99 $(MAKE) -f debian/rules DH_OPTIONS=-i binary-common
101 # Build architecture dependant packages using the common target.
102 binary-arch: build-arch install
103 $(MAKE) -f debian/rules DH_OPTIONS=-s binary-common
105 binary: binary-arch binary-indep
106 .PHONY: build clean binary-indep binary-arch binary install configure