Update for doxygen 1.5.5, graph generation, and match current code.
[tagua/yd.git] / debian / rules
bloba073b5502d84838f5bb42ac226302918b65504eb
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Sample debian/rules that uses debhelper.
5 # This file was originally written by Joey Hess and Craig Small.
6 # As a special exception, when this file is copied by dh-make into a
7 # dh-make output file, you may use that output file without restriction.
8 # This special exception was added by Craig Small in version 0.37 of dh-make.
10 # Modified to make a template file for a multi-binary package with separated
11 # build-arch and build-indep targets by Bill Allombert 2001
13 # Uncomment this to turn on verbose mode.
14 #export DH_VERBOSE=1
16 # This has to be exported to make some magic below work.
17 export DH_OPTIONS
19 # drop leading "v", replace the 1st hyphen with a ~ to sort lower than 1.0
20 # use debian revision 0 to sort lower than an official package
21 GITVERSION=$(shell git describe | sed -e s/^v// -e s/-/~/)-0
23 configure: BUILD/CMakeCache.txt
24 BUILD/CMakeCache.txt:
25 dh_testdir
26 rm -rf CMakeCache.txt BUILD
27 mkdir BUILD
28 cd BUILD && cmake \
29 -DSYSTEM_LUA=yes \
30 -DCMAKE_BUILD_TYPE:STRING=debugfull \
31 -DCMAKE_INSTALL_PREFIX:PATH=/usr \
32 -DQT_QMAKE_EXECUTABLE:FILEPATH=/usr/bin/qmake-qt4 ..
35 #Architecture
36 build: build-arch build-indep
38 build-arch: build-stamp
39 build-stamp: BUILD/CMakeCache.txt
41 $(MAKE) -C BUILD
42 ./extract-messages.sh
43 touch $@
45 build-indep:
46 # nothing to do here
48 clean:
49 dh_testdir
50 dh_testroot
51 rm -f build-stamp
53 rm -rf BUILD
55 dh_clean
57 install: SHELL=/bin/bash
58 install:
59 dh_testdir
60 dh_testroot
61 dh_clean -k
63 $(MAKE) -C BUILD DESTDIR=$(CURDIR)/debian/tmp install
64 cd debian/tmp && mv usr/bin usr/games
66 dh_movefiles
67 test -z "$$(find debian/tmp ! -type d | tee >(cat >&2))"
69 dh_install
71 # Must not depend on anything. This is to be called by
72 # binary-arch/binary-indep
73 # in another 'make' thread.
74 binary-common:
75 dh_testdir
76 dh_testroot
77 dh_installchangelogs CHANGELOG
78 dh_installdocs
79 dh_installexamples
80 dh_installmenu
81 # dh_installdebconf
82 # dh_installmime
83 # dh_python
84 # dh_installinfo
85 dh_installman
86 dh_link
87 dh_strip --dbg-package=tagua-dbg
88 dh_compress
89 dh_fixperms
90 # dh_perl
91 dh_makeshlibs
92 dh_installdeb
93 dh_shlibdeps
94 dh_gencontrol -u '-v$(GITVERSION)'
95 dh_md5sums
96 dh_builddeb
98 # Build architecture independant packages using the common target.
99 binary-indep: build-indep install
100 $(MAKE) -f debian/rules DH_OPTIONS=-i binary-common
102 # Build architecture dependant packages using the common target.
103 binary-arch: build-arch install
104 $(MAKE) -f debian/rules DH_OPTIONS=-s binary-common
106 binary: binary-arch binary-indep
107 .PHONY: build clean binary-indep binary-arch binary install configure