debian/rules should be producing architecture independent packages
[stgit/dwhite.git] / debian / rules
blob4d211c2530c528206adfda4c59416c756e252ad9
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
9 # Uncomment this to turn on verbose mode.
10 #export DH_VERBOSE=1
15 CFLAGS = -Wall -g
17 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
18 CFLAGS += -O0
19 else
20 CFLAGS += -O2
21 endif
23 configure: configure-stamp
24 configure-stamp:
25 dh_testdir
26 # Add here commands to configure the package.
28 touch configure-stamp
31 build: build-stamp
33 build-stamp: configure-stamp
34 dh_testdir
36 $(MAKE) all doc
38 touch build-stamp
40 clean:
41 dh_testdir
42 dh_testroot
43 rm -f build-stamp configure-stamp
45 # Add here commands to clean up after the build process.
46 -$(MAKE) clean
48 dh_clean
50 install: build
51 dh_testdir
52 dh_testroot
53 dh_clean -k
54 dh_installdirs
56 # Add here commands to install the package into debian/stgit.
57 $(MAKE) DESTDIR=$(CURDIR)/debian/stgit prefix=/usr install install-doc install-html
59 # Build architecture-independent files here.
60 binary-indep: build install
61 dh_testdir
62 dh_testroot
63 dh_installchangelogs
64 dh_installdocs
65 dh_installexamples
66 dh_install
67 # dh_installmenu
68 # dh_installdebconf
69 # dh_installlogrotate
70 # dh_installemacsen
71 # dh_installpam
72 # dh_installmime
73 # dh_installinit
74 # dh_installcron
75 # dh_installinfo
76 dh_installman
77 dh_link
78 dh_strip
79 dh_compress
80 dh_fixperms
81 # dh_perl
82 dh_python
83 # dh_makeshlibs
84 dh_installdeb
85 dh_shlibdeps
86 dh_gencontrol
87 dh_md5sums
88 dh_builddeb
90 # Build architecture-dependent files here.
91 binary-arch: build install
92 # We have nothing to do by default.
94 binary: binary-indep binary-arch
95 .PHONY: build clean binary-indep binary-arch binary install configure