Do not mess-up with commit message formatting when sending email
[stgit/dwhite.git] / debian / rules
blob56886805a4abbfc5f3c9023667e3d262b888392d
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
9 # Uncomment this to turn on verbose mode.
10 #export DH_VERBOSE=1
15 CFLAGS = -Wall -g
17 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
18 CFLAGS += -O0
19 else
20 CFLAGS += -O2
21 endif
23 configure: configure-stamp
24 configure-stamp:
25 dh_testdir
26 # Add here commands to configure the package.
28 touch configure-stamp
31 build: build-stamp
33 build-stamp: configure-stamp
34 dh_testdir
36 # Add here commands to compile the package.
37 $(MAKE)
38 #docbook-to-man debian/stgit.sgml > stgit.1
40 touch build-stamp
42 clean:
43 dh_testdir
44 dh_testroot
45 rm -f build-stamp configure-stamp
47 # Add here commands to clean up after the build process.
48 -$(MAKE) clean
50 dh_clean
52 install: build
53 dh_testdir
54 dh_testroot
55 dh_clean -k
56 dh_installdirs
58 # Add here commands to install the package into debian/stgit.
59 $(MAKE) DESTDIR=$(CURDIR)/debian/stgit PREFIX=/usr install
61 # Build architecture-independent files here.
62 binary-indep: build install
63 # We have nothing to do by default.
65 # Build architecture-dependent files here.
66 binary-arch: build install
67 dh_testdir
68 dh_testroot
69 dh_installchangelogs
70 dh_installdocs
71 dh_installexamples
72 # dh_install
73 # dh_installmenu
74 # dh_installdebconf
75 # dh_installlogrotate
76 # dh_installemacsen
77 # dh_installpam
78 # dh_installmime
79 # dh_installinit
80 # dh_installcron
81 # dh_installinfo
82 dh_installman
83 dh_link
84 dh_strip
85 dh_compress
86 dh_fixperms
87 # dh_perl
88 dh_python
89 # dh_makeshlibs
90 dh_installdeb
91 dh_shlibdeps
92 dh_gencontrol
93 dh_md5sums
94 dh_builddeb
96 binary: binary-indep binary-arch
97 .PHONY: build clean binary-indep binary-arch binary install configure