Added a debian/rules for building a Debian package, a man page various other niceties.
[stand.git] / debian / rules
blob6e716f158c2de4c85c9aae8432b5bb86b4d6e23b
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
9 # Uncomment this to turn on verbose mode.
10 #export DH_VERBOSE=1
15 configure: configure-stamp
16 configure-stamp:
17 dh_testdir
18 # Add here commands to configure the package.
20 touch configure-stamp
23 build: build-stamp
25 build-stamp: configure-stamp
26 dh_testdir
28 # Add here commands to compile the package.
29 $(MAKE)
30 #docbook-to-man debian/stand.sgml > stand.1
32 touch $@
34 clean:
35 dh_testdir
36 dh_testroot
37 rm -f build-stamp configure-stamp
39 # Add here commands to clean up after the build process.
40 $(MAKE) clean
42 dh_clean
44 install: build
45 dh_testdir
46 dh_testroot
47 dh_clean -k
48 dh_installdirs
50 # Add here commands to install the package into debian/stand.
51 $(MAKE) DESTDIR=$(CURDIR)/debian/stand install
54 # Build architecture-independent files here.
55 binary-indep: build install
56 dh_testdir
57 dh_testroot
58 dh_installchangelogs
59 dh_installdocs
60 dh_installexamples
61 # dh_install
62 # dh_installmenu
63 # dh_installdebconf
64 # dh_installlogrotate
65 # dh_installemacsen
66 # dh_installpam
67 # dh_installmime
68 # dh_python
69 # dh_installinit
70 # dh_installcron
71 # dh_installinfo
72 dh_installman stand.1
73 dh_link
74 dh_strip
75 dh_compress
76 dh_fixperms
77 # dh_perl
78 # dh_makeshlibs
79 dh_installdeb
80 dh_shlibdeps
81 dh_gencontrol
82 dh_md5sums
83 dh_builddeb
85 binary: binary-indep
86 .PHONY: build clean binary-indep binary install configure