core: moved repeating code to sipmsg_parse_warning()
[siplcs.git] / contrib / debian / rules
blobd6e529a249bbd8408471f45d422bee4973640aef
1 #!/usr/bin/make -f
3 include /usr/share/cdbs/1/class/autotools.mk
4 include /usr/share/cdbs/1/rules/debhelper.mk
6 DEB_CONFIGURE_EXTRA_FLAGS := --enable-purple --disable-telepathy
8 # run tests
9 DEB_MAKE_CHECK_TARGET := check
11 # don't run unnecessary ldconfig on postinst and postrm.
12 DEB_DH_MAKESHLIBS_ARGS_pidgin-sipe=-n
14 clean::
15 dh_testdir
17 # git snapshot does not contain a configure script
18 debian/stamp-autotools-files: $(DEB_CONFIGURE_SCRIPT)
19 $(DEB_BUILDDIR)/config.status: $(DEB_CONFIGURE_SCRIPT)
21 $(DEB_CONFIGURE_SCRIPT):
22 ./autogen.sh
24 binary-post-install/pidgin-sipe::
25 rm -f debian/pidgin-sipe/usr/share/doc/pidgin-sipe/README
26 rm debian/pidgin-sipe/usr/lib/purple-2/libsipe.la
28 .PHONY: update-debian-control