OBS: for 1.9.0 release
[siplcs.git] / contrib / opensuse-build-service / pidgin-sipe.spec
blob45a1f22eacb972fa2f54932d131f3d5ee76ee7b1
2 # OBS SPEC file to generate a RPM for pidgin-sipe.
3 # It should work on Fedora 9/10/11/12, openSUSE 11.x, RHEL5/CentOS 5, SLES/D 11 and Mandriva 2009.1/2010.
6 %define purple_plugin libpurple-plugin-sipe
8 %define purple_develname libpurple-devel
10 %if 0%{?mandriva_version} >= 200910
11 %ifarch x86_64
12 %define purple_develname lib64purple-devel
13 %endif
14 %endif
16 %if 0%{?suse_version} || 0%{?sles_version}
17 %define pkg_group Productivity/Networking/Instant Messenger
18 %endif
19 %if 0%{?fedora_version}
20 %define pkg_group Applications/Internet
21 %endif
22 %if 0%{?mandriva_version}
23 %define pkg_group Networking/Instant messaging
24 %else
25 %define pkg_group Applications/Internet
26 %endif
28 Name: pidgin-sipe
29 Summary: Pidgin protocol plugin to connect to MS Office Communicator
30 Version: 1.9.0
31 Release: 1
32 Source: %{name}-%{version}.tar.gz
33 Group: %{pkg_group}
34 License: GPLv2+
35 URL: http://sipe.sourceforge.net/
37 BuildRoot: %{_tmppath}/%{name}-%{version}-build
39 BuildRequires: %{purple_develname} >= 2.4.0
40 BuildRequires: libtool
41 BuildRequires: intltool
42 BuildRequires: gettext-devel
44 # Configurable components
45 %if !0%{?_without_kerberos:1}
46 %define config_krb5 --with-krb5
47 BuildRequires: krb5-devel
48 %endif
50 # For directory ownership
51 BuildRequires: pidgin
52 Requires: %{purple_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
53 Requires: pidgin
54 %if 0%{?sles_version} == 10
55 BuildRequires: gnome-keyring-devel
56 %endif
58 %description
59 A third-party plugin for the Pidgin multi-protocol instant messenger.
60 It implements the extended version of SIP/SIMPLE used by various products:
62 * Microsoft Office Communications Server (OCS 2007/2007 R2 and newer)
63 * Microsoft Live Communications Server (LCS 2003/2005)
64 * Reuters Messaging
66 With this plugin you should be able to replace your Microsoft Office
67 Communicator client with Pidgin.
69 This package provides the icon set for Pidgin.
72 %package -n %{purple_plugin}
73 Summary: Libpurple protocol plugin to connect to MS Office Communicator
74 Group: %{pkg_group}
75 License: GPLv2+
76 Obsoletes: purple-sipe
78 %description -n %{purple_plugin}
79 A third-party plugin for the Pidgin multi-protocol instant messenger.
80 It implements the extended version of SIP/SIMPLE used by various products:
82 * Microsoft Office Communications Server (OCS 2007/2007 R2 and newer)
83 * Microsoft Live Communications Server (LCS 2003/2005)
84 * Reuters Messaging
86 This package provides the protocol plugin for libpurple clients.
89 %prep
90 %setup -q
92 %build
93 %define config_params %{?config_krb5:%{config_krb5}}
94 %if 0%{?sles_version} == 10
95 export CFLAGS="%optflags -I%{_includedir}/gssapi"
96 %endif
97 %configure %{config_params}
98 make %{_smp_mflags}
101 %install
102 %makeinstall
103 find %{buildroot} -type f -name "*.la" -delete -print
104 %find_lang %{name}
107 %clean
108 rm -rf %{buildroot}
111 %files -n %{purple_plugin} -f %{name}.lang
112 %defattr(-,root,root,-)
113 %doc AUTHORS ChangeLog COPYING NEWS README TODO
114 %{_libdir}/purple-2/libsipe.so
117 %files
118 %defattr(-,root,root,-)
119 %doc AUTHORS COPYING
120 %{_datadir}/pixmaps/pidgin/protocols/*/sipe.png
123 %changelog
124 * Wed Mar 10 2010 pier11 <pier11@operamail.com> 1.9.0
125 - release
126 - dropped SLE 10 due to libpurple min version increase
127 - updated target distros in comment line
129 * Mon Mar 08 2010 J. D. User <jduser@noreply.com> 1.9.0-*git*
130 - increased libpurple build requisite to >= 2.4.0
132 * Sun Mar 07 2010 pier11 <pier11@operamail.com> pre-1.9.0-*git*
133 - OBS tests of pre-1.9.0 git-snapshot 61ea0856855483b9e18f23a87afe47437e526f0e
135 * Sun Mar 07 2010 J. D. User <jduser@noreply.com> 1.8.1-*git*
136 - sync with RPM SPEC from contrib/rpm
138 * Sun Feb 08 2010 pier11 <pier11@operamail.com> 1.8.0
139 - source is an original 1.8.0 with patch: git(upstream) 9c34cc3557daa3d61a002002492c71d0343c8cae
140 - temp hack - renamed source in spec from .bz2 to .gz as the latter was prepared with the patch.
142 * Sun Nov 22 2009 pier11 <pier11@operamail.com> 1.7.1
143 - reinstated enable-quality-check
145 * Wed Nov 04 2009 John Beranek <john@redux.org.uk> 1.7.0
146 - Spec file modifications to allow SLES/D 10 and Mandriva 2009.1 builds
148 * Tue Nov 03 2009 John Beranek <john@redux.org.uk> 1.7.0
149 - Spec file modifications for openSUSE build service
151 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
152 - move non-Pidgin files to new sub-package purple-sipe
154 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
155 - remove directory for emoticon theme icons
157 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
158 - libpurple protocol plugins are located under %%{_libdir}/purple-2
160 * Mon Sep 28 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
161 - added directory for emoticon theme icons
163 * Wed Sep 09 2009 J. D. User <jduser@noreply.com> 1.6.3
164 - update to 1.6.3
166 * Fri Aug 28 2009 J. D. User <jduser@noreply.com> 1.6.2-*git*
167 - reduce libpurple-devel requirement to >= 2.3.1
169 * Mon Aug 24 2009 J. D. User <jduser@noreply.com> 1.6.2
170 - update to 1.6.2
172 * Fri Aug 21 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
173 - reduce libpurple-devel requirement to >= 2.4.1
175 * Mon Aug 17 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
176 - com_err.h only required for kerberos
178 * Tue Aug 11 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
179 - require libpurple-devel >= 2.5.0
181 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
182 - refactor configure parameters
183 - make kerberos configurable
184 - don't hard code prefix for git builds
186 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
187 - removed unnecessary zlib-devel
189 * Sat Aug 08 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
190 - fix prefix for git builds
192 * Sat Aug 01 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
193 - append -Wno-unused-parameter for GCC <4.4 compilation errors
195 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
196 - remove duplicate GPL2
198 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
199 - use "--with git" to build from git
200 - corrected download URL for release archive
201 - add missing BR gettext-devel
203 * Wed Jul 29 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
204 - use default rpmbuild CFLAGS also for git builds
205 - merge with SPEC files created by mricon & jberanek
207 * Tue Jul 28 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
208 - initial RPM SPEC example generated