Merge tag '1.20.1' into mob
[siplcs.git] / contrib / opensuse-build-service / pidgin-sipe.spec
blob07c16ee76797c2d8721b7e043400feb8b96db1c1
2 # OBS SPEC file to generate a RPM for pidgin-sipe.
4 # It has support for:
6 # RedHat family (CentOS, Fedora, RHEL, ScientificLinux)
7 # SUSE family (openSUSE, SLED, SLES)
8 # Windows (mingw32, mingw64)
11 # Build options
12 %undefine build_telepathy
14 # Check for mingw32 cross compilation build
16 # Manually add this repository to your private OBS project:
18 # <repository name="mingw32">
19 # <path repository="openSUSE_13.2" project="windows:mingw:win32"/>
20 # <arch>i586</arch>
21 # </repository>
23 %if "%{_repository}" == "mingw32"
24 %define purple_sipe_mingw32 1
25 %define mingw_prefix mingw32-
26 %define mingw_cache %{_mingw32_cache}
27 %define mingw_configure %{_mingw32_configure}
28 %define mingw_datadir %{_mingw32_datadir}
29 %define mingw_debug_package %{_mingw32_debug_package}
30 %define mingw_ldflags MINGW32_LDFLAGS
31 %define mingw_libdir %{_mingw32_libdir}
32 %define mingw_make %{_mingw32_make}
33 %define mingw_makeinstall %{_mingw32_makeinstall}
34 %define __strip %{_mingw32_strip}
35 %define __objdump %{_mingw32_objdump}
36 %define _use_internal_dependency_generator 0
37 %define __find_requires %{_mingw32_findrequires}
38 %define __find_provides %{_mingw32_findprovides}
39 %define __os_install_post %{_mingw32_debug_install_post} \
40 %{_mingw32_install_post}
41 %endif
43 # Check for mingw64 cross compilation build
45 # Manually add this repository to your private OBS project:
47 # <repository name="mingw64">
48 # <path repository="openSUSE_13.2" project="windows:mingw:win64"/>
49 # <arch>i586</arch>
50 # </repository>
52 %if "%{_repository}" == "mingw64"
53 %define purple_sipe_mingw64 1
54 %define mingw_prefix mingw64-
55 %define mingw_cache %{_mingw64_cache}
56 %define mingw_configure %{_mingw64_configure}
57 %define mingw_datadir %{_mingw64_datadir}
58 %define mingw_debug_package %{_mingw64_debug_package}
59 %define mingw_ldflags MINGW64_LDFLAGS
60 %define mingw_libdir %{_mingw64_libdir}
61 %define mingw_make %{_mingw64_make}
62 %define mingw_makeinstall %{_mingw64_makeinstall}
63 %define __strip %{_mingw64_strip}
64 %define __objdump %{_mingw64_objdump}
65 %define _use_internal_dependency_generator 0
66 %define __find_requires %{_mingw64_findrequires}
67 %define __find_provides %{_mingw64_findprovides}
68 %define __os_install_post %{_mingw64_debug_install_post} \
69 %{_mingw64_install_post}
70 %endif
72 %define purple_plugin %{?mingw_prefix:%{mingw_prefix}}libpurple-plugin-sipe
73 %define telepathy_plugin %{?mingw_prefix:%{mingw_prefix}}telepathy-plugin-sipe
74 %define nsis_package %{?mingw_prefix:%{mingw_prefix}}pidgin-sipe-nsis
75 %define common_files sipe-common
76 %define empathy_files empathy-sipe
77 %define ktp_files ktp-accounts-kcm-sipe
80 %define has_pidgin 1
82 %if 0%{?suse_version}
83 %define nss_develname mozilla-nss-devel
84 # SLES11 defines suse_version = 1110
85 %if 0%{?suse_version} > 1110
86 %define has_libnice 1
87 %define has_gstreamer 1
88 %define build_telepathy 1
89 %define nice_gstreamer gstreamer-0_10-libnice
90 %endif
91 %else
92 %define nss_develname nss-devel
93 %endif
95 %if 0%{?suse_version} || 0%{?sles_version}
96 %define pkg_group Productivity/Networking/Instant Messenger
97 %else
98 %define pkg_group Applications/Internet
99 %endif
101 %if 0%{?fedora}
102 %define has_libnice 1
103 %define has_gstreamer 1
104 %define build_telepathy 1
105 %define build_ktp 1
106 %if 0%{?fedora} >= 20
107 %define nice_gstreamer libnice-gstreamer
108 %if 0%{?fedora} >= 21
109 %define has_gssntlmssp 1
110 %endif
111 %endif
112 %endif
114 %if 0%{?centos_version} || 0%{?scientificlinux_version}
115 %define rhel_base_version %{?centos_version}%{?scientificlinux_version}
116 %if %{rhel_base_version} >= 600
117 %define has_gstreamer 1
118 %define has_libnice 1
119 %if %{rhel_base_version} >= 700
120 # pidgin has been removed, but libpurple still exists
121 %define has_pidgin 0
122 %endif
123 %endif
124 %endif
126 %if 0%{?purple_sipe_mingw32}
127 Name: mingw32-pidgin-sipe
128 %else
129 %if 0%{?purple_sipe_mingw64}
130 Name: mingw64-pidgin-sipe
131 %else
132 Name: pidgin-sipe
133 %endif
134 %endif
135 Summary: Pidgin protocol plugin to connect to MS Office Communicator
136 Version: 1.20.1
137 Release: 1
138 Source: pidgin-sipe-%{version}.tar.gz
139 Group: %{pkg_group}
140 License: GPL-2.0+
141 URL: http://sipe.sourceforge.net/
143 BuildRoot: %{_tmppath}/%{name}-%{version}-build
145 %if 0%{?mingw_prefix:1}
147 # Windows cross-compilation build setup
149 BuildArch: noarch
150 #!BuildIgnore: post-build-checks
152 BuildRequires: %{mingw_prefix}filesystem >= 23
153 BuildRequires: %{mingw_prefix}cross-gcc
154 BuildRequires: %{mingw_prefix}cross-binutils
155 BuildRequires: %{mingw_prefix}gettext-runtime
156 BuildRequires: %{mingw_prefix}cross-pkg-config
157 BuildRequires: %{mingw_prefix}glib2-devel >= 2.12.0
158 BuildRequires: %{mingw_prefix}libxml2-devel
159 BuildRequires: %{mingw_prefix}mozilla-nss-devel
160 BuildRequires: %{mingw_prefix}libpurple-devel >= 2.4.0
161 BuildRequires: %{mingw_prefix}cross-nsis
163 # For directory ownership
164 BuildRequires: %{mingw_prefix}pidgin
166 # Make sure telepathy is disabled for Windows builds
167 %undefine build_telepathy
169 %else
171 # Standard Linux build setup
173 BuildRequires: libpurple-devel >= 2.4.0
174 BuildRequires: libxml2-devel
175 BuildRequires: %{nss_develname}
176 BuildRequires: gettext-devel
177 # The following two are required to enable Voice & Video features
178 %if 0%{?has_libnice:1}
179 BuildRequires: libnice-devel
180 %if 0%{?nice_gstreamer:1}
181 # Dependency required when gstreamer support is split into two packages
182 Requires: %{nice_gstreamer}
183 %endif
184 %endif
185 %if 0%{?has_gstreamer:1}
186 BuildRequires: pkgconfig(gstreamer-0.10)
187 %endif
188 # Requirements for telepathy backend
189 %if 0%{?build_telepathy:1}
190 BuildRequires: pkgconfig(telepathy-glib) >= 0.18.0
191 BuildRequires: gmime-devel
192 BuildRequires: glib2-devel >= 2.28.0
193 %endif
195 # Configurable components
196 %if !0%{?_without_kerberos:1}
197 BuildRequires: krb5-devel
198 %if 0%{?has_gssntlmssp}
199 BuildRequires: gssntlmssp-devel >= 0.5.0
200 Requires: gssntlmssp >= 0.5.0
201 %endif
202 %endif
204 # For directory ownership
205 %if %{has_pidgin}
206 BuildRequires: pidgin
207 Requires: pidgin
208 %endif
209 %if 0%{?build_telepathy:1}
210 BuildRequires: empathy
211 %endif
213 # End Windows cross-compilation/Linux build setup
214 %endif
216 Requires: %{purple_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
217 BuildRequires: libtool
218 BuildRequires: intltool
219 BuildRequires: glib2-devel >= 2.12.0
222 %description
223 A third-party plugin for the Pidgin multi-protocol instant messenger.
224 It implements the extended version of SIP/SIMPLE used by various products:
226 * Skype for Business
227 * Microsoft Office 365
228 * Microsoft Business Productivity Online Suite (BPOS)
229 * Microsoft Lync Server
230 * Microsoft Office Communications Server (OCS 2007/2007 R2)
231 * Microsoft Live Communications Server (LCS 2003/2005)
232 * Reuters Messaging
234 With this plugin you should be able to replace your Microsoft Office
235 Communicator client with Pidgin.
237 This package provides the icon set for Pidgin.
240 %package -n %{purple_plugin}
241 Summary: Libpurple protocol plugin to connect to MS Office Communicator
242 Group: %{pkg_group}
243 License: GPL-2.0+
244 Obsoletes: purple-sipe
245 %if 0%{?build_telepathy:1}
246 Requires: %{common_files} = %{?epoch:%{epoch}:}%{version}-%{release}
247 %endif
249 %description -n %{purple_plugin}
250 A third-party plugin for the Pidgin multi-protocol instant messenger.
251 It implements the extended version of SIP/SIMPLE used by various products:
253 * Skype for Business
254 * Microsoft Office 365
255 * Microsoft Business Productivity Online Suite (BPOS)
256 * Microsoft Lync Server
257 * Microsoft Office Communications Server (OCS 2007/2007 R2)
258 * Microsoft Live Communications Server (LCS 2003/2005)
259 * Reuters Messaging
261 This package provides the protocol plugin for libpurple clients.
264 %if 0%{?build_telepathy:1}
265 %package -n %{empathy_files}
266 Summary: Telepathy connection manager to connect to MS Office Communicator
267 Group: %{pkg_group}
268 License: GPL-2.0+
269 Requires: empathy
270 Requires: %{telepathy_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
272 %description -n %{empathy_files}
273 A Telepathy connection manager that implements the extended version of
274 SIP/SIMPLE used by various products:
276 * Skype for Business
277 * Microsoft Office 365
278 * Microsoft Business Productivity Online Suite (BPOS)
279 * Microsoft Lync Server
280 * Microsoft Office Communications Server (OCS 2007/2007 R2)
281 * Microsoft Live Communications Server (LCS 2003/2005)
282 * Reuters Messaging
284 This package provides the icon set for Empathy.
287 %if 0%{?build_ktp:1}
288 %package -n %{ktp_files}
289 Summary: Telepathy connection manager to connect to MS Office Communicator
290 Group: %{pkg_group}
291 License: GPL-2.0+
292 Requires: %{telepathy_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
294 %description -n %{ktp_files}
295 A Telepathy connection manager that implements the extended version of
296 SIP/SIMPLE used by various products:
298 * Skype for Business
299 * Microsoft Office 365
300 * Microsoft Business Productivity Online Suite (BPOS)
301 * Microsoft Lync Server
302 * Microsoft Office Communications Server (OCS 2007/2007 R2)
303 * Microsoft Live Communications Server (LCS 2003/2005)
304 * Reuters Messaging
306 This package provides the profile for KTP account manager.
307 %endif
310 %package -n %{telepathy_plugin}
311 Summary: Telepathy connection manager to connect to MS Office Communicator
312 Group: %{pkg_group}
313 License: GPL-2.0+
314 Requires: %{common_files} = %{?epoch:%{epoch}:}%{version}-%{release}
316 %description -n %{telepathy_plugin}
317 A Telepathy connection manager that implements the extended version of
318 SIP/SIMPLE used by various products:
320 * Skype for Business
321 * Microsoft Office 365
322 * Microsoft Business Productivity Online Suite (BPOS)
323 * Microsoft Lync Server
324 * Microsoft Office Communications Server (OCS 2007/2007 R2)
325 * Microsoft Live Communications Server (LCS 2003/2005)
326 * Reuters Messaging
328 This package provides the protocol support for Telepathy clients.
331 %package -n %{common_files}
332 Summary: Common files for SIPE protocol plugins
333 Group: %{pkg_group}
334 License: GPL-2.0+
335 BuildArch: noarch
337 %description -n %{common_files}
338 This package provides common files for the SIPE protocol plugins:
340 * Localisation
341 %endif
344 %if 0%{?mingw_prefix:1}
345 %package -n %{nsis_package}
346 Summary: Windows Pidgin protocol plugin to connect to MS Office Communicator
347 Group: %{pkg_group}
348 License: GPL-2.0+
350 %description -n %{nsis_package}
351 A third-party plugin for the Pidgin multi-protocol instant messenger.
352 It implements the extended version of SIP/SIMPLE used by various products:
354 * Skype for Business
355 * Microsoft Office 365
356 * Microsoft Business Productivity Online Suite (BPOS)
357 * Microsoft Lync Server
358 * Microsoft Office Communications Server (OCS 2007/2007 R2)
359 * Microsoft Live Communications Server (LCS 2003/2005)
360 * Reuters Messaging
362 This package contains the NSIS installer package of the protocol plugin
363 for Pidgin on Windows.
364 %endif
367 %{mingw_debug_package}
370 %prep
371 %setup -q -n pidgin-sipe-%{version}
373 %build
374 %if 0%{?mingw_prefix:1}
376 # Windows cross-compilation build
378 %{?env_options}
379 echo "lt_cv_deplibs_check_method='pass_all'" >>%{mingw_cache}
380 autoreconf --verbose --install --force
381 %{mingw_ldflags}="-Wl,--exclude-libs=libintl.a -Wl,--exclude-libs=libiconv.a -lws2_32"
382 %{mingw_configure} \
383 --enable-purple \
384 %if 0%{?build_telepathy:1}
385 --enable-telepathy
386 %else
387 --disable-telepathy
388 %endif
389 %{mingw_make} %{_smp_mflags} || %{mingw_make}
391 %else
393 # Standard Linux build
395 %configure \
396 --enable-purple \
397 %if 0%{?build_telepathy:1}
398 --enable-telepathy
399 %else
400 --disable-telepathy
401 %endif
402 make %{_smp_mflags}
403 make %{_smp_mflags} check
405 # End Windows cross-compilation/Linux build setup
406 %endif
409 %install
410 %if 0%{?mingw_prefix:1}
412 # Windows cross-compilation install
414 %{mingw_makeinstall}
415 rm -f %{buildroot}%{mingw_libdir}/purple-2/*.dll.a
417 # generate .dbgsym file
418 rm -f %{buildroot}%{mingw_libdir}/purple-2/libsipe.dll.dbgsym
419 mv \
420 %{buildroot}%{mingw_libdir}/purple-2/libsipe.dll \
421 %{buildroot}%{mingw_libdir}/purple-2/libsipe.dll.dbgsym
422 %{__strip} --strip-unneeded \
423 %{buildroot}%{mingw_libdir}/purple-2/libsipe.dll.dbgsym \
424 -o %{buildroot}%{mingw_libdir}/purple-2/libsipe.dll \
426 # generate NSIS installer package
427 perl contrib/opensuse-build-service/generate_nsi.pl po/LINGUAS \
428 <contrib/opensuse-build-service/pidgin-sipe.nsi.template \
429 >%{buildroot}/pidgin-sipe.nsi
431 set -e; \
432 cd %{buildroot}; \
433 makensis \
434 -DPIDGIN_VERSION=UNKNOWN \
435 -DVERSION=%{version} \
436 -DMINGW_LIBDIR=%{buildroot}%{mingw_libdir} \
437 -DMINGW_DATADIR=%{buildroot}%{mingw_datadir} \
438 pidgin-sipe.nsi \
440 rm -f %{buildroot}/pidgin-sipe.nsi
442 %else
444 # Standard Linux install
446 %makeinstall
448 # End Windows cross-compilation/Linux build setup
449 %endif
451 find %{buildroot} -type f -name "*.la" -delete -print
452 # SLES11 defines suse_version = 1110
453 %if 0%{?suse_version} && 0%{?suse_version} < 1120
454 rm -r %{buildroot}/%{_datadir}/pixmaps/pidgin/protocols/scalable
455 %endif
456 # Pidgin doesn't have 24 or 32 pixel icons
457 rm -f \
458 %{buildroot}%{_datadir}/pixmaps/pidgin/protocols/24/sipe.png \
459 %{buildroot}%{_datadir}/pixmaps/pidgin/protocols/32/sipe.png
460 %if !%{has_pidgin}
461 # We don't have Pidgin, so we can't package icons at all
462 rm -r %{buildroot}/%{_datadir}/pixmaps/pidgin
463 %endif
464 %if 0%{?build_telepathy:1}
465 %if !0%{?build_ktp:1}
466 rm -r %{buildroot}%{_datadir}/telepathy
467 %endif
468 %endif
469 %find_lang pidgin-sipe
472 %clean
473 rm -rf %{buildroot}
476 %if 0%{?build_telepathy:1}
477 %files -n %{purple_plugin}
478 %else
479 %files -n %{purple_plugin} -f pidgin-sipe.lang
480 %endif
481 %defattr(-,root,root,-)
482 %doc AUTHORS ChangeLog COPYING NEWS README TODO
483 %if 0%{?mingw_prefix:1}
484 %{mingw_libdir}/purple-2/libsipe.dll
485 %{mingw_libdir}/purple-2/libsipe.dll.dbgsym
486 %else
487 %{_libdir}/purple-2/libsipe.so
488 %endif
491 %if 0%{?build_telepathy:1}
492 %files -n %{empathy_files}
493 %defattr(-,root,root,-)
494 %doc AUTHORS COPYING
495 %{_datadir}/empathy/icons/hicolor/*/apps/im-sipe.png
496 %{_datadir}/empathy/icons/hicolor/*/apps/im-sipe.svg
499 %if 0%{?build_ktp:1}
500 %files -n %{ktp_files}
501 %defattr(-,root,root,-)
502 %doc AUTHORS COPYING
503 %{_datadir}/telepathy/profiles/sipe.profile
504 %endif
507 %files -n %{telepathy_plugin}
508 %defattr(-,root,root,-)
509 %doc AUTHORS ChangeLog COPYING NEWS README TODO
510 %{_datadir}/dbus-1/services/*.sipe.service
511 %{_libexecdir}/telepathy-sipe
514 %files -n %{common_files} -f pidgin-sipe.lang
515 %defattr(-,root,root,-)
516 %endif
519 %files
520 %defattr(-,root,root,-)
521 %doc AUTHORS COPYING
522 %if 0%{?mingw_prefix:1}
523 %{mingw_datadir}/pixmaps/pidgin/protocols/*/sipe.png
524 %{mingw_datadir}/pixmaps/pidgin/protocols/*/sipe.svg
525 %else
526 %if %{has_pidgin}
527 %{_datadir}/pixmaps/pidgin/protocols/*/sipe.png
528 # SLES11 defines suse_version = 1110
529 %if !0%{?suse_version} || 0%{?suse_version} >= 1120
530 %{_datadir}/pixmaps/pidgin/protocols/*/sipe.svg
531 %endif
532 %endif
533 %endif
536 %if 0%{?mingw_prefix:1}
537 %files -n %{nsis_package}
538 %defattr(-, root, root)
539 /pidgin-sipe-%{version}.exe
540 %endif
543 %changelog
544 * Sat Oct 24 2015 J. D. User <jduser@noreply.com> 1.20.1
545 - update to 1.20.1
547 * Thu Sep 03 2015 J. D. User <jduser@noreply.com> 1.20.0-*git*
548 - we also support "Skype for Business"
550 * Sat Aug 29 2015 J. D. User <jduser@noreply.com> 1.20.0
551 - update to 1.20.0
553 * Sat Apr 04 2015 J. D. User <jduser@noreply.com> 1.19.1
554 - update to 1.19.1
556 * Sat Feb 07 2015 J. D. User <jduser@noreply.com> 1.19.0
557 - update to 1.19.0
559 * Tue Jan 06 2015 J. D. User <jduser@noreply.com> 1.18.5-*git*
560 - add dependency on gssntlmssp(-devel) >= 0.5.0 for F21+
562 * Mon Jan 05 2015 J. D. User <jduser@noreply.com> 1.18.5-*git*
563 - remove support for obsolete distributions
564 - Fedora < 19
565 - Mandriva
566 - OpenSUSE < 13.x
568 * Mon Dec 29 2014 J. D. User <jduser@noreply.com> 1.18.5
569 - update to 1.18.5
571 * Thu Dec 18 2014 J. D. User <jduser@noreply.com> 1.18.4-*git*
572 - improve support for CentOS & Scientific Linux
574 * Sat Oct 18 2014 J. D. User <jduser@noreply.com> 1.18.4
575 - update to 1.18.4
577 * Sat Aug 16 2014 J. D. User <jduser@noreply.com> 1.18.3
578 - update to 1.18.3
580 * Sat Jun 07 2014 J. D. User <jduser@noreply.com> 1.18.2
581 - update to 1.18.2
583 * Sat Apr 12 2014 J. D. User <jduser@noreply.com> 1.18.1
584 - update to 1.18.1
586 * Sat Mar 04 2014 J. D. User <jduser@noreply.com> 1.18.0-*git*
587 - F20+/openSUSE 12.2+ require libnice gstreamer-0.10 plugin
589 * Sat Jan 11 2014 J. D. User <jduser@noreply.com> 1.18.0
590 - update to 1.18.0
592 * Wed Dec 11 2013 J. D. User <jduser@noreply.com> 1.17.3
593 - update to 1.17.3
595 * Sat Nov 30 2013 J. D. User <jduser@noreply.com> 1.17.2
596 - update to 1.17.2
598 * Sat Nov 16 2013 J. D. User <jduser@noreply.com> 1.17.1
599 - update to 1.17.1
601 * Sat Sep 21 2013 J. D. User <jduser@noreply.com> 1.17.0
602 - update to 1.17.0
604 * Sat Jul 13 2013 J. D. User <jduser@noreply.com> 1.16.1
605 - update to 1.16.1
607 * Fri Jun 14 2013 J. D. User <jduser@noreply.com> 1.16.0
608 - update to 1.16.0
610 * Sun Apr 07 2013 J. D. User <jduser@noreply.com> 1.15.1
611 - update to 1.15.1
613 * Fri Mar 29 2013 J. D. User <jduser@noreply.com> 1.15.0-*git*
614 - update package description texts
616 * Sat Mar 09 2013 J. D. User <jduser@noreply.com> 1.15.0
617 - update to 1.15.0
619 * Wed Dec 26 2012 J. D. User <jduser@noreply.com> 1.14.1
620 - update to 1.14.1
622 * Sun Dec 16 2012 J. D. User <jduser@noreply.com> 1.14.0
623 - update to 1.14.0
625 * Tue Sep 25 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
626 - change BR gstreamer-devel to pkgconfig(gstreamer-0.10)
628 * Sun Sep 09 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
629 - BR telepathy-glib-devel >= 0.18.0
631 * Wed Sep 05 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
632 - BR telepathy-glib-devel >= 0.14.0
634 * Sun Sep 02 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
635 - really disable telepathy for Windows cross-compilation builds
637 * Thu Aug 30 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
638 - updates to enable telepathy build
640 * Sun Aug 19 2012 J. D. User <jduser@noreply.com> 1.13.3
641 - update to 1.13.3
643 * Sun Jun 10 2012 J. D. User <jduser@noreply.com> 1.13.2
644 - update to 1.13.2
646 * Mon Apr 09 2012 J. D. User <jduser@noreply.com> 1.13.1
647 - update to 1.13.1
649 * Wed Mar 14 2012 J. D. User <jduser@noreply.com> 1.13.0
650 - update to 1.13.0
652 * Mon Dec 12 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
653 - we do support Microsoft Lync Server 2010 now.
655 * Tue Dec 06 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
656 - update GPL2 license name
658 * Sat Nov 12 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
659 - add BR gmime-devel for Fedora to have at least one verification platform
661 * Sun Nov 06 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
662 - fix Mandriva 2011 unresolvable BR
664 * Mon Oct 31 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
665 - add BR nss-devel
667 * Sat Oct 01 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
668 - add NSIS package for mingw builds
670 * Sat Oct 01 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
671 - add mingw64 build
673 * Wed Sep 28 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
674 - remove BR mingw32-mozilla-nss-devel, not needed for SSPI.
676 * Mon Sep 19 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
677 - update mingw32 build
678 - update descriptions
680 * Mon Aug 29 2011 J. D. User <jduser@noreply.com> 1.12.0
681 - update to 1.12.0
683 * Wed Jun 22 2011 J. D. User <jduser@noreply.com> 1.11.2-*git*
684 - add gstreamer-devel to enable Voice & Video features
686 * Sat Dec 11 2010 J. D. User <jduser@noreply.com> 1.11.2-*git*
687 - add optional subpackage for telepathy connection manager
689 * Tue Nov 02 2010 J. D. User <jduser@noreply.com> 1.11.2
690 - update to 1.11.2
692 * Sun Oct 24 2010 J. D. User <jduser@noreply.com> 1.11.1
693 - update to 1.11.1
695 * Fri Oct 15 2010 J. D. User <jduser@noreply.com> 1.11.0-*git*
696 - add mingw32 build configuration
698 * Sun Oct 03 2010 J. D. User <jduser@noreply.com> 1.11.0
699 - update to 1.11.0
701 * Thu Sep 02 2010 J. D. User <jduser@noreply.com> pre-1.11.0-*git*
702 - Mandriva config for OBS has changed
704 * Tue May 04 2010 J. D. User <jduser@noreply.com> 1.10.0-*git*
705 - add libnice build information discovered through OBS testing
707 * Mon Apr 12 2010 J. D. User <jduser@noreply.com> 1.10.0-*git*
708 - add NSS build information discovered through OBS testing
710 * Wed Apr 04 2010 pier11 <pier11@operamail.com> 1.10.0
711 - release
713 * Fri Apr 02 2010 J. D. User <jduser@noreply.com> pre-1.10.0-*git*
714 - Mandriva has too old libtool version
716 * Fri Apr 02 2010 J. D. User <jduser@noreply.com> pre-1.10.0-*git*
717 - SLE11, openSUSE 11.0/1 don't have pidgin/protocols/scalable directory
719 * Sun Mar 07 2010 pier11 <pier11@operamail.com> pre-1.10.0-*git*
720 - OBS tests of pre-1.10.0 git-snapshot 4fa20cd65e5be0e469d4aa55d861f11c5b08b816
722 * Sun Mar 28 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
723 - added --enable/--disable build options
725 * Sun Mar 28 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
726 - removed --with-krb5 configure option as it is autodetected now
728 * Tue Mar 23 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
729 - add SVG icon
731 * Sat Mar 20 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
732 - add BR glib2-devel >= 2.12.0
734 * Wed Mar 17 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
735 - add tests to build
737 * Tue Mar 16 2010 J. D. User <jduser@noreply.com> 1.9.1
738 - update to 1.9.1
740 * Thu Mar 11 2010 J. D. User <jduser@noreply.com> 1.9.0-*git*
741 - add BR libxml2-devel
743 * Wed Mar 10 2010 pier11 <pier11@operamail.com> 1.9.0
744 - release
745 - dropped SLE 10 due to libpurple min version increase
746 - updated target distros in comment line
748 * Mon Mar 08 2010 J. D. User <jduser@noreply.com> 1.9.0-*git*
749 - increased libpurple build requisite to >= 2.4.0
751 * Sun Mar 07 2010 pier11 <pier11@operamail.com> pre-1.9.0-*git*
752 - OBS tests of pre-1.9.0 git-snapshot 61ea0856855483b9e18f23a87afe47437e526f0e
754 * Sun Mar 07 2010 J. D. User <jduser@noreply.com> 1.8.1-*git*
755 - sync with RPM SPEC from contrib/rpm
757 * Sun Feb 08 2010 pier11 <pier11@operamail.com> 1.8.0
758 - source is an original 1.8.0 with patch: git(upstream) 9c34cc3557daa3d61a002002492c71d0343c8cae
759 - temp hack - renamed source in spec from .bz2 to .gz as the latter was prepared with the patch.
761 * Sun Nov 22 2009 pier11 <pier11@operamail.com> 1.7.1
762 - reinstated enable-quality-check
764 * Wed Nov 04 2009 John Beranek <john@redux.org.uk> 1.7.0
765 - Spec file modifications to allow SLES/D 10 and Mandriva 2009.1 builds
767 * Tue Nov 03 2009 John Beranek <john@redux.org.uk> 1.7.0
768 - Spec file modifications for openSUSE build service
770 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
771 - move non-Pidgin files to new sub-package purple-sipe
773 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
774 - remove directory for emoticon theme icons
776 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
777 - libpurple protocol plugins are located under %%{_libdir}/purple-2
779 * Mon Sep 28 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
780 - added directory for emoticon theme icons
782 * Wed Sep 09 2009 J. D. User <jduser@noreply.com> 1.6.3
783 - update to 1.6.3
785 * Fri Aug 28 2009 J. D. User <jduser@noreply.com> 1.6.2-*git*
786 - reduce libpurple-devel requirement to >= 2.3.1
788 * Mon Aug 24 2009 J. D. User <jduser@noreply.com> 1.6.2
789 - update to 1.6.2
791 * Fri Aug 21 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
792 - reduce libpurple-devel requirement to >= 2.4.1
794 * Mon Aug 17 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
795 - com_err.h only required for kerberos
797 * Tue Aug 11 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
798 - require libpurple-devel >= 2.5.0
800 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
801 - refactor configure parameters
802 - make kerberos configurable
803 - don't hard code prefix for git builds
805 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
806 - removed unnecessary zlib-devel
808 * Sat Aug 08 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
809 - fix prefix for git builds
811 * Sat Aug 01 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
812 - append -Wno-unused-parameter for GCC <4.4 compilation errors
814 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
815 - remove duplicate GPL2
817 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
818 - use "--with git" to build from git
819 - corrected download URL for release archive
820 - add missing BR gettext-devel
822 * Wed Jul 29 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
823 - use default rpmbuild CFLAGS also for git builds
824 - merge with SPEC files created by mricon & jberanek
826 * Tue Jul 28 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
827 - initial RPM SPEC example generated