3 include /usr
/share
/cdbs
/1/class
/autotools.mk
4 include /usr
/share
/cdbs
/1/rules
/debhelper.mk
6 DEB_CONFIGURE_EXTRA_FLAGS
:= --enable-purple
7 # detect if package telepathy-glib is available
8 ifneq ($(shell pkg-config
--exists telepathy-glib
&& echo FOUND
),)
9 DEB_CONFIGURE_EXTRA_FLAGS
+= --enable-telepathy
11 DEB_CONFIGURE_EXTRA_FLAGS
+= --disable-telepathy
15 DEB_MAKE_CHECK_TARGET
:= check
17 # don't run unnecessary ldconfig on postinst and postrm.
18 DEB_DH_MAKESHLIBS_ARGS_pidgin-sipe
=-n
23 # git snapshot does not contain a configure script
24 debian
/stamp-autotools-files
: $(DEB_CONFIGURE_SCRIPT
)
25 $(DEB_BUILDDIR
)/config.status
: $(DEB_CONFIGURE_SCRIPT
)
27 $(DEB_CONFIGURE_SCRIPT
):
30 binary-post-install
/pidgin-sipe
::
31 rm -f debian
/pidgin-sipe
/usr
/share
/doc
/pidgin-sipe
/README
32 rm -r debian
/pidgin-sipe
/usr
/share
/pixmaps
/pidgin
/protocols
/24
33 rm -r debian
/pidgin-sipe
/usr
/share
/pixmaps
/pidgin
/protocols
/32
34 rm debian
/pidgin-sipe
/usr
/lib
/purple-2
/libsipe.la
36 .PHONY
: update-debian-control