mingw: tests compilation and run
[siplcs.git] / contrib / opensuse-build-service / pidgin-sipe.spec
blob0a220ae3963a03ba90af5f3ffc2e427523da2fb1
2 # OBS SPEC file to generate a RPM for pidgin-sipe.
3 # It should work on Fedora 9/10/11/12, openSUSE 11.x, RHEL5/CentOS 5, SLES/D 11 and Mandriva 2009.1/2010.
6 %define purple_plugin libpurple-plugin-sipe
8 %define purple_develname libpurple-devel
10 %if 0%{?mandriva_version} >= 200910
11 %ifarch x86_64
12 %define purple_develname lib64purple-devel
13 %endif
14 %endif
16 %if 0%{?suse_version} || 0%{?sles_version}
17 %define pkg_group Productivity/Networking/Instant Messenger
18 %endif
19 %if 0%{?fedora_version}
20 %define pkg_group Applications/Internet
21 %endif
22 %if 0%{?mandriva_version}
23 %define pkg_group Networking/Instant messaging
24 %else
25 %define pkg_group Applications/Internet
26 %endif
28 Name: pidgin-sipe
29 Summary: Pidgin protocol plugin to connect to MS Office Communicator
30 Version: 1.9.1
31 Release: 1
32 Source: %{name}-%{version}.tar.gz
33 Group: %{pkg_group}
34 License: GPLv2+
35 URL: http://sipe.sourceforge.net/
37 BuildRoot: %{_tmppath}/%{name}-%{version}-build
39 BuildRequires: %{purple_develname} >= 2.4.0
40 BuildRequires: glib2-devel >= 2.12.0
41 BuildRequires: libxml2-devel
42 BuildRequires: libtool
43 BuildRequires: intltool
44 BuildRequires: gettext-devel
46 # Configurable components
47 %if !0%{?_without_kerberos:1}
48 %define config_krb5 --with-krb5
49 BuildRequires: krb5-devel
50 %endif
52 # For directory ownership
53 BuildRequires: pidgin
54 Requires: %{purple_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
55 Requires: pidgin
56 %if 0%{?sles_version} == 10
57 BuildRequires: gnome-keyring-devel
58 %endif
60 %description
61 A third-party plugin for the Pidgin multi-protocol instant messenger.
62 It implements the extended version of SIP/SIMPLE used by various products:
64 * Microsoft Office Communications Server (OCS 2007/2007 R2 and newer)
65 * Microsoft Live Communications Server (LCS 2003/2005)
66 * Reuters Messaging
68 With this plugin you should be able to replace your Microsoft Office
69 Communicator client with Pidgin.
71 This package provides the icon set for Pidgin.
74 %package -n %{purple_plugin}
75 Summary: Libpurple protocol plugin to connect to MS Office Communicator
76 Group: %{pkg_group}
77 License: GPLv2+
78 Obsoletes: purple-sipe
80 %description -n %{purple_plugin}
81 A third-party plugin for the Pidgin multi-protocol instant messenger.
82 It implements the extended version of SIP/SIMPLE used by various products:
84 * Microsoft Office Communications Server (OCS 2007/2007 R2 and newer)
85 * Microsoft Live Communications Server (LCS 2003/2005)
86 * Reuters Messaging
88 This package provides the protocol plugin for libpurple clients.
91 %prep
92 %setup -q
94 %build
95 %define config_params %{?config_krb5:%{config_krb5}}
96 %if 0%{?sles_version} == 10
97 export CFLAGS="%optflags -I%{_includedir}/gssapi"
98 %endif
99 %configure %{config_params}
100 make %{_smp_mflags}
101 make %{_smp_mflags} check
104 %install
105 %makeinstall
106 find %{buildroot} -type f -name "*.la" -delete -print
107 %find_lang %{name}
110 %clean
111 rm -rf %{buildroot}
114 %files -n %{purple_plugin} -f %{name}.lang
115 %defattr(-,root,root,-)
116 %doc AUTHORS ChangeLog COPYING NEWS README TODO
117 %{_libdir}/purple-2/libsipe.so
120 %files
121 %defattr(-,root,root,-)
122 %doc AUTHORS COPYING
123 %{_datadir}/pixmaps/pidgin/protocols/*/sipe.png
124 %{_datadir}/pixmaps/pidgin/protocols/*/sipe.svg
127 %changelog
128 * Tue Mar 23 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
129 - add SVG icon
131 * Sat Mar 20 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
132 - add BR glib2-devel >= 2.12.0
134 * Wed Mar 17 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
135 - add tests to build
137 * Tue Mar 16 2010 J. D. User <jduser@noreply.com> 1.9.1
138 - update to 1.9.1
140 * Thu Mar 11 2010 J. D. User <jduser@noreply.com> 1.9.0-*git*
141 - add BR libxml2-devel
143 * Wed Mar 10 2010 pier11 <pier11@operamail.com> 1.9.0
144 - release
145 - dropped SLE 10 due to libpurple min version increase
146 - updated target distros in comment line
148 * Mon Mar 08 2010 J. D. User <jduser@noreply.com> 1.9.0-*git*
149 - increased libpurple build requisite to >= 2.4.0
151 * Sun Mar 07 2010 pier11 <pier11@operamail.com> pre-1.9.0-*git*
152 - OBS tests of pre-1.9.0 git-snapshot 61ea0856855483b9e18f23a87afe47437e526f0e
154 * Sun Mar 07 2010 J. D. User <jduser@noreply.com> 1.8.1-*git*
155 - sync with RPM SPEC from contrib/rpm
157 * Sun Feb 08 2010 pier11 <pier11@operamail.com> 1.8.0
158 - source is an original 1.8.0 with patch: git(upstream) 9c34cc3557daa3d61a002002492c71d0343c8cae
159 - temp hack - renamed source in spec from .bz2 to .gz as the latter was prepared with the patch.
161 * Sun Nov 22 2009 pier11 <pier11@operamail.com> 1.7.1
162 - reinstated enable-quality-check
164 * Wed Nov 04 2009 John Beranek <john@redux.org.uk> 1.7.0
165 - Spec file modifications to allow SLES/D 10 and Mandriva 2009.1 builds
167 * Tue Nov 03 2009 John Beranek <john@redux.org.uk> 1.7.0
168 - Spec file modifications for openSUSE build service
170 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
171 - move non-Pidgin files to new sub-package purple-sipe
173 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
174 - remove directory for emoticon theme icons
176 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
177 - libpurple protocol plugins are located under %%{_libdir}/purple-2
179 * Mon Sep 28 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
180 - added directory for emoticon theme icons
182 * Wed Sep 09 2009 J. D. User <jduser@noreply.com> 1.6.3
183 - update to 1.6.3
185 * Fri Aug 28 2009 J. D. User <jduser@noreply.com> 1.6.2-*git*
186 - reduce libpurple-devel requirement to >= 2.3.1
188 * Mon Aug 24 2009 J. D. User <jduser@noreply.com> 1.6.2
189 - update to 1.6.2
191 * Fri Aug 21 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
192 - reduce libpurple-devel requirement to >= 2.4.1
194 * Mon Aug 17 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
195 - com_err.h only required for kerberos
197 * Tue Aug 11 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
198 - require libpurple-devel >= 2.5.0
200 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
201 - refactor configure parameters
202 - make kerberos configurable
203 - don't hard code prefix for git builds
205 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
206 - removed unnecessary zlib-devel
208 * Sat Aug 08 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
209 - fix prefix for git builds
211 * Sat Aug 01 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
212 - append -Wno-unused-parameter for GCC <4.4 compilation errors
214 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
215 - remove duplicate GPL2
217 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
218 - use "--with git" to build from git
219 - corrected download URL for release archive
220 - add missing BR gettext-devel
222 * Wed Jul 29 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
223 - use default rpmbuild CFLAGS also for git builds
224 - merge with SPEC files created by mricon & jberanek
226 * Tue Jul 28 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
227 - initial RPM SPEC example generated