2 # OBS SPEC file to generate a RPM for pidgin-sipe.
3 # It should work on Fedora 9/10/11/12, openSUSE 11.x, RHEL5/CentOS 5, SLES/D 11 and Mandriva 2009.1/2010.
6 %define purple_plugin libpurple
-plugin
-sipe
8 %define purple_develname libpurple
-devel
10 %if 0%{?mdkversion} >= 200910
12 %define purple_develname lib64purple
-devel
14 %if 0%{?mdkversion} >= 201000
22 %define nss_develname mozilla
-nss
-devel
23 %if 0%{?suse_version} >= 1120
27 %define nss_develname nss
-devel
30 %if 0%{?suse_version} || 0%{?sles_version}
31 %define pkg_group Productivity
/Networking
/Instant Messenger
34 %define pkg_group Applications
/Internet
40 %define pkg_group Networking
/Instant messaging
42 %define pkg_group Applications
/Internet
46 Summary: Pidgin protocol plugin to connect to MS Office Communicator
49 Source: %{name}-%{version}.tar.gz
52 URL: http
://sipe.sourceforge.net
/
54 BuildRoot: %{_tmppath}/%{name}-%{version}-build
56 BuildRequires
: %{purple_develname} >= 2.4.0
57 BuildRequires
: glib2
-devel
>= 2.12.0
58 BuildRequires
: libxml2
-devel
59 #BuildRequires: %{nss_develname}
60 BuildRequires
: libtool
61 BuildRequires
: intltool
62 BuildRequires
: gettext
-devel
63 %if 0%{?has_libnice:1}
64 BuildRequires
: libnice
-devel
67 # Configurable components
68 %if !0%{?_without_kerberos:1}
69 BuildRequires
: krb5
-devel
72 # For directory ownership
74 Requires: %{purple_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
76 %if 0%{?sles_version} == 10
77 BuildRequires
: gnome
-keyring
-devel
80 # For OBS's "have choice for" for Fedora 11 (only)
81 %if 0%{?fedora_version} == 11
82 BuildRequires
: libproxy
-mozjs
83 BuildRequires
: PolicyKit
-gnome
86 # For OBS's "have choice for" for Mandriva 2010.1 (and up?)
87 %if 0%{?mdkversion} >= 201010
88 BuildRequires
: polkit
-gnome
92 A third
-party plugin
for the Pidgin multi
-protocol instant messenger.
93 It implements the extended version of SIP
/SIMPLE used by various products
:
95 * Microsoft Office Communications Server
(OCS
2007/2007 R2 and newer
)
96 * Microsoft Live Communications Server
(LCS
2003/2005)
99 With this plugin you should be able to replace your Microsoft Office
100 Communicator client with Pidgin.
102 This package provides the icon
set for Pidgin.
105 %package -n
%{purple_plugin}
106 Summary: Libpurple protocol plugin to connect to MS Office Communicator
109 Obsoletes
: purple
-sipe
111 %description -n
%{purple_plugin}
112 A third
-party plugin
for the Pidgin multi
-protocol instant messenger.
113 It implements the extended version of SIP
/SIMPLE used by various products
:
115 * Microsoft Office Communications Server
(OCS
2007/2007 R2 and newer
)
116 * Microsoft Live Communications Server
(LCS
2003/2005)
119 This package provides the protocol plugin
for libpurple clients.
126 %if 0%{?sles_version} == 10
127 export CFLAGS
="
%optflags -I
%{_includedir}/gssapi"
130 autoreconf
--verbose
--install --force
136 make %{_smp_mflags} check
141 find
%{buildroot} -type f
-name "
*.la"
-delete
-print
142 # SLES11 defines suse_version = 1110
143 %if 0%{?suse_version} && 0%{?suse_version} < 1120
144 rm -r
%{buildroot}/%{_datadir}/pixmaps
/pidgin
/protocols
/scalable
153 %files -n
%{purple_plugin} -f %{name}.lang
154 %defattr(-,root
,root
,-)
155 %doc AUTHORS ChangeLog COPYING NEWS README TODO
156 %{_libdir}/purple
-2/libsipe.so
160 %defattr(-,root
,root
,-)
162 %{_datadir}/pixmaps
/pidgin
/protocols
/*/sipe.png
163 # SLES11 defines suse_version = 1110
164 %if !0%{?suse_version} || 0%{?suse_version} >= 1120
165 %{_datadir}/pixmaps
/pidgin
/protocols
/*/sipe.svg
170 * ??? ??? ??
2010 J. D. User
<jduser@noreply.com
> 1.11.0
173 * Thu Sep
02 2010 J. D. User
<jduser@noreply.com
> pre
-1.11.0-*git
*
174 - Mandriva config
for OBS has changed
176 * Tue May
04 2010 J. D. User
<jduser@noreply.com
> 1.10.0-*git
*
177 - add libnice build information discovered through OBS testing
179 * Mon Apr
12 2010 J. D. User
<jduser@noreply.com
> 1.10.0-*git
*
180 - add NSS build information discovered through OBS testing
182 * Wed Apr
04 2010 pier11
<pier11@operamail.com
> 1.10.0
185 * Fri Apr
02 2010 J. D. User
<jduser@noreply.com
> pre
-1.10.0-*git
*
186 - Mandriva has too old libtool version
188 * Fri Apr
02 2010 J. D. User
<jduser@noreply.com
> pre
-1.10.0-*git
*
189 - SLE11
, openSUSE
11.0/1 don't have pidgin
/protocols
/scalable directory
191 * Sun Mar
07 2010 pier11
<pier11@operamail.com
> pre
-1.10.0-*git
*
192 - OBS tests of pre
-1.10.0 git
-snapshot
4fa20cd65e5be0e469d4aa55d861f11c5b08b816
194 * Sun Mar
28 2010 J. D. User
<jduser@noreply.com
> 1.9.1-*git
*
195 - added
--enable/--disable build options
197 * Sun Mar
28 2010 J. D. User
<jduser@noreply.com
> 1.9.1-*git
*
198 - removed
--with
-krb5 configure option as it is autodetected now
200 * Tue Mar
23 2010 J. D. User
<jduser@noreply.com
> 1.9.1-*git
*
203 * Sat Mar
20 2010 J. D. User
<jduser@noreply.com
> 1.9.1-*git
*
204 - add BR glib2
-devel
>= 2.12.0
206 * Wed Mar
17 2010 J. D. User
<jduser@noreply.com
> 1.9.1-*git
*
209 * Tue Mar
16 2010 J. D. User
<jduser@noreply.com
> 1.9.1
212 * Thu Mar
11 2010 J. D. User
<jduser@noreply.com
> 1.9.0-*git
*
213 - add BR libxml2
-devel
215 * Wed Mar
10 2010 pier11
<pier11@operamail.com
> 1.9.0
217 - dropped SLE
10 due to libpurple min version increase
218 - updated target distros
in comment line
220 * Mon Mar
08 2010 J. D. User
<jduser@noreply.com
> 1.9.0-*git
*
221 - increased libpurple build requisite to
>= 2.4.0
223 * Sun Mar
07 2010 pier11
<pier11@operamail.com
> pre
-1.9.0-*git
*
224 - OBS tests of pre
-1.9.0 git
-snapshot
61ea0856855483b9e18f23a87afe47437e526f0e
226 * Sun Mar
07 2010 J. D. User
<jduser@noreply.com
> 1.8.1-*git
*
227 - sync with RPM SPEC from contrib
/rpm
229 * Sun Feb
08 2010 pier11
<pier11@operamail.com
> 1.8.0
230 - source is an original
1.8.0 with patch
: git
(upstream
) 9c34cc3557daa3d61a002002492c71d0343c8cae
231 - temp hack
- renamed
source in spec from .bz2 to .gz as the latter was prepared with the patch.
233 * Sun Nov
22 2009 pier11
<pier11@operamail.com
> 1.7.1
234 - reinstated
enable-quality
-check
236 * Wed Nov
04 2009 John Beranek
<john@redux.org.uk
> 1.7.0
237 - Spec file modifications to allow SLES
/D
10 and Mandriva
2009.1 builds
239 * Tue Nov
03 2009 John Beranek
<john@redux.org.uk
> 1.7.0
240 - Spec file modifications
for openSUSE build service
242 * Sun Oct
11 2009 J. D. User
<jduser@noreply.com
> 1.6.3-*git
*
243 - move non
-Pidgin files to new sub
-package purple
-sipe
245 * Sun Oct
11 2009 J. D. User
<jduser@noreply.com
> 1.6.3-*git
*
246 - remove directory
for emoticon theme icons
248 * Sun Oct
11 2009 J. D. User
<jduser@noreply.com
> 1.6.3-*git
*
249 - libpurple protocol plugins are located under %
%{_libdir}/purple
-2
251 * Mon Sep
28 2009 J. D. User
<jduser@noreply.com
> 1.6.3-*git
*
252 - added directory
for emoticon theme icons
254 * Wed Sep
09 2009 J. D. User
<jduser@noreply.com
> 1.6.3
257 * Fri Aug
28 2009 J. D. User
<jduser@noreply.com
> 1.6.2-*git
*
258 - reduce libpurple
-devel requirement to
>= 2.3.1
260 * Mon Aug
24 2009 J. D. User
<jduser@noreply.com
> 1.6.2
263 * Fri Aug
21 2009 J. D. User
<jduser@noreply.com
> 1.6.1-*git
*
264 - reduce libpurple
-devel requirement to
>= 2.4.1
266 * Mon Aug
17 2009 J. D. User
<jduser@noreply.com
> 1.6.1-*git
*
267 - com_err.h only required
for kerberos
269 * Tue Aug
11 2009 J. D. User
<jduser@noreply.com
> 1.6.0-*git
*
270 - require libpurple
-devel
>= 2.5.0
272 * Sun Aug
09 2009 J. D. User
<jduser@noreply.com
> 1.6.0-*git
*
273 - refactor configure parameters
274 - make kerberos configurable
275 - don't hard code prefix
for git builds
277 * Sun Aug
09 2009 J. D. User
<jduser@noreply.com
> 1.6.0-*git
*
278 - removed unnecessary zlib
-devel
280 * Sat Aug
08 2009 J. D. User
<jduser@noreply.com
> 1.6.0-*git
*
281 - fix prefix
for git builds
283 * Sat Aug
01 2009 J. D. User
<jduser@noreply.com
> 1.6.0-*git
*
284 - append
-Wno
-unused
-parameter
for GCC
<4.4 compilation errors
286 * Thu Jul
30 2009 J. D. User
<jduser@noreply.com
> 1.6.0-*git
*
287 - remove duplicate GPL2
289 * Thu Jul
30 2009 J. D. User
<jduser@noreply.com
> 1.6.0-*git
*
290 - use "
--with git" to build from git
291 - corrected download
URL for release archive
292 - add missing BR gettext
-devel
294 * Wed Jul
29 2009 J. D. User
<jduser@noreply.com
> 1.6.0-*git
*
295 - use default rpmbuild CFLAGS also
for git builds
296 - merge with SPEC files created by mricon
& jberanek
298 * Tue Jul
28 2009 J. D. User
<jduser@noreply.com
> 1.6.0-*git
*
299 - initial RPM SPEC example generated