Release 1.23.2 -- Bug Fixes II
[siplcs.git] / contrib / opensuse-build-service / pidgin-sipe.spec
blob04bc0529485ad6b7261ec6191d10c4b73b8bc648
2 # OBS SPEC file to generate a RPM for pidgin-sipe.
4 # It has support for:
6 # RedHat family (CentOS, Fedora, RHEL, ScientificLinux)
7 # SUSE family (openSUSE, SLED, SLES)
8 # Mageia
9 # Windows (mingw32, mingw64)
12 # Build options
13 %undefine build_telepathy
15 # Check for mingw32 cross compilation build
17 # Manually add this repository to your private OBS project:
19 # <repository name="mingw32">
20 # <path repository="openSUSE_13.2" project="windows:mingw:win32"/>
21 # <arch>i586</arch>
22 # </repository>
24 %if "%{_repository}" == "mingw32"
25 %define purple_sipe_mingw32 1
26 %define mingw_prefix mingw32-
27 %define mingw_cache %{_mingw32_cache}
28 %define mingw_configure %{_mingw32_configure}
29 %define mingw_datadir %{_mingw32_datadir}
30 %define mingw_debug_package %{_mingw32_debug_package}
31 %define mingw_ldflags MINGW32_LDFLAGS
32 %define mingw_libdir %{_mingw32_libdir}
33 %define mingw_make %{_mingw32_make}
34 %define mingw_makeinstall %{_mingw32_makeinstall}
35 %define __strip %{_mingw32_strip}
36 %define __objdump %{_mingw32_objdump}
37 %define _use_internal_dependency_generator 0
38 %define __find_requires %{_mingw32_findrequires}
39 %define __find_provides %{_mingw32_findprovides}
40 %define __os_install_post %{_mingw32_debug_install_post} \
41 %{_mingw32_install_post}
42 %endif
44 # Check for mingw64 cross compilation build
46 # Manually add this repository to your private OBS project:
48 # <repository name="mingw64">
49 # <path repository="openSUSE_13.2" project="windows:mingw:win64"/>
50 # <arch>i586</arch>
51 # </repository>
53 %if "%{_repository}" == "mingw64"
54 %define purple_sipe_mingw64 1
55 %define mingw_prefix mingw64-
56 %define mingw_cache %{_mingw64_cache}
57 %define mingw_configure %{_mingw64_configure}
58 %define mingw_datadir %{_mingw64_datadir}
59 %define mingw_debug_package %{_mingw64_debug_package}
60 %define mingw_ldflags MINGW64_LDFLAGS
61 %define mingw_libdir %{_mingw64_libdir}
62 %define mingw_make %{_mingw64_make}
63 %define mingw_makeinstall %{_mingw64_makeinstall}
64 %define __strip %{_mingw64_strip}
65 %define __objdump %{_mingw64_objdump}
66 %define _use_internal_dependency_generator 0
67 %define __find_requires %{_mingw64_findrequires}
68 %define __find_provides %{_mingw64_findprovides}
69 %define __os_install_post %{_mingw64_debug_install_post} \
70 %{_mingw64_install_post}
71 %endif
73 %define purple_plugin %{?mingw_prefix:%{mingw_prefix}}libpurple-plugin-sipe
74 %define telepathy_plugin %{?mingw_prefix:%{mingw_prefix}}telepathy-plugin-sipe
75 %define nsis_package %{?mingw_prefix:%{mingw_prefix}}pidgin-sipe-nsis
76 %define common_files sipe-common
77 %define empathy_files empathy-sipe
78 %define ktp_files ktp-accounts-kcm-sipe
81 %define has_pidgin 1
83 %if 0%{?mageia}
84 %define has_appdata 1
85 %define has_gstreamer 1
86 %endif
88 %if 0%{?suse_version}
89 %define has_appdata 1
90 %define has_gstreamer 1
91 %define build_telepathy 1
92 %endif
94 %if 0%{?suse_version} || 0%{?sles_version}
95 %define pkg_group Productivity/Networking/Instant Messenger
96 %else
97 %define pkg_group Applications/Communications
98 %endif
100 # workaround for Fedora Rawhide
101 %if 0%{?fedora_version}
102 %if 0%{?fedora}
103 %else
104 %define fedora %{?fedora_version}
105 %endif
106 %endif
108 %if 0%{?fedora}
109 %define has_appdata 1
110 %define has_gssntlmssp 1
111 %define has_gstreamer 1
112 %define build_telepathy 1
113 %define build_ktp 1
114 %endif
116 %if 0%{?centos_version} || 0%{?scientificlinux_version}
117 %define has_krb5devel 1
118 %define rhel_base_version %{?centos_version}%{?scientificlinux_version}
119 %if %{rhel_base_version} >= 700
120 # pidgin has been removed, but libpurple still exists
121 %define has_pidgin 0
122 %endif
123 %endif
125 %if 0%{?purple_sipe_mingw32}
126 Name: mingw32-pidgin-sipe
127 %else
128 %if 0%{?purple_sipe_mingw64}
129 Name: mingw64-pidgin-sipe
130 %else
131 Name: pidgin-sipe
132 %endif
133 %endif
134 Summary: Pidgin protocol plugin to connect to MS Office Communicator
135 Version: 1.23.2
136 Release: 1
137 Source: pidgin-sipe-%{version}.tar.gz
138 Group: %{pkg_group}
139 License: GPLv2+
140 URL: http://sipe.sourceforge.net/
142 BuildRoot: %{_tmppath}/%{name}-%{version}-build
144 %if 0%{?mingw_prefix:1}
146 # Windows cross-compilation build setup
148 BuildArch: noarch
149 #!BuildIgnore: post-build-checks
151 BuildRequires: libtool
152 BuildRequires: intltool
153 BuildRequires: %{mingw_prefix}filesystem >= 23
154 BuildRequires: %{mingw_prefix}cross-gcc
155 BuildRequires: %{mingw_prefix}cross-binutils
156 BuildRequires: %{mingw_prefix}gettext-runtime
157 BuildRequires: %{mingw_prefix}cross-pkg-config
158 BuildRequires: %{mingw_prefix}glib2-devel >= 2.18.0
159 BuildRequires: %{mingw_prefix}libxml2-devel
160 BuildRequires: %{mingw_prefix}mozilla-nss-devel
161 BuildRequires: %{mingw_prefix}libpurple-devel >= 2.7.0
162 BuildRequires: %{mingw_prefix}cross-nsis
164 # For directory ownership
165 BuildRequires: %{mingw_prefix}pidgin
167 # Make sure telepathy is disabled for Windows builds
168 %undefine build_telepathy
170 %else
172 # Standard Linux build setup
174 BuildRequires: libtool
175 BuildRequires: intltool
176 BuildRequires: pkgconfig(dbus-1)
177 BuildRequires: pkgconfig(glib-2.0) >= 2.18.0
178 BuildRequires: pkgconfig(gmodule-2.0) >= 2.18.0
179 BuildRequires: pkgconfig(libxml-2.0)
180 BuildRequires: pkgconfig(nss)
181 BuildRequires: pkgconfig(purple) >= 2.7.0
182 %if 0%{?mageia}
183 # It seems linking against -lpurple is severely broken on Mageia...
184 BuildRequires: pkgconfig(libgadu)
185 %endif
186 %if 0%{?has_gstreamer:1}
187 BuildRequires: pkgconfig(farstream-0.2)
188 BuildRequires: pkgconfig(gio-2.0)
189 BuildRequires: pkgconfig(gstreamer-1.0)
190 BuildRequires: pkgconfig(gstreamer-rtp-1.0)
191 BuildRequires: pkgconfig(nice) >= 0.1.0
192 %endif
193 # Requirements for telepathy backend
194 %if 0%{?build_telepathy:1}
195 BuildRequires: gmime-devel
196 BuildRequires: pkgconfig(dbus-glib-1)
197 BuildRequires: pkgconfig(gio-2.0) >= 2.32.0
198 BuildRequires: pkgconfig(glib-2.0) >= 2.32.0
199 BuildRequires: pkgconfig(gobject-2.0)
200 BuildRequires: pkgconfig(telepathy-glib) >= 0.18.0
201 %endif
203 # Configurable components
204 # Use "--without kerberos" to disable krb5
205 %if !0%{?_without_kerberos:1}
206 %if 0%{?has_krb5devel:1}
207 BuildRequires: krb5-devel
208 %else
209 BuildRequires: pkgconfig(krb5)
210 %endif
211 %if 0%{?has_gssntlmssp:1}
212 BuildRequires: gssntlmssp-devel >= 0.5.0
213 Requires: gssntlmssp >= 0.5.0
214 %endif
215 %endif
217 # For directory ownership
218 %if %{has_pidgin}
219 BuildRequires: pidgin
220 Requires: pidgin
221 %endif
222 %if 0%{?build_telepathy:1}
223 BuildRequires: empathy
224 %endif
226 # End Windows cross-compilation/Linux build setup
227 %endif
229 Requires: %{purple_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
232 %description
233 A third-party plugin for the Pidgin multi-protocol instant messenger.
234 It implements the extended version of SIP/SIMPLE used by various products:
236 * Skype for Business
237 * Microsoft Office 365
238 * Microsoft Business Productivity Online Suite (BPOS)
239 * Microsoft Lync Server
240 * Microsoft Office Communications Server (OCS 2007/2007 R2)
241 * Microsoft Live Communications Server (LCS 2003/2005)
243 With this plugin you should be able to replace your Microsoft Office
244 Communicator client with Pidgin.
246 This package provides the icon set for Pidgin.
249 %package -n %{purple_plugin}
250 Summary: Libpurple protocol plugin to connect to MS Office Communicator
251 Group: %{pkg_group}
252 License: GPLv2+
253 Obsoletes: purple-sipe
254 %if 0%{?build_telepathy:1}
255 Requires: %{common_files} = %{?epoch:%{epoch}:}%{version}-%{release}
256 %endif
258 %description -n %{purple_plugin}
259 A third-party plugin for the Pidgin multi-protocol instant messenger.
260 It implements the extended version of SIP/SIMPLE used by various products:
262 * Skype for Business
263 * Microsoft Office 365
264 * Microsoft Business Productivity Online Suite (BPOS)
265 * Microsoft Lync Server
266 * Microsoft Office Communications Server (OCS 2007/2007 R2)
267 * Microsoft Live Communications Server (LCS 2003/2005)
269 This package provides the protocol plugin for libpurple clients.
272 %if 0%{?build_telepathy:1}
273 %package -n %{empathy_files}
274 Summary: Telepathy connection manager to connect to MS Office Communicator
275 Group: %{pkg_group}
276 License: GPLv2+
277 Requires: empathy
278 Requires: %{telepathy_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
280 %description -n %{empathy_files}
281 A Telepathy connection manager that implements the extended version of
282 SIP/SIMPLE used by various products:
284 * Skype for Business
285 * Microsoft Office 365
286 * Microsoft Business Productivity Online Suite (BPOS)
287 * Microsoft Lync Server
288 * Microsoft Office Communications Server (OCS 2007/2007 R2)
289 * Microsoft Live Communications Server (LCS 2003/2005)
291 This package provides the icon set for Empathy.
294 %if 0%{?build_ktp:1}
295 %package -n %{ktp_files}
296 Summary: Telepathy connection manager to connect to MS Office Communicator
297 Group: %{pkg_group}
298 License: GPLv2+
299 Requires: %{telepathy_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
301 %description -n %{ktp_files}
302 A Telepathy connection manager that implements the extended version of
303 SIP/SIMPLE used by various products:
305 * Skype for Business
306 * Microsoft Office 365
307 * Microsoft Business Productivity Online Suite (BPOS)
308 * Microsoft Lync Server
309 * Microsoft Office Communications Server (OCS 2007/2007 R2)
310 * Microsoft Live Communications Server (LCS 2003/2005)
312 This package provides the profile for KTP account manager.
313 %endif
316 %package -n %{telepathy_plugin}
317 Summary: Telepathy connection manager to connect to MS Office Communicator
318 Group: %{pkg_group}
319 License: GPLv2+
320 Requires: %{common_files} = %{?epoch:%{epoch}:}%{version}-%{release}
322 %description -n %{telepathy_plugin}
323 A Telepathy connection manager that implements the extended version of
324 SIP/SIMPLE used by various products:
326 * Skype for Business
327 * Microsoft Office 365
328 * Microsoft Business Productivity Online Suite (BPOS)
329 * Microsoft Lync Server
330 * Microsoft Office Communications Server (OCS 2007/2007 R2)
331 * Microsoft Live Communications Server (LCS 2003/2005)
333 This package provides the protocol support for Telepathy clients.
336 %package -n %{common_files}
337 Summary: Common files for SIPE protocol plugins
338 Group: %{pkg_group}
339 License: GPLv2+
340 BuildArch: noarch
342 %description -n %{common_files}
343 This package provides common files for the SIPE protocol plugins:
345 * Localisation
346 %endif
349 %if 0%{?mingw_prefix:1}
350 %package -n %{nsis_package}
351 Summary: Windows Pidgin protocol plugin to connect to MS Office Communicator
352 Group: %{pkg_group}
353 License: GPLv2+
355 %description -n %{nsis_package}
356 A third-party plugin for the Pidgin multi-protocol instant messenger.
357 It implements the extended version of SIP/SIMPLE used by various products:
359 * Skype for Business
360 * Microsoft Office 365
361 * Microsoft Business Productivity Online Suite (BPOS)
362 * Microsoft Lync Server
363 * Microsoft Office Communications Server (OCS 2007/2007 R2)
364 * Microsoft Live Communications Server (LCS 2003/2005)
366 This package contains the NSIS installer package of the protocol plugin
367 for Pidgin on Windows.
368 %endif
371 %{mingw_debug_package}
374 %prep
375 %setup -q -n pidgin-sipe-%{version}
377 %build
378 %if 0%{?mingw_prefix:1}
380 # Windows cross-compilation build
382 %{?env_options}
383 echo "lt_cv_deplibs_check_method='pass_all'" >>%{mingw_cache}
384 autoreconf --verbose --install --force
385 %{mingw_ldflags}="-Wl,--exclude-libs=libintl.a -Wl,--exclude-libs=libiconv.a -lws2_32"
386 %{mingw_configure} \
387 --enable-purple \
388 %if 0%{?build_telepathy:1}
389 --enable-telepathy
390 %else
391 --disable-telepathy
392 %endif
393 %{mingw_make} %{?_smp_mflags} || %{mingw_make}
395 %else
397 # Standard Linux build
399 # Special case handling for Mageia
400 %if 0%{?mageia}
401 %configure2_5x \
402 --with-krb5 \
403 --disable-telepathy
404 %make_build
405 %make_build check
407 # All other Linuxes
408 %else
409 %configure \
410 %if !0%{?_without_kerberos:1}
411 --with-krb5 \
412 %endif
413 --enable-purple \
414 %if 0%{?build_telepathy:1}
415 --enable-telepathy
416 %else
417 --disable-telepathy
418 %endif
419 make %{?_smp_mflags}
420 make %{?_smp_mflags} check
421 %endif
423 # End Windows cross-compilation/Linux build setup
424 %endif
427 %install
428 %if 0%{?mingw_prefix:1}
430 # Windows cross-compilation install
432 %{mingw_makeinstall}
433 rm -f %{buildroot}%{mingw_libdir}/purple-2/*.dll.a
435 # generate .dbgsym file
436 rm -f %{buildroot}%{mingw_libdir}/purple-2/libsipe.dll.dbgsym
437 mv \
438 %{buildroot}%{mingw_libdir}/purple-2/libsipe.dll \
439 %{buildroot}%{mingw_libdir}/purple-2/libsipe.dll.dbgsym
440 %{__strip} --strip-unneeded \
441 %{buildroot}%{mingw_libdir}/purple-2/libsipe.dll.dbgsym \
442 -o %{buildroot}%{mingw_libdir}/purple-2/libsipe.dll \
444 # generate NSIS installer package
445 perl contrib/opensuse-build-service/generate_nsi.pl po/LINGUAS \
446 <contrib/opensuse-build-service/pidgin-sipe.nsi.template \
447 >%{buildroot}/pidgin-sipe.nsi
449 set -e; \
450 cd %{buildroot}; \
451 makensis \
452 -DPIDGIN_VERSION=UNKNOWN \
453 -DVERSION=%{version} \
454 -DMINGW_LIBDIR=%{buildroot}%{mingw_libdir} \
455 -DMINGW_DATADIR=%{buildroot}%{mingw_datadir} \
456 pidgin-sipe.nsi \
458 rm -f %{buildroot}/pidgin-sipe.nsi
460 %else
462 # Standard Linux install
464 %make_install
466 # End Windows cross-compilation/Linux build setup
467 %endif
469 find %{buildroot} -type f -name "*.la" -delete -print
470 # Pidgin doesn't have 24 or 32 pixel icons
471 rm -f \
472 %{buildroot}%{_datadir}/pixmaps/pidgin/protocols/24/sipe.png \
473 %{buildroot}%{_datadir}/pixmaps/pidgin/protocols/32/sipe.png
474 %if !0%{?has_appdata:1}
475 # We don't have AppStream, so we can't package metadata file at all
476 rm -r %{buildroot}/%{_datadir}/appdata
477 %endif
478 %if !%{has_pidgin}
479 # We don't have Pidgin, so we can't package icons at all
480 rm -r %{buildroot}/%{_datadir}/pixmaps/pidgin
481 %endif
482 %if 0%{?build_telepathy:1}
483 %if !0%{?build_ktp:1}
484 rm -r %{buildroot}%{_datadir}/telepathy
485 %endif
486 %endif
487 %find_lang pidgin-sipe
490 %clean
491 rm -rf %{buildroot}
494 %if 0%{?build_telepathy:1}
495 %files -n %{purple_plugin}
496 %else
497 %files -n %{purple_plugin} -f pidgin-sipe.lang
498 %endif
499 %defattr(-,root,root,-)
500 %doc AUTHORS ChangeLog COPYING NEWS README TODO
501 %if 0%{?mingw_prefix:1}
502 %{mingw_libdir}/purple-2/libsipe.dll
503 %{mingw_libdir}/purple-2/libsipe.dll.dbgsym
504 %else
505 %{_libdir}/purple-2/libsipe.so
506 %endif
509 %if 0%{?build_telepathy:1}
510 %files -n %{empathy_files}
511 %defattr(-,root,root,-)
512 %{_datadir}/empathy/icons/hicolor/*/apps/im-sipe.png
513 %{_datadir}/empathy/icons/hicolor/*/apps/im-sipe.svg
516 %if 0%{?build_ktp:1}
517 %files -n %{ktp_files}
518 %defattr(-,root,root,-)
519 %doc AUTHORS COPYING
520 %{_datadir}/telepathy/profiles/sipe.profile
521 %endif
524 %files -n %{telepathy_plugin}
525 %defattr(-,root,root,-)
526 %doc AUTHORS ChangeLog COPYING NEWS README TODO
527 %{_datadir}/dbus-1/services/*.sipe.service
528 %{_libexecdir}/telepathy-sipe
531 %files -n %{common_files} -f pidgin-sipe.lang
532 %defattr(-,root,root,-)
533 %endif
536 %files
537 %defattr(-,root,root,-)
538 %doc AUTHORS COPYING
539 %if 0%{?mingw_prefix:1}
540 %if 0%{?has_appdata:1}
541 %{mingw_datadir}/appdata/pidgin-sipe.metainfo.xml
542 %endif
543 %{mingw_datadir}/pixmaps/pidgin/protocols/*/sipe.png
544 %{mingw_datadir}/pixmaps/pidgin/protocols/*/sipe.svg
545 %else
546 %if %{has_pidgin}
547 %if 0%{?has_appdata:1}
548 %{_datadir}/appdata/%{name}.metainfo.xml
549 %endif
550 %{_datadir}/pixmaps/pidgin/protocols/*/sipe.png
551 %{_datadir}/pixmaps/pidgin/protocols/*/sipe.svg
552 %endif
553 %endif
556 %if 0%{?mingw_prefix:1}
557 %files -n %{nsis_package}
558 %defattr(-, root, root)
559 /pidgin-sipe-%{version}.exe
560 %endif
563 %changelog
564 * Sat Mar 10 2018 J. D. User <jduser@noreply.com> 1.23.2
565 - update to 1.23.2
567 * Sun Feb 25 2018 J. D. User <jduser@noreply.com> 1.23.1
568 - update to 1.23.1
570 * Sat Oct 28 2017 J. D. User <jduser@noreply.com> 1.23.0
571 - update to 1.23.0
572 - raise BR glib-2.0 >= 2.18.0
573 - raise BR purple >= 2.7.0
575 * Fri Aug 11 2017 J. D. User <jduser@noreply.com> 1.22.1-*git*
576 - add BR dbus-1
577 - fix incorrect BR gstreamer-0.10 when gstreamer-1.0 is selected
579 * Sun Jun 11 2017 J. D. User <jduser@noreply.com> 1.22.1
580 - update to 1.22.1
582 * Wed Feb 01 2017 J. D. User <jduser@noreply.com> 1.22.0
583 - update to 1.22.0
585 * Sun Dec 18 2016 J. D. User <jduser@noreply.com> 1.21.1-*git*
586 - add BR gio-2.0
588 * Wed Jun 15 2016 J. D. User <jduser@noreply.com> 1.21.1-*git*
589 - add BR farstream-0.2
591 * Sat May 28 2016 J. D. User <jduser@noreply.com> 1.21.1
592 - update to 1.21.1
594 * Sat Apr 23 2016 J. D. User <jduser@noreply.com> 1.21.0
595 - update to 1.21.0
597 * Tue Apr 05 2016 J. D. User <jduser@noreply.com> 1.20.1-*git*
598 - align with Fedora SPEC file
600 * Fri Jan 01 2016 J. D. User <jduser@noreply.com> 1.20.1-*git*
601 - add AppStream metadata file
603 * Sun Nov 08 2015 J. D. User <jduser@noreply.com> 1.20.1-*git*
604 - add dependency on pkgconfig(gstreamer-1.0) for F22+ & Leap 42.1+
606 * Sat Oct 24 2015 J. D. User <jduser@noreply.com> 1.20.1
607 - update to 1.20.1
609 * Thu Sep 03 2015 J. D. User <jduser@noreply.com> 1.20.0-*git*
610 - we also support "Skype for Business"
612 * Sat Aug 29 2015 J. D. User <jduser@noreply.com> 1.20.0
613 - update to 1.20.0
615 * Sat Apr 04 2015 J. D. User <jduser@noreply.com> 1.19.1
616 - update to 1.19.1
618 * Sat Feb 07 2015 J. D. User <jduser@noreply.com> 1.19.0
619 - update to 1.19.0
621 * Tue Jan 06 2015 J. D. User <jduser@noreply.com> 1.18.5-*git*
622 - add dependency on gssntlmssp(-devel) >= 0.5.0 for F21+
624 * Mon Jan 05 2015 J. D. User <jduser@noreply.com> 1.18.5-*git*
625 - remove support for obsolete distributions
626 - Fedora < 19
627 - Mandriva
628 - OpenSUSE < 13.x
630 * Mon Dec 29 2014 J. D. User <jduser@noreply.com> 1.18.5
631 - update to 1.18.5
633 * Thu Dec 18 2014 J. D. User <jduser@noreply.com> 1.18.4-*git*
634 - improve support for CentOS & Scientific Linux
636 * Sat Oct 18 2014 J. D. User <jduser@noreply.com> 1.18.4
637 - update to 1.18.4
639 * Sat Aug 16 2014 J. D. User <jduser@noreply.com> 1.18.3
640 - update to 1.18.3
642 * Sat Jun 07 2014 J. D. User <jduser@noreply.com> 1.18.2
643 - update to 1.18.2
645 * Sat Apr 12 2014 J. D. User <jduser@noreply.com> 1.18.1
646 - update to 1.18.1
648 * Tue Mar 04 2014 J. D. User <jduser@noreply.com> 1.18.0-*git*
649 - F20+/openSUSE 12.2+ require libnice gstreamer-0.10 plugin
651 * Sat Jan 11 2014 J. D. User <jduser@noreply.com> 1.18.0
652 - update to 1.18.0
654 * Wed Dec 11 2013 J. D. User <jduser@noreply.com> 1.17.3
655 - update to 1.17.3
657 * Sat Nov 30 2013 J. D. User <jduser@noreply.com> 1.17.2
658 - update to 1.17.2
660 * Sat Nov 16 2013 J. D. User <jduser@noreply.com> 1.17.1
661 - update to 1.17.1
663 * Sat Sep 21 2013 J. D. User <jduser@noreply.com> 1.17.0
664 - update to 1.17.0
666 * Sat Jul 13 2013 J. D. User <jduser@noreply.com> 1.16.1
667 - update to 1.16.1
669 * Fri Jun 14 2013 J. D. User <jduser@noreply.com> 1.16.0
670 - update to 1.16.0
672 * Sun Apr 07 2013 J. D. User <jduser@noreply.com> 1.15.1
673 - update to 1.15.1
675 * Fri Mar 29 2013 J. D. User <jduser@noreply.com> 1.15.0-*git*
676 - update package description texts
678 * Sat Mar 09 2013 J. D. User <jduser@noreply.com> 1.15.0
679 - update to 1.15.0
681 * Wed Dec 26 2012 J. D. User <jduser@noreply.com> 1.14.1
682 - update to 1.14.1
684 * Sun Dec 16 2012 J. D. User <jduser@noreply.com> 1.14.0
685 - update to 1.14.0
687 * Tue Sep 25 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
688 - change BR gstreamer-devel to pkgconfig(gstreamer-0.10)
690 * Sun Sep 09 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
691 - BR telepathy-glib-devel >= 0.18.0
693 * Wed Sep 05 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
694 - BR telepathy-glib-devel >= 0.14.0
696 * Sun Sep 02 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
697 - really disable telepathy for Windows cross-compilation builds
699 * Thu Aug 30 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
700 - updates to enable telepathy build
702 * Sun Aug 19 2012 J. D. User <jduser@noreply.com> 1.13.3
703 - update to 1.13.3
705 * Sun Jun 10 2012 J. D. User <jduser@noreply.com> 1.13.2
706 - update to 1.13.2
708 * Mon Apr 09 2012 J. D. User <jduser@noreply.com> 1.13.1
709 - update to 1.13.1
711 * Wed Mar 14 2012 J. D. User <jduser@noreply.com> 1.13.0
712 - update to 1.13.0
714 * Mon Dec 12 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
715 - we do support Microsoft Lync Server 2010 now.
717 * Tue Dec 06 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
718 - update GPL2 license name
720 * Sat Nov 12 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
721 - add BR gmime-devel for Fedora to have at least one verification platform
723 * Sun Nov 06 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
724 - fix Mandriva 2011 unresolvable BR
726 * Mon Oct 31 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
727 - add BR nss-devel
729 * Sat Oct 01 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
730 - add NSIS package for mingw builds
732 * Sat Oct 01 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
733 - add mingw64 build
735 * Wed Sep 28 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
736 - remove BR mingw32-mozilla-nss-devel, not needed for SSPI.
738 * Mon Sep 19 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
739 - update mingw32 build
740 - update descriptions
742 * Mon Aug 29 2011 J. D. User <jduser@noreply.com> 1.12.0
743 - update to 1.12.0
745 * Wed Jun 22 2011 J. D. User <jduser@noreply.com> 1.11.2-*git*
746 - add gstreamer-devel to enable Voice & Video features
748 * Sat Dec 11 2010 J. D. User <jduser@noreply.com> 1.11.2-*git*
749 - add optional subpackage for telepathy connection manager
751 * Tue Nov 02 2010 J. D. User <jduser@noreply.com> 1.11.2
752 - update to 1.11.2
754 * Sun Oct 24 2010 J. D. User <jduser@noreply.com> 1.11.1
755 - update to 1.11.1
757 * Fri Oct 15 2010 J. D. User <jduser@noreply.com> 1.11.0-*git*
758 - add mingw32 build configuration
760 * Sun Oct 03 2010 J. D. User <jduser@noreply.com> 1.11.0
761 - update to 1.11.0
763 * Thu Sep 02 2010 J. D. User <jduser@noreply.com> pre-1.11.0-*git*
764 - Mandriva config for OBS has changed
766 * Tue May 04 2010 J. D. User <jduser@noreply.com> 1.10.0-*git*
767 - add libnice build information discovered through OBS testing
769 * Mon Apr 12 2010 J. D. User <jduser@noreply.com> 1.10.0-*git*
770 - add NSS build information discovered through OBS testing
772 * Sun Apr 04 2010 pier11 <pier11@operamail.com> 1.10.0
773 - release
775 * Fri Apr 02 2010 J. D. User <jduser@noreply.com> pre-1.10.0-*git*
776 - Mandriva has too old libtool version
778 * Fri Apr 02 2010 J. D. User <jduser@noreply.com> pre-1.10.0-*git*
779 - SLE11, openSUSE 11.0/1 don't have pidgin/protocols/scalable directory
781 * Thu Apr 01 2010 pier11 <pier11@operamail.com> pre-1.10.0-*git*
782 - OBS tests of pre-1.10.0 git-snapshot 4fa20cd65e5be0e469d4aa55d861f11c5b08b816
784 * Sun Mar 28 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
785 - added --enable/--disable build options
787 * Sun Mar 28 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
788 - removed --with-krb5 configure option as it is autodetected now
790 * Tue Mar 23 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
791 - add SVG icon
793 * Sat Mar 20 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
794 - add BR glib2-devel >= 2.12.0
796 * Wed Mar 17 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
797 - add tests to build
799 * Tue Mar 16 2010 J. D. User <jduser@noreply.com> 1.9.1
800 - update to 1.9.1
802 * Thu Mar 11 2010 J. D. User <jduser@noreply.com> 1.9.0-*git*
803 - add BR libxml2-devel
805 * Wed Mar 10 2010 pier11 <pier11@operamail.com> 1.9.0
806 - release
807 - dropped SLE 10 due to libpurple min version increase
808 - updated target distros in comment line
810 * Mon Mar 08 2010 J. D. User <jduser@noreply.com> 1.9.0-*git*
811 - increased libpurple build requisite to >= 2.4.0
813 * Sun Mar 07 2010 pier11 <pier11@operamail.com> pre-1.9.0-*git*
814 - OBS tests of pre-1.9.0 git-snapshot 61ea0856855483b9e18f23a87afe47437e526f0e
816 * Sun Mar 07 2010 J. D. User <jduser@noreply.com> 1.8.1-*git*
817 - sync with RPM SPEC from contrib/rpm
819 * Mon Feb 08 2010 pier11 <pier11@operamail.com> 1.8.0
820 - source is an original 1.8.0 with patch: git(upstream) 9c34cc3557daa3d61a002002492c71d0343c8cae
821 - temp hack - renamed source in spec from .bz2 to .gz as the latter was prepared with the patch.
823 * Sun Nov 22 2009 pier11 <pier11@operamail.com> 1.7.1
824 - reinstated enable-quality-check
826 * Wed Nov 04 2009 John Beranek <john@redux.org.uk> 1.7.0
827 - Spec file modifications to allow SLES/D 10 and Mandriva 2009.1 builds
829 * Tue Nov 03 2009 John Beranek <john@redux.org.uk> 1.7.0
830 - Spec file modifications for openSUSE build service
832 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
833 - move non-Pidgin files to new sub-package purple-sipe
835 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
836 - remove directory for emoticon theme icons
838 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
839 - libpurple protocol plugins are located under %%{_libdir}/purple-2
841 * Mon Sep 28 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
842 - added directory for emoticon theme icons
844 * Wed Sep 09 2009 J. D. User <jduser@noreply.com> 1.6.3
845 - update to 1.6.3
847 * Fri Aug 28 2009 J. D. User <jduser@noreply.com> 1.6.2-*git*
848 - reduce libpurple-devel requirement to >= 2.3.1
850 * Mon Aug 24 2009 J. D. User <jduser@noreply.com> 1.6.2
851 - update to 1.6.2
853 * Fri Aug 21 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
854 - reduce libpurple-devel requirement to >= 2.4.1
856 * Mon Aug 17 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
857 - com_err.h only required for kerberos
859 * Tue Aug 11 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
860 - require libpurple-devel >= 2.5.0
862 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
863 - refactor configure parameters
864 - make kerberos configurable
865 - don't hard code prefix for git builds
867 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
868 - removed unnecessary zlib-devel
870 * Sat Aug 08 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
871 - fix prefix for git builds
873 * Sat Aug 01 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
874 - append -Wno-unused-parameter for GCC <4.4 compilation errors
876 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
877 - remove duplicate GPL2
879 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
880 - use "--with git" to build from git
881 - corrected download URL for release archive
882 - add missing BR gettext-devel
884 * Wed Jul 29 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
885 - use default rpmbuild CFLAGS also for git builds
886 - merge with SPEC files created by mricon & jberanek
888 * Tue Jul 28 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
889 - initial RPM SPEC example generated