RaeMote 1.3 released
[raemote.git] / debian / rules
blobe3d588ec75d711f762c0761920f36d30d4f8c1be
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
9 # Uncomment this to turn on verbose mode.
10 #export DH_VERBOSE=1
15 CFLAGS = -Wall -g
17 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
18 CFLAGS += -O0
19 else
20 CFLAGS += -O2
21 endif
23 configure: configure-stamp
24 configure-stamp:
25 dh_testdir
26 touch configure-stamp
29 build: build-stamp
31 build-stamp: configure-stamp
32 touch $@
34 clean:
35 dh_testdir
36 dh_testroot
37 rm -f build-stamp configure-stamp
38 dh_clean
40 install: build
41 dh_testdir
42 dh_testroot
43 dh_clean -k
44 dh_installdirs
45 cp -rp opt etc usr $(CURDIR)/debian/raemote
46 chown -R root:root $(CURDIR)/debian/raemote
48 # Build architecture-independent files here.
49 binary-indep: build install
50 # We have nothing to do by default.
52 # Build architecture-dependent files here.
53 binary-arch: build install
54 dh_testdir
55 dh_testroot
56 dh_installchangelogs
57 dh_installman
58 dh_link
59 dh_strip
60 dh_compress
61 dh_fixperms
62 dh_installdeb
63 dh_shlibdeps
64 dh_gencontrol
65 dh_md5sums
66 dh_builddeb
68 binary: binary-indep binary-arch
69 .PHONY: build clean binary-indep binary-arch binary install configure