removed binary translation (will be generated when building the project)
[qbat.git] / gentoo / qbat-9999.ebuild
blobfd89b28424f7d2802a36ad7e3b70a2519b2b3d6c
2 EGIT_REPO_URI="git://repo.or.cz/qbat.git"
4 inherit eutils flag-o-matic git
6 DESCRIPTION="QBat is a small tool based on Qt4 to display battery stats in system tray."
7 HOMEPAGE="http://repo.or.cz/qbat.git"
8 SRC_URI=""
10 LICENSE="GPL-2.0"
11 SLOT="0"
12 KEYWORDS="~x86 ~amd64"
13 IUSE="debug"
15 RDEPEND="
16 x11-libs/qt-gui:4
17 x11-libs/qt-core:4
20 DEPEND="${RDEPEND}
21 sys-kernel/linux-headers"
23 S=${WORKDIR}/${EGIT_PROJECT}
25 pkg_setup() {
26 if ! qmake --version | grep -i qt4 ; then
27 eerror "qmake does not point to qmake-qt4"
28 die "Install qmake-qt4 and set symlinks correctly"
33 src_unpack() {
34 #check version:
35 if [ "$PV" != 9999 ]; then
36 EGIT_TREE="v${PV}"
38 git_src_unpack
41 src_compile() {
42 cd "${S}"
43 config_defines=""
44 config_release=""
45 if use debug; then
46 config_release="debug"
47 else
48 config_release="release"
49 config_defines="$config_defines QT_NO_DEBUG_OUTPUT"
52 qmake -recursive -Wall "CONFIG+=$config_release" "DEFINES+=$config_defines"
53 emake || die
56 src_install() {
57 make INSTALL_ROOT="${D}" install || die
58 doman "${S}/res/qbat.1"
61 pkg_postinst() {
62 elog "You need a at least kernel version 2.6.24 to use this software"