Modified the firewall to use a callback instead of the 2.5 append_const
[pykickstart/EL-5.git] / pykickstart.spec
blob153dd3ad1a679a14a933b33018b83b52bd55f7ca
1 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
3 Summary: A python library for manipulating kickstart files
4 Name: pykickstart
5 Url: http://fedoraproject.org/wiki/pykickstart
6 Version: 1.47
7 Release: 1%{?dist}
8 # This is a Red Hat maintained package which is specific to
9 # our distribution. Thus the source is only available from
10 # within this srpm.
11 Source0: %{name}-%{version}.tar.gz
13 License: GPLv2
14 Group: System Environment/Libraries
15 BuildArch: noarch
16 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
17 BuildRequires: python-devel, gettext, python-setuptools-devel
18 Requires: python, python-urlgrabber
20 %description
21 The pykickstart package is a python library for manipulating kickstart
22 files.
24 %prep
25 %setup -q
26 make
28 %build
30 %install
31 rm -rf %{buildroot}
32 make DESTDIR=%{buildroot} install
33 %find_lang %{name}
35 %clean
36 rm -rf %{buildroot}
38 %files -f %{name}.lang
39 %defattr(-,root,root,-)
40 %doc README ChangeLog COPYING docs/programmers-guide
41 %doc docs/kickstart-docs.txt
42 %{python_sitelib}/*
43 %{_bindir}/ksvalidator
44 %{_bindir}/ksflatten
46 %changelog
47 * Thu Oct 30 2008 Chris Lumens <clumens@redhat.com> - 1.47-1
48 - Fix enabling services we specify by specific options.
50 * Mon Oct 27 2008 Chris Lumens <clumens@redhat.com> - 1.46-1
51 - Add support for firewall --service (#467005).
53 * Tue Oct 14 2008 Chris Lumens <clumens@redhat.com> - 1.45-1
54 - Lots of translation updates.
55 - Remove use of string.partition for python2.4 (atodorov).
57 * Mon Sep 22 2008 Chris Lumens <clumens@redhat.com> - 1.44-1
58 - Add support for reverse CHAP to the kickstart iscsi command (hans)
59 - Fix typo (katzj)
61 * Wed Sep 03 2008 Chris Lumens <clumens@redhat.com> - 1.43-1
62 - Revert "Do not include passphrases for encrypted block devices in
63 anaconda-ks.cfg." (dlehman)
64 - yum doesn't like when mirrorlist is "". (clumens)
66 * Mon Aug 11 2008 Chris Lumens <clumens@redhat.com> - 1.42-1
67 - Add rescue command to pykickstart (atodorov)
68 - Sort %packages output (katzj)
69 - Fix a typo (atodorov).
71 * Fri Aug 01 2008 Chris Lumens <clumens@redhat.com> - 1.41-1
72 - RHEL5 supports ignoredisk --only-use now too. (clumens)
73 - Do not include passphrases for encrypted block devices in
74 anaconda-ks.cfg. (dlehman)
75 - Fix F9,F10,RHEL5 "part" commands to use the same class as
76 "partition". (dlehman)
77 - Add an apply method() for commands and implement for lang (katzj)
79 * Tue Jul 15 2008 Chris Lumens <clumens@redhat.com> - 1.40-1
80 - RHEL5_LogVolData should inherit from FC4, not FC3.
81 Also fix FC9->F9 typo. (dlehman)
82 - Support creation of encrypted block devices in RHEL5. (#449830) (dlehman)
83 - Use the right LogVolData objects for RHEL3 and 4 (jlaska). (clumens)
84 - We no longer use rhpl for translations. (clumens)
85 - All the base classes should derive from object. (clumens)
87 * Fri Jun 13 2008 Chris Lumens <clumens@redhat.com> - 1.39-1
88 - It's helpful to return the parser object. (clumens)
90 * Tue Jun 10 2008 Chris Lumens <clumens@redhat.com> - 1.38-1
91 - Fix loading the Handler object by looking for a more specific
92 name (#450740). (clumens)
94 * Sun Jun 08 2008 Chris Lumens <clumens@redhat.com> - 1.37-1
95 - XConfig is still used by other projects, so just deprecate some
96 options. (clumens)
98 * Thu May 29 2008 Chris Lumens <clumens@redhat.com> - 1.36-1
99 - It should be repo --cost, not repo --priority. (clumens)
101 * Fri May 23 2008 Chris Lumens <clumens@redhat.com> - 1.35-1
102 - Bring driverdisk command in line with the docs. (clumens)
103 - Change RAID command print priorities (jlaska).
104 - According to docs, physvols are space delimited. (jlaska)
105 - Don't write the label out twice (jlaska).
106 - Deprecate monitor and xconfig commands. (clumens)
108 * Wed May 07 2008 Chris Lumens <clumens@redhat.com> - 1.34-1
109 - Load the handler module automatically. (clumens)
110 - Add support for F10. (clumens)
111 - Initialize cmd.handler earlier; fixes repo.methodToRepo() (markmc)
112 - Don't shadow builtin function names. (clumens)
113 - Running check is now required before pykickstart can be packaged. (clumens)
114 - Reorganize code a little bit to pass pychecker. (clumens)
116 * Tue Apr 08 2008 Chris Lumens <clumens@redhat.com> - 1.33-1
117 - Fix whitespace when printing out the bootloader command (pmeyers).
118 - Fix the type on bootloader --timeout processing. (clumens)
120 * Wed Apr 02 2008 Chris Lumens <clumens@redhat.com> - 1.32-1
121 - Make the string reader act like the file reader upon EOF. (clumens)
122 - Add syntax for encrypted logical volumes. (clumens)
124 * Tue Mar 25 2008 Chris Lumens <clumens@redhat.com> - 1.31-1
125 - Support end-of-line comments. (clumens)
126 - Lots of translation updates.
128 * Tue Feb 26 2008 Chris Lumens <clumens@redhat.com> - 1.30-1
129 - Reverse writePriorities of iscsi and iscsname (#434965, jlaska).
130 - Fix printing of iscsiname command (#434945, jlaska).
131 - Don't traceback on ENOENT. (pnasrat)
132 - Store the mouse name as a string, not a list. (clumens)
133 - Update translations.
135 * Wed Jan 30 2008 Chris Lumens <clumens@redhat.com> - 1.29-1
136 - Renamed bootproto=ask to bootproto=query, add to RHEL5 as well. (clumens)
138 * Wed Jan 23 2008 Chris Lumens <clumens@redhat.com> - 1.28-1
139 - Fix traceback on volgroup command. (clumens)
141 * Thu Jan 17 2008 Chris Lumens <clumens@redhat.com> - 1.27-1
142 - The bootprotoList needs to be defined before it's used. (clumens)
144 * Thu Jan 17 2008 Chris Lumens <clumens@redhat.com> - 1.26-1
145 - Add support for network --bootproto=ask. (clumens)
147 * Tue Jan 15 2008 Chris Lumens <clumens@redhat.com> - 1.25-1
148 - Add the version to the output ks file. (clumens)
149 - Add syntax for encrypted partitions and raid devices. (clumens)
151 * Thu Jan 10 2008 Chris Lumens <clumens@redhat.com> - 1.24-1
152 - Make inheritance and overriding of %packages work (#427768). (clumens)
153 - Add an option for which languages should be installed. (katzj)
154 - Use the right name for the iscsi --target variable (#418781). (clumens)
156 * Mon Dec 10 2007 Chris Lumens <clumens@redhat.com> - 1.23-1
157 - Take Makefile improvements from anaconda.
158 - Fix a traceback on F9 zerombr command (#395431).
159 - Update to handle new Python eggs packaging.
161 * Tue Nov 20 2007 Chris Lumens <clumens@redhat.com> 1.22-1
162 - Don't process or write out vnc --enabled (jlaska AT redhat DOT com).
163 - Fix a traceback in the clearpart command.
165 * Tue Nov 06 2007 Chris Lumens <clumens@redhat.com> 1.21-1
166 - Save script line numbers for debugging.
167 - More internal cleanups.
169 * Wed Oct 31 2007 Chris Lumens <clumens@redhat.com> 1.20-1
170 - Pull wiki docs from the new location.
171 - Fix error messages for options that have been removed after having been
172 previously deprecated.
173 - zerombr no longer takes any arguments.
174 - %packages --ignoredeps --resolvedeps have been removed.
175 - firewall --high --medium have been removed.
176 - vnc --connect has been removed.
177 - xconfig options from monitor have now been removed.
178 - --bytes-per-inode has been marked as deprecated.
179 - Fix typos.
180 - Add --fsprofile option to disk commands (pjones).
181 - Add F9 support (pjones).
182 - Lots of internal fixes (clumens, pjones).
184 * Tue Oct 23 2007 Chris Lumens <clumens@redhat.com> 1.19-1
185 - Fix a traceback on the cdrom method.
187 * Thu Oct 18 2007 Chris Lumens <clumens@redhat.com> 1.18-1
188 - Don't write out %end to packages and scripts if the syntax version doesn't
189 support it.
190 - Remove obsolete translation (#332221).
192 * Thu Oct 04 2007 Chris Lumens <clumens@redhat.com> 1.17-1
193 - Simplify argument processing and printing.
195 * Wed Oct 03 2007 Chris Lumens <clumens@redhat.com> 1.16-1
196 - Undeprecate %packages --excludedocs.
197 - Fix a traceback in the device command handling.
198 - Add bootloader --timeout (katzj).
200 * Tue Oct 02 2007 Chris Lumens <clumens@redhat.com> 1.15-1
201 - Update translations (#259121).
202 - The device command no longer takes a type argument.
204 * Fri Sep 28 2007 Chris Lumens <clumens@redhat.com> 1.14-1
205 - Fix output formatting for packages section header (#310211).
206 - Add a script to flatten kickstart files containing includes (katzj).
208 * Wed Sep 12 2007 Chris Lumens <clumens@redhat.com> 1.13-1
209 - Add a function to convert URL method strings into repo objects
210 (jkeating).
211 - Writer formatting fixes.
212 - Add kickstart documentation from the Fedora Wiki.
214 * Tue Sep 04 2007 Chris Lumens <clumens@redhat.com> 1.12-1
215 - Fix lots of problems in processing the bootloader, device, network, and
216 raid commands.
217 - Add %end when writing out scripts and packages.
218 - Add a makefile target to run pychecker to cut down on errors in
219 releases.
221 * Mon Sep 3 2007 Jeremy Katz <katzj@redhat.com> - 1.11-1
222 - fix a few tracebacks
224 * Fri Aug 31 2007 Chris Lumens <clumens@redhat.com> 1.10-1
225 - Add network --ipv6=.
227 * Fri Aug 24 2007 Chris Lumens <clumens@redhat.com> 1.9-1
228 - Add support for the %end directive to be placed at the end of scripts
229 and packages sections. Deprecate old syntax.
230 - Clean up after ksvalidator if pykickstart issues a traceback.
231 - Add support for repo --priority --includepkgs --excludepkgs.
232 - Fix newline at end of reboot --eject output (#253562).
234 * Mon Aug 13 2007 Chris Lumens <clumens@redhat.com> 1.8-1
235 - Fix type checking of string values.
237 * Thu Aug 09 2007 Chris Lumens <clumens@redhat.com> 1.7-1
238 - Clarify license in spec file and all source files.
239 - Check string values to options to make sure they're not other options
240 (#251318).
242 * Thu Aug 02 2007 Chris Lumens <clumens@redhat.com> 1.6-1
243 - Fix a couple tracebacks in ksvalidator.
244 - Change --class to --dhcpclass (#248912).
246 * Thu Jul 19 2007 Chris Lumens <clumens@redhat.com> 1.5-2
247 - Require rhpl (#248953).
249 * Tue Jul 17 2007 Chris Lumens <clumens@redhat.com> 1.5-1
250 - Fix traceback when calling preprocessKickstart.
252 * Tue Jul 17 2007 Chris Lumens <clumens@redhat.com> 1.4-1
253 - Add methods to handle the %ksappend directive.
254 - Fix ignoredisk --disks.
256 * Wed Jul 11 2007 Chris Lumens <clumens@redhat.com> - 1.3-1
257 - Add support for ignoredisk --only-use.
258 - Fix traceback in raid command printing method (#246709).
260 * Fri Jun 08 2007 Chris Lumens <clumens@redhat.com> - 1.2-2
261 - Fix package review problems (#226334).
263 * Mon Jun 04 2007 Chris Lumens <clumens@redhat.com> - 1.2-1
264 - Fix harddrive install method error checking (#232492).
265 - Set authentication information from the input line to preserve quoting
266 (#241657).
267 - Allow included files to be given by URL.
268 - Fix typo in user --iscrypted option.
270 * Mon May 14 2007 Chris Lumens <clumens@redhat.com> - 1.1-1
271 - Better regexes for splitting version strings into family and version.
272 - Add basic support for RHEL3.
273 - Update translations.
275 * Fri Apr 13 2007 Chris Lumens <clumens@redhat.com> - 1.0-1
276 - Update documentation.
277 - Update translations.
279 * Mon Mar 19 2007 Chris Lumens <clumens@redhat.com> - 0.100-1
280 - bootloader should be written out after upgrade/install.
281 - Treat class names as unicode strings (#231053).
283 * Wed Mar 07 2007 Chris Lumens <clumens@redhat.com> - 0.99-1
284 - The timezone command didn't recognize --isUtc before FC6 (#231189).
285 - Recognize %ksappend lines in ksvalidator.
286 - Don't set default values in some command __init__ methods.
287 - Added an updates command.
288 - Add support for RAID10.
290 * Mon Feb 26 2007 Chris Lumens <clumens@redhat.com> - 0.98-1
291 - Fix device command syntax to match anaconda.
292 - Fix __call__ on method command.
294 * Wed Feb 21 2007 Chris Lumens <clumens@redhat.com> - 0.97-1
295 - Fix traceback when not overriding default mappings (#229505).
297 * Tue Feb 20 2007 Chris Lumens <clumens@redhat.com> - 0.96-1
298 - Fix __str__ methods for langsupport and reboot commands.
299 - Renamed BaseHandler.empty to BaseHandler.maskAllExcept.
300 - Split command objects out into their own files in commands/.
301 - Rename command objects to start with Version_.
302 - Support extended group selection syntax.
304 * Wed Feb 14 2007 Chris Lumens <clumens@redhat.com> - 0.95-1
305 - KickstartParser no longer takes a version argument.
306 - Be more lenient in what strings stringToVersion accepts.
307 - Allow setting state on one data object from multiple files.
309 * Wed Feb 07 2007 Chris Lumens <clumens@redhat.com> - 0.94-1
310 - Add a newline to the end of the key command output.
311 - Use network bootproto constants (#197694).
312 - Fix tracebacks in subclass __str__ methods (#226734).
314 * Wed Jan 31 2007 Chris Lumens <clumens@redhat.com> - 0.93-2
315 - Make some minor spec file changes to get closer to the extras guidelines.
317 * Thu Jan 25 2007 Chris Lumens <clumens@redhat.com> - 0.93-1
318 - Add support for FC3, RHEL4, and RHEL5.
319 - The key command was not supported until after FC6.
320 - Accept more strings in stringToVersion.
322 * Fri Jan 19 2007 Chris Lumens <clumens@redhat.com> - 0.92-1
323 - Fix KickstartVersionError reporting.
324 - Add a version attribute to handler objects.
325 - Fix line number reporting on lots of commands.
326 - Add initial support for Fedora 7 and remove deprecated commands.
327 - Accept a --default argument to the %%packages header (#221305).
329 * Wed Jan 17 2007 Chris Lumens <clumens@redhat.com> - 0.91-1
330 - Add a method to read kickstart files from strings.
332 * Tue Jan 16 2007 Chris Lumens <clumens@redhat.com> - 0.90-1
333 - Support multiple versions of kickstart syntax from one code base
334 (#189348).
335 - Fix inconsistency between Script parser and writer (#222877).
337 * Fri Dec 15 2006 Chris Lumens <clumens@redhat.com> - 0.43-1
338 - Pull in new translations (#216620).
340 * Thu Dec 7 2006 Jeremy Katz <katzj@redhat.com> - 0.42-2
341 - rebuild against python 2.5
343 * Tue Dec 05 2006 Chris Lumens <clumens@redhat.com> - 0.42-1
344 - Fix traceback when writing out repo command (#218274).
346 * Fri Dec 01 2006 Chris Lumens <clumens@redhat.com> - 0.41-1
347 - Fix traceback when using deprecated commands (#218047, #218059).
349 * Thu Nov 30 2006 Chris Lumens <clumens@redhat.com> - 0.40-1
350 - Pull in new translations (#216620).
351 - Add --level argument to logging command writer.
353 * Tue Oct 24 2006 Chris Lumens <clumens@redhat.com> - 0.39-2
354 - Fix release number.
356 * Tue Oct 24 2006 Chris Lumens <clumens@redhat.com> - 0.39-1
357 - Add writer for --key (#211997).
359 * Tue Oct 17 2006 Jeremy Katz <katzj@redhat.com> - 0.38-1
360 - allow --skip for installation number as well (#207029)
362 * Mon Oct 16 2006 Jeremy Katz <katzj@redhat.com> - 0.37-1
363 - support for installation numbers (#207029)
365 * Fri Oct 13 2006 Bill Nottingham <notting@redhat.com> - 0.36-1
366 - use valid charsets in translations (#210720)
368 * Fri Sep 29 2006 Chris Lumens <clumens@redhat.com> - 0.35-1
369 - Fix traceback in harddrive command (#208557).
371 * Mon Sep 25 2006 Chris Lumens <clumens@redhat.com> - 0.34-1
372 - Add support for --biospart option to harddrive (#207585).
373 - Update writer for syntax changes.
375 * Wed Sep 20 2006 Jeremy Katz <katzj@redhat.com> - 0.33-1
376 - improved iscsi syntax
377 - allow multiple zfcp devs
379 * Thu Jul 20 2006 Chris Lumens <clumens@redhat.com> 0.32-1
380 - Limit --bootproto to what anaconda supports.
381 - Add --noipv4 and --noipv6 network options.
383 * Tue Jun 20 2006 Chris Lumens <clumens@redhat.com> 0.31-1
384 - Handle nfs --opts (katzj).
385 - RAID devices should be integers instead of strings (#176537).
386 - Add initial support for iscsi (katzj).
388 * Tue Jun 06 2006 Chris Lumens <clumens@redhat.com> 0.30-2
389 - Add BuildRequires to fix building under mock (#194156, Joost Soeterbroek
390 <fedora AT soeterbroek.com>).
392 * Thu May 25 2006 Chris Lumens <clumens@redhat.com> 0.30-1
393 - Change order of LVM-related writing functions (#193073).
394 - Require urlgrabber.
395 - Return a more useful error message on unknown commands.
396 - Fix logvol writing typo.
397 - Make ksvalidator validate from a URL in addition to a file.
398 - Don't write out an empty packages section (#192851).
400 * Tue May 23 2006 Chris Lumens <clumens@redhat.com> 0.29-1
401 - Add multipath command, handlers, and data objects (pjones).
402 - Rename --ports to --port in writer.
404 * Mon May 15 2006 Chris Lumens <clumens@redhat.com> 0.28-1
405 - Support --mtu for the network command (#191328).
406 - Accept --isUtc for backwards compatibility.
408 * Wed May 04 2006 Chris Lumens <clumens@redhat.com> 0.27-1
409 - Output formatting fixes.
410 - Added commands for managing users and services.
412 * Mon Apr 17 2006 Chris Lumens <clumens@redhat.com> 0.26-1
413 - Ignore spaces before group names (#188095).
414 - Added some translations.
415 - Add options for repo command.
416 - Reorder %%packages section output.
417 - Output %%packages header options.
418 - Initialize RAID and volume group members to empty lists.
420 * Mon Mar 27 2006 Chris Lumens <clumens@redhat.com> 0.25-1
421 - Add support for the logging command.
423 * Mon Mar 27 2006 Chris Lumens <clumens@redhat.com> 0.24-1
424 - Don't write out a blank xconfig line.
425 - Reorder output handlers to group like commands together.
426 - Mark strings for translation.
428 * Tue Mar 07 2006 Chris Lumens <clumens@redhat.com> 0.23-1
429 - Backwards compatibility support for options to zerombr.
431 * Fri Feb 24 2006 Chris Lumens <clumens@redhat.com> 0.22-1
432 - Get ignoredisk working again (#182934).
434 * Fri Feb 17 2006 Chris Lumens <clumens@redhat.com> 0.21-1
435 - Provide an option to not traceback on missing include files (#181760).
436 - Update programming documentation.
438 * Mon Feb 13 2006 Chris Lumens <clumens@redhat.com> 0.20-1
439 - Correctly set --noformat and --useexisting on lvm and raid.
441 * Mon Feb 13 2006 Chris Lumens <clumens@redhat.com> 0.19-1
442 - --onboot requires a value (#180987).
443 - Be more strict about commands that don't take arguments.
445 * Thu Feb 09 2006 Chris Lumens <clumens@redhat.com> 0.18-1
446 - Fix some errors pychecker caught.
447 - Allow exceptions to not be fatal so ksvalidator can spot more errors in
448 a single pass (#179894).
450 * Wed Feb 01 2006 Chris Lumens <clumens@redhat.com> 0.17-1
451 - Don't set a default port for vnc.
453 * Tue Jan 31 2006 Chris Lumens <clumens@redhat.com> 0.16-1
454 - Give dmraid string an initial value.
455 - Handle None on partition size.
457 * Tue Jan 31 2006 Peter Jones <pjones@redhat.com> 0.15-1
458 - Add dmraid support
460 * Mon Jan 30 2006 Chris Lumens <clumens@redhat.com> 0.14-1
461 - Fix VNC parameter parsing (#179209).
462 - Deprecate --connect. Add --host and --port instead.
464 * Thu Jan 19 2006 Chris Lumens <clumens@redhat.com> 0.13-1
465 - Recognize the --eject parameter to shutdown/halt.
466 - Store the exact post-installation action in ksdata.
468 * Mon Jan 09 2006 Chris Lumens <clumens@redhat.com> 0.12-1
469 - Clean up output quoting.
470 - Finish removing monitor-related stuff from xconfig.
472 * Mon Dec 12 2005 Chris Lumens <clumens@redhat.com> 0.11-1
473 - Deprecate monitor-related options to xconfig.
475 * Thu Dec 08 2005 Chris Lumens <clumens@redhat.com> 0.10-1
476 - Support --bytes-per-inode on raid
477 (Curtis Doty <Curtis at GreenKey.net> #175288).
479 * Wed Nov 16 2005 Jeremy Katz <katzj@redhat.com> - 0.9-1
480 - fixup network --onboot
482 * Thu Nov 03 2005 Chris Lumens <clumens@redhat.com> 0.8-1
483 - Default to SELINUX_ENFORCING.
484 - Default partition sizes to None for anaconda (#172378).
485 - Don't call shlex.split on anything inside a script (#172313).
487 * Tue Nov 01 2005 Chris Lumens <clumens@redhat.com> 0.7-1
488 - Fix clearpart --all.
489 - vnc command does not require --connect option (#172192).
490 - network --onboot does not take any option.
491 - Remove extra spaces from firewall --ports and --trust.
492 - Write out network --<service> options.
494 * Fri Oct 28 2005 Chris Lumens <clumens@redhat.com> 0.6-1
495 - Add --resolvedeps and --ignoredeps as deprecated options.
496 - Pass line number to header functions.
498 * Mon Oct 24 2005 Chris Lumens <clumens@redhat.com> 0.5-1
499 - Add line numbers to exception reporting.
500 - Added ksvalidator.
502 * Wed Oct 19 2005 Chris Lumens <clumens@redhat.com> 0.4-1
503 - Correct deprecated attribute on options.
504 - Added programming documentation.
506 * Thu Oct 13 2005 Chris Lumens <clumens@redhat.com> 0.3-2
507 - Correct python lib directory on 64-bit archs (#170621).
509 * Fri Oct 07 2005 Chris Lumens <clumens@redhat.com> 0.3-1
510 - Add a deprecated attribute to options.
511 - Add --card option back to xconfig and mark as deprecated.
512 - Throw a deprecation warning on mouse and langsupport commands.
513 - Rename Writer to KickstartWriter for consistency.
514 - Collapse scripts into a single list and add an attribute on Script to
515 differentiate.
517 * Wed Oct 05 2005 Chris Lumens <clumens@redhat.com> 0.2-1
518 - Rename module to pykickstart to avoid conflicts in anaconda.
519 - Rename data classes for consistency.
520 - Add default bytesPerInode settings.
522 * Wed Oct 05 2005 Chris Lumens <clumens@redhat.com> 0.1-1
523 - Created package from anaconda.