Save the line number the script starts on as a debugging aid in anaconda.
[pykickstart.git] / pykickstart.spec
blobd9fcc7e1555c0e7addeb232c74baba1948d0dc58
1 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
3 Summary: A python library for manipulating kickstart files
4 Name: pykickstart
5 Url: http://fedoraproject.org/wiki/pykickstart
6 Version: 1.20
7 Release: 1%{?dist}
8 # This is a Red Hat maintained package which is specific to
9 # our distribution. Thus the source is only available from
10 # within this srpm.
11 Source0: %{name}-%{version}.tar.gz
13 License: GPLv2
14 Group: System Environment/Libraries
15 BuildArch: noarch
16 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
17 BuildRequires: python-devel, gettext
18 Requires: python, python-urlgrabber, rhpl
20 %description
21 The pykickstart package is a python library for manipulating kickstart
22 files.
24 %prep
25 %setup -q
26 make
28 %build
30 %install
31 rm -rf %{buildroot}
32 make DESTDIR=%{buildroot} install
33 %find_lang %{name}
35 %clean
36 rm -rf %{buildroot}
38 %files -f %{name}.lang
39 %defattr(-,root,root,-)
40 %doc README ChangeLog COPYING docs/programmers-guide
41 %doc docs/kickstart-docs.txt
42 %{python_sitelib}/pykickstart
43 %{_bindir}/ksvalidator
44 %{_bindir}/ksflatten
46 %changelog
47 * Wed Oct 31 2007 Chris Lumens <clumens@redhat.com> 1.20-1
48 - Pull wiki docs from the new location.
49 - Fix error messages for options that have been removed after having been
50 previously deprecated.
51 - zerombr no longer takes any arguments.
52 - %packages --ignoredeps --resolvedeps have been removed.
53 - firewall --high --medium have been removed.
54 - vnc --connect has been removed.
55 - xconfig options from monitor have now been removed.
56 - --bytes-per-inode has been marked as deprecated.
57 - Fix typos.
58 - Add --fsprofile option to disk commands (pjones).
59 - Add F9 support (pjones).
60 - Lots of internal fixes (clumens, pjones).
62 * Tue Oct 23 2007 Chris Lumens <clumens@redhat.com> 1.19-1
63 - Fix a traceback on the cdrom method.
65 * Thu Oct 18 2007 Chris Lumens <clumens@redhat.com> 1.18-1
66 - Don't write out %end to packages and scripts if the syntax version doesn't
67 support it.
68 - Remove obsolete translation (#332221).
70 * Thu Oct 04 2007 Chris Lumens <clumens@redhat.com> 1.17-1
71 - Simplify argument processing and printing.
73 * Wed Oct 03 2007 Chris Lumens <clumens@redhat.com> 1.16-1
74 - Undeprecate %packages --excludedocs.
75 - Fix a traceback in the device command handling.
76 - Add bootloader --timeout (katzj).
78 * Tue Oct 02 2007 Chris Lumens <clumens@redhat.com> 1.15-1
79 - Update translations (#259121).
80 - The device command no longer takes a type argument.
82 * Fri Sep 28 2007 Chris Lumens <clumens@redhat.com> 1.14-1
83 - Fix output formatting for packages section header (#310211).
84 - Add a script to flatten kickstart files containing includes (katzj).
86 * Wed Sep 12 2007 Chris Lumens <clumens@redhat.com> 1.13-1
87 - Add a function to convert URL method strings into repo objects
88 (jkeating).
89 - Writer formatting fixes.
90 - Add kickstart documentation from the Fedora Wiki.
92 * Tue Sep 04 2007 Chris Lumens <clumens@redhat.com> 1.12-1
93 - Fix lots of problems in processing the bootloader, device, network, and
94 raid commands.
95 - Add %end when writing out scripts and packages.
96 - Add a makefile target to run pychecker to cut down on errors in
97 releases.
99 * Mon Sep 3 2007 Jeremy Katz <katzj@redhat.com> - 1.11-1
100 - fix a few tracebacks
102 * Fri Aug 31 2007 Chris Lumens <clumens@redhat.com> 1.10-1
103 - Add network --ipv6=.
105 * Fri Aug 24 2007 Chris Lumens <clumens@redhat.com> 1.9-1
106 - Add support for the %end directive to be placed at the end of scripts
107 and packages sections. Deprecate old syntax.
108 - Clean up after ksvalidator if pykickstart issues a traceback.
109 - Add support for repo --priority --includepkgs --excludepkgs.
110 - Fix newline at end of reboot --eject output (#253562).
112 * Mon Aug 13 2007 Chris Lumens <clumens@redhat.com> 1.8-1
113 - Fix type checking of string values.
115 * Thu Aug 09 2007 Chris Lumens <clumens@redhat.com> 1.7-1
116 - Clarify license in spec file and all source files.
117 - Check string values to options to make sure they're not other options
118 (#251318).
120 * Thu Aug 02 2007 Chris Lumens <clumens@redhat.com> 1.6-1
121 - Fix a couple tracebacks in ksvalidator.
122 - Change --class to --dhcpclass (#248912).
124 * Thu Jul 19 2007 Chris Lumens <clumens@redhat.com> 1.5-2
125 - Require rhpl (#248953).
127 * Tue Jul 17 2007 Chris Lumens <clumens@redhat.com> 1.5-1
128 - Fix traceback when calling preprocessKickstart.
130 * Tue Jul 17 2007 Chris Lumens <clumens@redhat.com> 1.4-1
131 - Add methods to handle the %ksappend directive.
132 - Fix ignoredisk --disks.
134 * Wed Jul 11 2007 Chris Lumens <clumens@redhat.com> - 1.3-1
135 - Add support for ignoredisk --only-use.
136 - Fix traceback in raid command printing method (#246709).
138 * Fri Jun 08 2007 Chris Lumens <clumens@redhat.com> - 1.2-2
139 - Fix package review problems (#226334).
141 * Mon Jun 04 2007 Chris Lumens <clumens@redhat.com> - 1.2-1
142 - Fix harddrive install method error checking (#232492).
143 - Set authentication information from the input line to preserve quoting
144 (#241657).
145 - Allow included files to be given by URL.
146 - Fix typo in user --iscrypted option.
148 * Mon May 14 2007 Chris Lumens <clumens@redhat.com> - 1.1-1
149 - Better regexes for splitting version strings into family and version.
150 - Add basic support for RHEL3.
151 - Update translations.
153 * Fri Apr 13 2007 Chris Lumens <clumens@redhat.com> - 1.0-1
154 - Update documentation.
155 - Update translations.
157 * Mon Mar 19 2007 Chris Lumens <clumens@redhat.com> - 0.100-1
158 - bootloader should be written out after upgrade/install.
159 - Treat class names as unicode strings (#231053).
161 * Wed Mar 07 2007 Chris Lumens <clumens@redhat.com> - 0.99-1
162 - The timezone command didn't recognize --isUtc before FC6 (#231189).
163 - Recognize %ksappend lines in ksvalidator.
164 - Don't set default values in some command __init__ methods.
165 - Added an updates command.
166 - Add support for RAID10.
168 * Mon Feb 26 2007 Chris Lumens <clumens@redhat.com> - 0.98-1
169 - Fix device command syntax to match anaconda.
170 - Fix __call__ on method command.
172 * Wed Feb 21 2007 Chris Lumens <clumens@redhat.com> - 0.97-1
173 - Fix traceback when not overriding default mappings (#229505).
175 * Tue Feb 20 2007 Chris Lumens <clumens@redhat.com> - 0.96-1
176 - Fix __str__ methods for langsupport and reboot commands.
177 - Renamed BaseHandler.empty to BaseHandler.maskAllExcept.
178 - Split command objects out into their own files in commands/.
179 - Rename command objects to start with Version_.
180 - Support extended group selection syntax.
182 * Wed Feb 14 2007 Chris Lumens <clumens@redhat.com> - 0.95-1
183 - KickstartParser no longer takes a version argument.
184 - Be more lenient in what strings stringToVersion accepts.
185 - Allow setting state on one data object from multiple files.
187 * Wed Feb 07 2007 Chris Lumens <clumens@redhat.com> - 0.94-1
188 - Add a newline to the end of the key command output.
189 - Use network bootproto constants (#197694).
190 - Fix tracebacks in subclass __str__ methods (#226734).
192 * Wed Jan 31 2007 Chris Lumens <clumens@redhat.com> - 0.93-2
193 - Make some minor spec file changes to get closer to the extras guidelines.
195 * Thu Jan 25 2007 Chris Lumens <clumens@redhat.com> - 0.93-1
196 - Add support for FC3, RHEL4, and RHEL5.
197 - The key command was not supported until after FC6.
198 - Accept more strings in stringToVersion.
200 * Fri Jan 19 2007 Chris Lumens <clumens@redhat.com> - 0.92-1
201 - Fix KickstartVersionError reporting.
202 - Add a version attribute to handler objects.
203 - Fix line number reporting on lots of commands.
204 - Add initial support for Fedora 7 and remove deprecated commands.
205 - Accept a --default argument to the %%packages header (#221305).
207 * Wed Jan 17 2007 Chris Lumens <clumens@redhat.com> - 0.91-1
208 - Add a method to read kickstart files from strings.
210 * Tue Jan 16 2007 Chris Lumens <clumens@redhat.com> - 0.90-1
211 - Support multiple versions of kickstart syntax from one code base
212 (#189348).
213 - Fix inconsistency between Script parser and writer (#222877).
215 * Fri Dec 15 2006 Chris Lumens <clumens@redhat.com> - 0.43-1
216 - Pull in new translations (#216620).
218 * Thu Dec 7 2006 Jeremy Katz <katzj@redhat.com> - 0.42-2
219 - rebuild against python 2.5
221 * Tue Dec 05 2006 Chris Lumens <clumens@redhat.com> - 0.42-1
222 - Fix traceback when writing out repo command (#218274).
224 * Fri Dec 01 2006 Chris Lumens <clumens@redhat.com> - 0.41-1
225 - Fix traceback when using deprecated commands (#218047, #218059).
227 * Thu Nov 30 2006 Chris Lumens <clumens@redhat.com> - 0.40-1
228 - Pull in new translations (#216620).
229 - Add --level argument to logging command writer.
231 * Tue Oct 24 2006 Chris Lumens <clumens@redhat.com> - 0.39-2
232 - Fix release number.
234 * Tue Oct 24 2006 Chris Lumens <clumens@redhat.com> - 0.39-1
235 - Add writer for --key (#211997).
237 * Tue Oct 17 2006 Jeremy Katz <katzj@redhat.com> - 0.38-1
238 - allow --skip for installation number as well (#207029)
240 * Mon Oct 16 2006 Jeremy Katz <katzj@redhat.com> - 0.37-1
241 - support for installation numbers (#207029)
243 * Fri Oct 13 2006 Bill Nottingham <notting@redhat.com> - 0.36-1
244 - use valid charsets in translations (#210720)
246 * Fri Sep 29 2006 Chris Lumens <clumens@redhat.com> - 0.35-1
247 - Fix traceback in harddrive command (#208557).
249 * Mon Sep 25 2006 Chris Lumens <clumens@redhat.com> - 0.34-1
250 - Add support for --biospart option to harddrive (#207585).
251 - Update writer for syntax changes.
253 * Wed Sep 20 2006 Jeremy Katz <katzj@redhat.com> - 0.33-1
254 - improved iscsi syntax
255 - allow multiple zfcp devs
257 * Thu Jul 20 2006 Chris Lumens <clumens@redhat.com> 0.32-1
258 - Limit --bootproto to what anaconda supports.
259 - Add --noipv4 and --noipv6 network options.
261 * Tue Jun 20 2006 Chris Lumens <clumens@redhat.com> 0.31-1
262 - Handle nfs --opts (katzj).
263 - RAID devices should be integers instead of strings (#176537).
264 - Add initial support for iscsi (katzj).
266 * Tue Jun 06 2006 Chris Lumens <clumens@redhat.com> 0.30-2
267 - Add BuildRequires to fix building under mock (#194156, Joost Soeterbroek
268 <fedora AT soeterbroek.com>).
270 * Thu May 25 2006 Chris Lumens <clumens@redhat.com> 0.30-1
271 - Change order of LVM-related writing functions (#193073).
272 - Require urlgrabber.
273 - Return a more useful error message on unknown commands.
274 - Fix logvol writing typo.
275 - Make ksvalidator validate from a URL in addition to a file.
276 - Don't write out an empty packages section (#192851).
278 * Tue May 23 2006 Chris Lumens <clumens@redhat.com> 0.29-1
279 - Add multipath command, handlers, and data objects (pjones).
280 - Rename --ports to --port in writer.
282 * Mon May 15 2006 Chris Lumens <clumens@redhat.com> 0.28-1
283 - Support --mtu for the network command (#191328).
284 - Accept --isUtc for backwards compatibility.
286 * Wed May 04 2006 Chris Lumens <clumens@redhat.com> 0.27-1
287 - Output formatting fixes.
288 - Added commands for managing users and services.
290 * Mon Apr 17 2006 Chris Lumens <clumens@redhat.com> 0.26-1
291 - Ignore spaces before group names (#188095).
292 - Added some translations.
293 - Add options for repo command.
294 - Reorder %%packages section output.
295 - Output %%packages header options.
296 - Initialize RAID and volume group members to empty lists.
298 * Mon Mar 27 2006 Chris Lumens <clumens@redhat.com> 0.25-1
299 - Add support for the logging command.
301 * Mon Mar 27 2006 Chris Lumens <clumens@redhat.com> 0.24-1
302 - Don't write out a blank xconfig line.
303 - Reorder output handlers to group like commands together.
304 - Mark strings for translation.
306 * Tue Mar 07 2006 Chris Lumens <clumens@redhat.com> 0.23-1
307 - Backwards compatibility support for options to zerombr.
309 * Fri Feb 24 2006 Chris Lumens <clumens@redhat.com> 0.22-1
310 - Get ignoredisk working again (#182934).
312 * Fri Feb 17 2006 Chris Lumens <clumens@redhat.com> 0.21-1
313 - Provide an option to not traceback on missing include files (#181760).
314 - Update programming documentation.
316 * Mon Feb 13 2006 Chris Lumens <clumens@redhat.com> 0.20-1
317 - Correctly set --noformat and --useexisting on lvm and raid.
319 * Mon Feb 13 2006 Chris Lumens <clumens@redhat.com> 0.19-1
320 - --onboot requires a value (#180987).
321 - Be more strict about commands that don't take arguments.
323 * Thu Feb 09 2006 Chris Lumens <clumens@redhat.com> 0.18-1
324 - Fix some errors pychecker caught.
325 - Allow exceptions to not be fatal so ksvalidator can spot more errors in
326 a single pass (#179894).
328 * Wed Feb 01 2006 Chris Lumens <clumens@redhat.com> 0.17-1
329 - Don't set a default port for vnc.
331 * Tue Jan 31 2006 Chris Lumens <clumens@redhat.com> 0.16-1
332 - Give dmraid string an initial value.
333 - Handle None on partition size.
335 * Tue Jan 31 2006 Peter Jones <pjones@redhat.com> 0.15-1
336 - Add dmraid support
338 * Mon Jan 30 2006 Chris Lumens <clumens@redhat.com> 0.14-1
339 - Fix VNC parameter parsing (#179209).
340 - Deprecate --connect. Add --host and --port instead.
342 * Thu Jan 19 2006 Chris Lumens <clumens@redhat.com> 0.13-1
343 - Recognize the --eject parameter to shutdown/halt.
344 - Store the exact post-installation action in ksdata.
346 * Mon Jan 09 2006 Chris Lumens <clumens@redhat.com> 0.12-1
347 - Clean up output quoting.
348 - Finish removing monitor-related stuff from xconfig.
350 * Mon Dec 12 2005 Chris Lumens <clumens@redhat.com> 0.11-1
351 - Deprecate monitor-related options to xconfig.
353 * Thu Dec 08 2005 Chris Lumens <clumens@redhat.com> 0.10-1
354 - Support --bytes-per-inode on raid
355 (Curtis Doty <Curtis at GreenKey.net> #175288).
357 * Wed Nov 16 2005 Jeremy Katz <katzj@redhat.com> - 0.9-1
358 - fixup network --onboot
360 * Thu Nov 03 2005 Chris Lumens <clumens@redhat.com> 0.8-1
361 - Default to SELINUX_ENFORCING.
362 - Default partition sizes to None for anaconda (#172378).
363 - Don't call shlex.split on anything inside a script (#172313).
365 * Tue Nov 01 2005 Chris Lumens <clumens@redhat.com> 0.7-1
366 - Fix clearpart --all.
367 - vnc command does not require --connect option (#172192).
368 - network --onboot does not take any option.
369 - Remove extra spaces from firewall --ports and --trust.
370 - Write out network --<service> options.
372 * Fri Oct 28 2005 Chris Lumens <clumens@redhat.com> 0.6-1
373 - Add --resolvedeps and --ignoredeps as deprecated options.
374 - Pass line number to header functions.
376 * Mon Oct 24 2005 Chris Lumens <clumens@redhat.com> 0.5-1
377 - Add line numbers to exception reporting.
378 - Added ksvalidator.
380 * Wed Oct 19 2005 Chris Lumens <clumens@redhat.com> 0.4-1
381 - Correct deprecated attribute on options.
382 - Added programming documentation.
384 * Thu Oct 13 2005 Chris Lumens <clumens@redhat.com> 0.3-2
385 - Correct python lib directory on 64-bit archs (#170621).
387 * Fri Oct 07 2005 Chris Lumens <clumens@redhat.com> 0.3-1
388 - Add a deprecated attribute to options.
389 - Add --card option back to xconfig and mark as deprecated.
390 - Throw a deprecation warning on mouse and langsupport commands.
391 - Rename Writer to KickstartWriter for consistency.
392 - Collapse scripts into a single list and add an attribute on Script to
393 differentiate.
395 * Wed Oct 05 2005 Chris Lumens <clumens@redhat.com> 0.2-1
396 - Rename module to pykickstart to avoid conflicts in anaconda.
397 - Rename data classes for consistency.
398 - Add default bytesPerInode settings.
400 * Wed Oct 05 2005 Chris Lumens <clumens@redhat.com> 0.1-1
401 - Created package from anaconda.