Call parent class tests first.
[pykickstart.git] / pykickstart.spec
blobe747319c2f3e7ba25a4796e71763563bb896038c
1 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
3 Summary: A python library for manipulating kickstart files
4 Name: pykickstart
5 Url: http://fedoraproject.org/wiki/pykickstart
6 Version: 1.58
7 Release: 1%{?dist}
8 # This is a Red Hat maintained package which is specific to
9 # our distribution. Thus the source is only available from
10 # within this srpm.
11 Source0: %{name}-%{version}.tar.gz
13 License: GPLv2
14 Group: System Environment/Libraries
15 BuildArch: noarch
16 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
17 BuildRequires: python-devel, gettext, python-setuptools-devel
18 Requires: python, python-urlgrabber
20 %description
21 The pykickstart package is a python library for manipulating kickstart
22 files.
24 %prep
25 %setup -q
26 make
28 %build
30 %install
31 rm -rf %{buildroot}
32 make DESTDIR=%{buildroot} install
33 %find_lang %{name}
35 %clean
36 rm -rf %{buildroot}
38 %files -f %{name}.lang
39 %defattr(-,root,root,-)
40 %doc README ChangeLog COPYING docs/programmers-guide
41 %doc docs/kickstart-docs.txt
42 %{python_sitelib}/*
43 %{_bindir}/ksvalidator
44 %{_bindir}/ksflatten
45 %{_bindir}/ksverdiff
47 %changelog
48 * Fri Jul 17 2009 Chris Lumens <clumens@redhat.com> - 1.58-1
49 - Adjust writePriority to fix lvm-on-raid0 test cases (jlaska).
50 - Add F12 to the version number tests. (clumens)
51 - F12_User test case. (dcantrell)
52 - Add --gecos argument to the 'user' command (dcantrell)
53 - Convert user.py to use _getArgsAsStr() (dcantrell)
55 * Fri Jul 10 2009 Chris Lumens <clumens@redhat.com> - 1.57-1
56 - Another patch to make the bootloader test work (jlaska).
58 * Thu Jul 09 2009 Chris Lumens <clumens@redhat.com> - 1.56-1
59 - Make sure to import the gettext stuff in fcoe. (clumens)
60 - Correctly deprecate bootloader --lba32 (jlaska).
61 - pykickstart: fix zfcp command writepriority (hdegoede)
62 - pykickstart: Add fcoe command (take 2) (hdegoede)
63 - Add a test case for RAID (jlaska).
65 * Thu Jul 02 2009 Chris Lumens <clumens@redhat.com> - 1.55-1
66 - Add support for the group command to F12 (#509119).
67 - RHEL5 now supports RAID 10.
68 - The f12 hander class should be called F12Handler. (jgranado)
69 - Remove bootloader --lba32.
70 - Add a new version of the driverdisk command without --type=.
71 - Add initial support for F12.
72 - Fetch the programmers-guide from the wiki now.
74 * Mon May 18 2009 Chris Lumens <clumens@redhat.com> - 1.54-1
75 - Make sure the F11 handler gets used for "partition" and "part" (#501020).
77 * Wed Apr 29 2009 Chris Lumens <clumens@redhat.com> - 1.53-1
78 - Move lineno= from KSOptionParser.__init__ to parse_args (#497149). (clumens)
79 - Use the F11 version of the partition command. (clumens)
80 - Remove the --start and --end options since anaconda no longer uses them. (clumens)
81 - Remove a broken test case. (clumens)
83 * Wed Feb 18 2009 Chris Lumens <clumens@redhat.com> - 1.52-1
84 - Add lots more test cases (alindebe, mgracik, stickster).
85 - Add a skip attribute on key to shut up pychecker.
86 - Only show autostep command when requested (jlaska)
87 - Strip spaces from service names, and require an option to be provided.
88 - Surround services lists in double quotes.
89 - Remove the extra space from the services __str__ method.
90 - Fix output formatting bugs in firewall, partition, and repo (mgracik).
91 - Specifying both or neither of --drives and --only-use should be an error.
92 - Corrected newline char in return value of FC6_Method. (mgracik)
93 - Make --drives a required option for FC3, and catch no args on F8.
94 - Fix final printing of the rescue command (mgracik).
95 - Surround output strings in double quotes.
96 - Fix a typo in the deviceprobe command.
97 - Revert the more strict option processing on displaymode.
98 - Properly handle erroring on extra args, not just extra options.
99 - Don't use the logging class since it interferes with the logging test.
100 - port without host should raise KickstartParseError, not kickstartValueError.
101 - Add the --key option to option processing, since it's a valid argument.
102 - Fix test cases that were failing due to the new use of KSOptionParser.
103 - Teach driverdisk.py command to reject extra partitions (stickster).
104 - Add KSOptionParser to all commands ... enables more strick option checking (jlaska).
105 - Use KSOptionParser so we can catch bad command options (jlaska).
107 * Thu Jan 29 2009 Chris Lumens <clumens@redhat.com> - 1.51-1
108 - Make a couple changes to how the logging command is handled.
109 - Add a lot of test cases (clumens, alindebe, jlaska, fcami, adamwill, pfrields).
110 - Fix output formatting for the rootpw command.
111 - For commands that take exactly one argument, check and error correctly.
112 - Surround module options in quotes on the output side (jlaska).
113 - Set module opts in the FC3 handler correctly.
114 - Fix newlines on the device command output (jlaska).
115 - If --autoscreenshot is not specified, still output "autostep".
116 - Move the currentCmd and currentLine into getParser(). (jlaska)
117 - Write out an selinux line if set to disabled, but not if None.
118 - F9_LogVolData should inherit from FC4_LogVolData, not FC3_LogVolData (jlaska).
119 - Add unittest framework along with logvol and vnc unittests. (jlaska)
120 - Don't set the KSOption.required attribute in the constructor (jlaska).
122 * Sat Jan 10 2009 Chris Lumens <clumens@redhat.com> - 1.50-1
123 - Add a script to diff two versions of kickstart syntax.
124 - Add an option to ksvalidator to list all available syntax versions.
125 - Remove a couple extra newlines in output formatting.
126 - Add documentation for the new %include representation.
127 - Add support %include to the pykickstart data objects.
129 * Thu Jan 08 2009 Chris Lumens <clumens@redhat.com> - 1.49-1
130 - Add upgrade --root-device (atodorov, #471232).
131 - Use python's builtin set rather than the Sets module (#477836, dcantrell).
133 * Tue Dec 23 2008 Chris Lumens <clumens@redhat.com> - 1.48-1
134 - Allow ignoring group metadata from repos, using a '--ignoregroups'
135 boolean. (notting)
136 - Add initial support for F11.
137 - Specify the command versions in the handlers instead of making copies.
138 - Remove empty and pointless __init__ methods.
139 - Pass arguments to superclasses via *args and **kwargs, all the way up.
140 - Add removedKeywords and removedAttrs lists on Commands and Data.
141 - Fix version regexes to handle double digits and minor releases (jlaska).
143 * Thu Oct 30 2008 Chris Lumens <clumens@redhat.com> - 1.47-1
144 - Fix enabling services we specify by specific options.
146 * Mon Oct 27 2008 Chris Lumens <clumens@redhat.com> - 1.46-1
147 - Add support for firewall --service (#467005).
149 * Tue Oct 14 2008 Chris Lumens <clumens@redhat.com> - 1.45-1
150 - Lots of translation updates.
151 - Remove use of string.partition for python2.4 (atodorov).
153 * Mon Sep 22 2008 Chris Lumens <clumens@redhat.com> - 1.44-1
154 - Add support for reverse CHAP to the kickstart iscsi command (hans)
155 - Fix typo (katzj)
157 * Wed Sep 03 2008 Chris Lumens <clumens@redhat.com> - 1.43-1
158 - Revert "Do not include passphrases for encrypted block devices in
159 anaconda-ks.cfg." (dlehman)
160 - yum doesn't like when mirrorlist is "". (clumens)
162 * Mon Aug 11 2008 Chris Lumens <clumens@redhat.com> - 1.42-1
163 - Add rescue command to pykickstart (atodorov)
164 - Sort %packages output (katzj)
165 - Fix a typo (atodorov).
167 * Fri Aug 01 2008 Chris Lumens <clumens@redhat.com> - 1.41-1
168 - RHEL5 supports ignoredisk --only-use now too. (clumens)
169 - Do not include passphrases for encrypted block devices in
170 anaconda-ks.cfg. (dlehman)
171 - Fix F9,F10,RHEL5 "part" commands to use the same class as
172 "partition". (dlehman)
173 - Add an apply method() for commands and implement for lang (katzj)
175 * Tue Jul 15 2008 Chris Lumens <clumens@redhat.com> - 1.40-1
176 - RHEL5_LogVolData should inherit from FC4, not FC3.
177 Also fix FC9->F9 typo. (dlehman)
178 - Support creation of encrypted block devices in RHEL5. (#449830) (dlehman)
179 - Use the right LogVolData objects for RHEL3 and 4 (jlaska). (clumens)
180 - We no longer use rhpl for translations. (clumens)
181 - All the base classes should derive from object. (clumens)
183 * Fri Jun 13 2008 Chris Lumens <clumens@redhat.com> - 1.39-1
184 - It's helpful to return the parser object. (clumens)
186 * Tue Jun 10 2008 Chris Lumens <clumens@redhat.com> - 1.38-1
187 - Fix loading the Handler object by looking for a more specific
188 name (#450740). (clumens)
190 * Sun Jun 08 2008 Chris Lumens <clumens@redhat.com> - 1.37-1
191 - XConfig is still used by other projects, so just deprecate some
192 options. (clumens)
194 * Thu May 29 2008 Chris Lumens <clumens@redhat.com> - 1.36-1
195 - It should be repo --cost, not repo --priority. (clumens)
197 * Fri May 23 2008 Chris Lumens <clumens@redhat.com> - 1.35-1
198 - Bring driverdisk command in line with the docs. (clumens)
199 - Change RAID command print priorities (jlaska).
200 - According to docs, physvols are space delimited. (jlaska)
201 - Don't write the label out twice (jlaska).
202 - Deprecate monitor and xconfig commands. (clumens)
204 * Wed May 07 2008 Chris Lumens <clumens@redhat.com> - 1.34-1
205 - Load the handler module automatically. (clumens)
206 - Add support for F10. (clumens)
207 - Initialize cmd.handler earlier; fixes repo.methodToRepo() (markmc)
208 - Don't shadow builtin function names. (clumens)
209 - Running check is now required before pykickstart can be packaged. (clumens)
210 - Reorganize code a little bit to pass pychecker. (clumens)
212 * Tue Apr 08 2008 Chris Lumens <clumens@redhat.com> - 1.33-1
213 - Fix whitespace when printing out the bootloader command (pmeyers).
214 - Fix the type on bootloader --timeout processing. (clumens)
216 * Wed Apr 02 2008 Chris Lumens <clumens@redhat.com> - 1.32-1
217 - Make the string reader act like the file reader upon EOF. (clumens)
218 - Add syntax for encrypted logical volumes. (clumens)
220 * Tue Mar 25 2008 Chris Lumens <clumens@redhat.com> - 1.31-1
221 - Support end-of-line comments. (clumens)
222 - Lots of translation updates.
224 * Tue Feb 26 2008 Chris Lumens <clumens@redhat.com> - 1.30-1
225 - Reverse writePriorities of iscsi and iscsname (#434965, jlaska).
226 - Fix printing of iscsiname command (#434945, jlaska).
227 - Don't traceback on ENOENT. (pnasrat)
228 - Store the mouse name as a string, not a list. (clumens)
229 - Update translations.
231 * Wed Jan 30 2008 Chris Lumens <clumens@redhat.com> - 1.29-1
232 - Renamed bootproto=ask to bootproto=query, add to RHEL5 as well. (clumens)
234 * Wed Jan 23 2008 Chris Lumens <clumens@redhat.com> - 1.28-1
235 - Fix traceback on volgroup command. (clumens)
237 * Thu Jan 17 2008 Chris Lumens <clumens@redhat.com> - 1.27-1
238 - The bootprotoList needs to be defined before it's used. (clumens)
240 * Thu Jan 17 2008 Chris Lumens <clumens@redhat.com> - 1.26-1
241 - Add support for network --bootproto=ask. (clumens)
243 * Tue Jan 15 2008 Chris Lumens <clumens@redhat.com> - 1.25-1
244 - Add the version to the output ks file. (clumens)
245 - Add syntax for encrypted partitions and raid devices. (clumens)
247 * Thu Jan 10 2008 Chris Lumens <clumens@redhat.com> - 1.24-1
248 - Make inheritance and overriding of %packages work (#427768). (clumens)
249 - Add an option for which languages should be installed. (katzj)
250 - Use the right name for the iscsi --target variable (#418781). (clumens)
252 * Mon Dec 10 2007 Chris Lumens <clumens@redhat.com> - 1.23-1
253 - Take Makefile improvements from anaconda.
254 - Fix a traceback on F9 zerombr command (#395431).
255 - Update to handle new Python eggs packaging.
257 * Tue Nov 20 2007 Chris Lumens <clumens@redhat.com> 1.22-1
258 - Don't process or write out vnc --enabled (jlaska AT redhat DOT com).
259 - Fix a traceback in the clearpart command.
261 * Tue Nov 06 2007 Chris Lumens <clumens@redhat.com> 1.21-1
262 - Save script line numbers for debugging.
263 - More internal cleanups.
265 * Wed Oct 31 2007 Chris Lumens <clumens@redhat.com> 1.20-1
266 - Pull wiki docs from the new location.
267 - Fix error messages for options that have been removed after having been
268 previously deprecated.
269 - zerombr no longer takes any arguments.
270 - %packages --ignoredeps --resolvedeps have been removed.
271 - firewall --high --medium have been removed.
272 - vnc --connect has been removed.
273 - xconfig options from monitor have now been removed.
274 - --bytes-per-inode has been marked as deprecated.
275 - Fix typos.
276 - Add --fsprofile option to disk commands (pjones).
277 - Add F9 support (pjones).
278 - Lots of internal fixes (clumens, pjones).
280 * Tue Oct 23 2007 Chris Lumens <clumens@redhat.com> 1.19-1
281 - Fix a traceback on the cdrom method.
283 * Thu Oct 18 2007 Chris Lumens <clumens@redhat.com> 1.18-1
284 - Don't write out %end to packages and scripts if the syntax version doesn't
285 support it.
286 - Remove obsolete translation (#332221).
288 * Thu Oct 04 2007 Chris Lumens <clumens@redhat.com> 1.17-1
289 - Simplify argument processing and printing.
291 * Wed Oct 03 2007 Chris Lumens <clumens@redhat.com> 1.16-1
292 - Undeprecate %packages --excludedocs.
293 - Fix a traceback in the device command handling.
294 - Add bootloader --timeout (katzj).
296 * Tue Oct 02 2007 Chris Lumens <clumens@redhat.com> 1.15-1
297 - Update translations (#259121).
298 - The device command no longer takes a type argument.
300 * Fri Sep 28 2007 Chris Lumens <clumens@redhat.com> 1.14-1
301 - Fix output formatting for packages section header (#310211).
302 - Add a script to flatten kickstart files containing includes (katzj).
304 * Wed Sep 12 2007 Chris Lumens <clumens@redhat.com> 1.13-1
305 - Add a function to convert URL method strings into repo objects
306 (jkeating).
307 - Writer formatting fixes.
308 - Add kickstart documentation from the Fedora Wiki.
310 * Tue Sep 04 2007 Chris Lumens <clumens@redhat.com> 1.12-1
311 - Fix lots of problems in processing the bootloader, device, network, and
312 raid commands.
313 - Add %end when writing out scripts and packages.
314 - Add a makefile target to run pychecker to cut down on errors in
315 releases.
317 * Mon Sep 3 2007 Jeremy Katz <katzj@redhat.com> - 1.11-1
318 - fix a few tracebacks
320 * Fri Aug 31 2007 Chris Lumens <clumens@redhat.com> 1.10-1
321 - Add network --ipv6=.
323 * Fri Aug 24 2007 Chris Lumens <clumens@redhat.com> 1.9-1
324 - Add support for the %end directive to be placed at the end of scripts
325 and packages sections. Deprecate old syntax.
326 - Clean up after ksvalidator if pykickstart issues a traceback.
327 - Add support for repo --priority --includepkgs --excludepkgs.
328 - Fix newline at end of reboot --eject output (#253562).
330 * Mon Aug 13 2007 Chris Lumens <clumens@redhat.com> 1.8-1
331 - Fix type checking of string values.
333 * Thu Aug 09 2007 Chris Lumens <clumens@redhat.com> 1.7-1
334 - Clarify license in spec file and all source files.
335 - Check string values to options to make sure they're not other options
336 (#251318).
338 * Thu Aug 02 2007 Chris Lumens <clumens@redhat.com> 1.6-1
339 - Fix a couple tracebacks in ksvalidator.
340 - Change --class to --dhcpclass (#248912).
342 * Thu Jul 19 2007 Chris Lumens <clumens@redhat.com> 1.5-2
343 - Require rhpl (#248953).
345 * Tue Jul 17 2007 Chris Lumens <clumens@redhat.com> 1.5-1
346 - Fix traceback when calling preprocessKickstart.
348 * Tue Jul 17 2007 Chris Lumens <clumens@redhat.com> 1.4-1
349 - Add methods to handle the %ksappend directive.
350 - Fix ignoredisk --disks.
352 * Wed Jul 11 2007 Chris Lumens <clumens@redhat.com> - 1.3-1
353 - Add support for ignoredisk --only-use.
354 - Fix traceback in raid command printing method (#246709).
356 * Fri Jun 08 2007 Chris Lumens <clumens@redhat.com> - 1.2-2
357 - Fix package review problems (#226334).
359 * Mon Jun 04 2007 Chris Lumens <clumens@redhat.com> - 1.2-1
360 - Fix harddrive install method error checking (#232492).
361 - Set authentication information from the input line to preserve quoting
362 (#241657).
363 - Allow included files to be given by URL.
364 - Fix typo in user --iscrypted option.
366 * Mon May 14 2007 Chris Lumens <clumens@redhat.com> - 1.1-1
367 - Better regexes for splitting version strings into family and version.
368 - Add basic support for RHEL3.
369 - Update translations.
371 * Fri Apr 13 2007 Chris Lumens <clumens@redhat.com> - 1.0-1
372 - Update documentation.
373 - Update translations.
375 * Mon Mar 19 2007 Chris Lumens <clumens@redhat.com> - 0.100-1
376 - bootloader should be written out after upgrade/install.
377 - Treat class names as unicode strings (#231053).
379 * Wed Mar 07 2007 Chris Lumens <clumens@redhat.com> - 0.99-1
380 - The timezone command didn't recognize --isUtc before FC6 (#231189).
381 - Recognize %ksappend lines in ksvalidator.
382 - Don't set default values in some command __init__ methods.
383 - Added an updates command.
384 - Add support for RAID10.
386 * Mon Feb 26 2007 Chris Lumens <clumens@redhat.com> - 0.98-1
387 - Fix device command syntax to match anaconda.
388 - Fix __call__ on method command.
390 * Wed Feb 21 2007 Chris Lumens <clumens@redhat.com> - 0.97-1
391 - Fix traceback when not overriding default mappings (#229505).
393 * Tue Feb 20 2007 Chris Lumens <clumens@redhat.com> - 0.96-1
394 - Fix __str__ methods for langsupport and reboot commands.
395 - Renamed BaseHandler.empty to BaseHandler.maskAllExcept.
396 - Split command objects out into their own files in commands/.
397 - Rename command objects to start with Version_.
398 - Support extended group selection syntax.
400 * Wed Feb 14 2007 Chris Lumens <clumens@redhat.com> - 0.95-1
401 - KickstartParser no longer takes a version argument.
402 - Be more lenient in what strings stringToVersion accepts.
403 - Allow setting state on one data object from multiple files.
405 * Wed Feb 07 2007 Chris Lumens <clumens@redhat.com> - 0.94-1
406 - Add a newline to the end of the key command output.
407 - Use network bootproto constants (#197694).
408 - Fix tracebacks in subclass __str__ methods (#226734).
410 * Wed Jan 31 2007 Chris Lumens <clumens@redhat.com> - 0.93-2
411 - Make some minor spec file changes to get closer to the extras guidelines.
413 * Thu Jan 25 2007 Chris Lumens <clumens@redhat.com> - 0.93-1
414 - Add support for FC3, RHEL4, and RHEL5.
415 - The key command was not supported until after FC6.
416 - Accept more strings in stringToVersion.
418 * Fri Jan 19 2007 Chris Lumens <clumens@redhat.com> - 0.92-1
419 - Fix KickstartVersionError reporting.
420 - Add a version attribute to handler objects.
421 - Fix line number reporting on lots of commands.
422 - Add initial support for Fedora 7 and remove deprecated commands.
423 - Accept a --default argument to the %%packages header (#221305).
425 * Wed Jan 17 2007 Chris Lumens <clumens@redhat.com> - 0.91-1
426 - Add a method to read kickstart files from strings.
428 * Tue Jan 16 2007 Chris Lumens <clumens@redhat.com> - 0.90-1
429 - Support multiple versions of kickstart syntax from one code base
430 (#189348).
431 - Fix inconsistency between Script parser and writer (#222877).
433 * Fri Dec 15 2006 Chris Lumens <clumens@redhat.com> - 0.43-1
434 - Pull in new translations (#216620).
436 * Thu Dec 7 2006 Jeremy Katz <katzj@redhat.com> - 0.42-2
437 - rebuild against python 2.5
439 * Tue Dec 05 2006 Chris Lumens <clumens@redhat.com> - 0.42-1
440 - Fix traceback when writing out repo command (#218274).
442 * Fri Dec 01 2006 Chris Lumens <clumens@redhat.com> - 0.41-1
443 - Fix traceback when using deprecated commands (#218047, #218059).
445 * Thu Nov 30 2006 Chris Lumens <clumens@redhat.com> - 0.40-1
446 - Pull in new translations (#216620).
447 - Add --level argument to logging command writer.
449 * Tue Oct 24 2006 Chris Lumens <clumens@redhat.com> - 0.39-2
450 - Fix release number.
452 * Tue Oct 24 2006 Chris Lumens <clumens@redhat.com> - 0.39-1
453 - Add writer for --key (#211997).
455 * Tue Oct 17 2006 Jeremy Katz <katzj@redhat.com> - 0.38-1
456 - allow --skip for installation number as well (#207029)
458 * Mon Oct 16 2006 Jeremy Katz <katzj@redhat.com> - 0.37-1
459 - support for installation numbers (#207029)
461 * Fri Oct 13 2006 Bill Nottingham <notting@redhat.com> - 0.36-1
462 - use valid charsets in translations (#210720)
464 * Fri Sep 29 2006 Chris Lumens <clumens@redhat.com> - 0.35-1
465 - Fix traceback in harddrive command (#208557).
467 * Mon Sep 25 2006 Chris Lumens <clumens@redhat.com> - 0.34-1
468 - Add support for --biospart option to harddrive (#207585).
469 - Update writer for syntax changes.
471 * Wed Sep 20 2006 Jeremy Katz <katzj@redhat.com> - 0.33-1
472 - improved iscsi syntax
473 - allow multiple zfcp devs
475 * Thu Jul 20 2006 Chris Lumens <clumens@redhat.com> 0.32-1
476 - Limit --bootproto to what anaconda supports.
477 - Add --noipv4 and --noipv6 network options.
479 * Tue Jun 20 2006 Chris Lumens <clumens@redhat.com> 0.31-1
480 - Handle nfs --opts (katzj).
481 - RAID devices should be integers instead of strings (#176537).
482 - Add initial support for iscsi (katzj).
484 * Tue Jun 06 2006 Chris Lumens <clumens@redhat.com> 0.30-2
485 - Add BuildRequires to fix building under mock (#194156, Joost Soeterbroek
486 <fedora AT soeterbroek.com>).
488 * Thu May 25 2006 Chris Lumens <clumens@redhat.com> 0.30-1
489 - Change order of LVM-related writing functions (#193073).
490 - Require urlgrabber.
491 - Return a more useful error message on unknown commands.
492 - Fix logvol writing typo.
493 - Make ksvalidator validate from a URL in addition to a file.
494 - Don't write out an empty packages section (#192851).
496 * Tue May 23 2006 Chris Lumens <clumens@redhat.com> 0.29-1
497 - Add multipath command, handlers, and data objects (pjones).
498 - Rename --ports to --port in writer.
500 * Mon May 15 2006 Chris Lumens <clumens@redhat.com> 0.28-1
501 - Support --mtu for the network command (#191328).
502 - Accept --isUtc for backwards compatibility.
504 * Wed May 04 2006 Chris Lumens <clumens@redhat.com> 0.27-1
505 - Output formatting fixes.
506 - Added commands for managing users and services.
508 * Mon Apr 17 2006 Chris Lumens <clumens@redhat.com> 0.26-1
509 - Ignore spaces before group names (#188095).
510 - Added some translations.
511 - Add options for repo command.
512 - Reorder %%packages section output.
513 - Output %%packages header options.
514 - Initialize RAID and volume group members to empty lists.
516 * Mon Mar 27 2006 Chris Lumens <clumens@redhat.com> 0.25-1
517 - Add support for the logging command.
519 * Mon Mar 27 2006 Chris Lumens <clumens@redhat.com> 0.24-1
520 - Don't write out a blank xconfig line.
521 - Reorder output handlers to group like commands together.
522 - Mark strings for translation.
524 * Tue Mar 07 2006 Chris Lumens <clumens@redhat.com> 0.23-1
525 - Backwards compatibility support for options to zerombr.
527 * Fri Feb 24 2006 Chris Lumens <clumens@redhat.com> 0.22-1
528 - Get ignoredisk working again (#182934).
530 * Fri Feb 17 2006 Chris Lumens <clumens@redhat.com> 0.21-1
531 - Provide an option to not traceback on missing include files (#181760).
532 - Update programming documentation.
534 * Mon Feb 13 2006 Chris Lumens <clumens@redhat.com> 0.20-1
535 - Correctly set --noformat and --useexisting on lvm and raid.
537 * Mon Feb 13 2006 Chris Lumens <clumens@redhat.com> 0.19-1
538 - --onboot requires a value (#180987).
539 - Be more strict about commands that don't take arguments.
541 * Thu Feb 09 2006 Chris Lumens <clumens@redhat.com> 0.18-1
542 - Fix some errors pychecker caught.
543 - Allow exceptions to not be fatal so ksvalidator can spot more errors in
544 a single pass (#179894).
546 * Wed Feb 01 2006 Chris Lumens <clumens@redhat.com> 0.17-1
547 - Don't set a default port for vnc.
549 * Tue Jan 31 2006 Chris Lumens <clumens@redhat.com> 0.16-1
550 - Give dmraid string an initial value.
551 - Handle None on partition size.
553 * Tue Jan 31 2006 Peter Jones <pjones@redhat.com> 0.15-1
554 - Add dmraid support
556 * Mon Jan 30 2006 Chris Lumens <clumens@redhat.com> 0.14-1
557 - Fix VNC parameter parsing (#179209).
558 - Deprecate --connect. Add --host and --port instead.
560 * Thu Jan 19 2006 Chris Lumens <clumens@redhat.com> 0.13-1
561 - Recognize the --eject parameter to shutdown/halt.
562 - Store the exact post-installation action in ksdata.
564 * Mon Jan 09 2006 Chris Lumens <clumens@redhat.com> 0.12-1
565 - Clean up output quoting.
566 - Finish removing monitor-related stuff from xconfig.
568 * Mon Dec 12 2005 Chris Lumens <clumens@redhat.com> 0.11-1
569 - Deprecate monitor-related options to xconfig.
571 * Thu Dec 08 2005 Chris Lumens <clumens@redhat.com> 0.10-1
572 - Support --bytes-per-inode on raid
573 (Curtis Doty <Curtis at GreenKey.net> #175288).
575 * Wed Nov 16 2005 Jeremy Katz <katzj@redhat.com> - 0.9-1
576 - fixup network --onboot
578 * Thu Nov 03 2005 Chris Lumens <clumens@redhat.com> 0.8-1
579 - Default to SELINUX_ENFORCING.
580 - Default partition sizes to None for anaconda (#172378).
581 - Don't call shlex.split on anything inside a script (#172313).
583 * Tue Nov 01 2005 Chris Lumens <clumens@redhat.com> 0.7-1
584 - Fix clearpart --all.
585 - vnc command does not require --connect option (#172192).
586 - network --onboot does not take any option.
587 - Remove extra spaces from firewall --ports and --trust.
588 - Write out network --<service> options.
590 * Fri Oct 28 2005 Chris Lumens <clumens@redhat.com> 0.6-1
591 - Add --resolvedeps and --ignoredeps as deprecated options.
592 - Pass line number to header functions.
594 * Mon Oct 24 2005 Chris Lumens <clumens@redhat.com> 0.5-1
595 - Add line numbers to exception reporting.
596 - Added ksvalidator.
598 * Wed Oct 19 2005 Chris Lumens <clumens@redhat.com> 0.4-1
599 - Correct deprecated attribute on options.
600 - Added programming documentation.
602 * Thu Oct 13 2005 Chris Lumens <clumens@redhat.com> 0.3-2
603 - Correct python lib directory on 64-bit archs (#170621).
605 * Fri Oct 07 2005 Chris Lumens <clumens@redhat.com> 0.3-1
606 - Add a deprecated attribute to options.
607 - Add --card option back to xconfig and mark as deprecated.
608 - Throw a deprecation warning on mouse and langsupport commands.
609 - Rename Writer to KickstartWriter for consistency.
610 - Collapse scripts into a single list and add an attribute on Script to
611 differentiate.
613 * Wed Oct 05 2005 Chris Lumens <clumens@redhat.com> 0.2-1
614 - Rename module to pykickstart to avoid conflicts in anaconda.
615 - Rename data classes for consistency.
616 - Add default bytesPerInode settings.
618 * Wed Oct 05 2005 Chris Lumens <clumens@redhat.com> 0.1-1
619 - Created package from anaconda.