Add support for the group command to F12.
[pykickstart.git] / pykickstart.spec
blobe7dbc08ab9148a556be6868c62d9928c6a6dfda6
1 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
3 Summary: A python library for manipulating kickstart files
4 Name: pykickstart
5 Url: http://fedoraproject.org/wiki/pykickstart
6 Version: 1.54
7 Release: 1%{?dist}
8 # This is a Red Hat maintained package which is specific to
9 # our distribution. Thus the source is only available from
10 # within this srpm.
11 Source0: %{name}-%{version}.tar.gz
13 License: GPLv2
14 Group: System Environment/Libraries
15 BuildArch: noarch
16 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
17 BuildRequires: python-devel, gettext, python-setuptools-devel
18 Requires: python, python-urlgrabber
20 %description
21 The pykickstart package is a python library for manipulating kickstart
22 files.
24 %prep
25 %setup -q
26 make
28 %build
30 %install
31 rm -rf %{buildroot}
32 make DESTDIR=%{buildroot} install
33 %find_lang %{name}
35 %clean
36 rm -rf %{buildroot}
38 %files -f %{name}.lang
39 %defattr(-,root,root,-)
40 %doc README ChangeLog COPYING docs/programmers-guide
41 %doc docs/kickstart-docs.txt
42 %{python_sitelib}/*
43 %{_bindir}/ksvalidator
44 %{_bindir}/ksflatten
45 %{_bindir}/ksverdiff
47 %changelog
48 * Mon May 18 2009 Chris Lumens <clumens@redhat.com> - 1.54-1
49 - Make sure the F11 handler gets used for "partition" and "part" (#501020).
51 * Wed Apr 29 2009 Chris Lumens <clumens@redhat.com> - 1.53-1
52 - Move lineno= from KSOptionParser.__init__ to parse_args (#497149). (clumens)
53 - Use the F11 version of the partition command. (clumens)
54 - Remove the --start and --end options since anaconda no longer uses them. (clumens)
55 - Remove a broken test case. (clumens)
57 * Wed Feb 18 2009 Chris Lumens <clumens@redhat.com> - 1.52-1
58 - Add lots more test cases (alindebe, mgracik, stickster).
59 - Add a skip attribute on key to shut up pychecker.
60 - Only show autostep command when requested (jlaska)
61 - Strip spaces from service names, and require an option to be provided.
62 - Surround services lists in double quotes.
63 - Remove the extra space from the services __str__ method.
64 - Fix output formatting bugs in firewall, partition, and repo (mgracik).
65 - Specifying both or neither of --drives and --only-use should be an error.
66 - Corrected newline char in return value of FC6_Method. (mgracik)
67 - Make --drives a required option for FC3, and catch no args on F8.
68 - Fix final printing of the rescue command (mgracik).
69 - Surround output strings in double quotes.
70 - Fix a typo in the deviceprobe command.
71 - Revert the more strict option processing on displaymode.
72 - Properly handle erroring on extra args, not just extra options.
73 - Don't use the logging class since it interferes with the logging test.
74 - port without host should raise KickstartParseError, not kickstartValueError.
75 - Add the --key option to option processing, since it's a valid argument.
76 - Fix test cases that were failing due to the new use of KSOptionParser.
77 - Teach driverdisk.py command to reject extra partitions (stickster).
78 - Add KSOptionParser to all commands ... enables more strick option checking (jlaska).
79 - Use KSOptionParser so we can catch bad command options (jlaska).
81 * Thu Jan 29 2009 Chris Lumens <clumens@redhat.com> - 1.51-1
82 - Make a couple changes to how the logging command is handled.
83 - Add a lot of test cases (clumens, alindebe, jlaska, fcami, adamwill, pfrields).
84 - Fix output formatting for the rootpw command.
85 - For commands that take exactly one argument, check and error correctly.
86 - Surround module options in quotes on the output side (jlaska).
87 - Set module opts in the FC3 handler correctly.
88 - Fix newlines on the device command output (jlaska).
89 - If --autoscreenshot is not specified, still output "autostep".
90 - Move the currentCmd and currentLine into getParser(). (jlaska)
91 - Write out an selinux line if set to disabled, but not if None.
92 - F9_LogVolData should inherit from FC4_LogVolData, not FC3_LogVolData (jlaska).
93 - Add unittest framework along with logvol and vnc unittests. (jlaska)
94 - Don't set the KSOption.required attribute in the constructor (jlaska).
96 * Sat Jan 10 2009 Chris Lumens <clumens@redhat.com> - 1.50-1
97 - Add a script to diff two versions of kickstart syntax.
98 - Add an option to ksvalidator to list all available syntax versions.
99 - Remove a couple extra newlines in output formatting.
100 - Add documentation for the new %include representation.
101 - Add support %include to the pykickstart data objects.
103 * Thu Jan 08 2009 Chris Lumens <clumens@redhat.com> - 1.49-1
104 - Add upgrade --root-device (atodorov, #471232).
105 - Use python's builtin set rather than the Sets module (#477836, dcantrell).
107 * Tue Dec 23 2008 Chris Lumens <clumens@redhat.com> - 1.48-1
108 - Allow ignoring group metadata from repos, using a '--ignoregroups'
109 boolean. (notting)
110 - Add initial support for F11.
111 - Specify the command versions in the handlers instead of making copies.
112 - Remove empty and pointless __init__ methods.
113 - Pass arguments to superclasses via *args and **kwargs, all the way up.
114 - Add removedKeywords and removedAttrs lists on Commands and Data.
115 - Fix version regexes to handle double digits and minor releases (jlaska).
117 * Thu Oct 30 2008 Chris Lumens <clumens@redhat.com> - 1.47-1
118 - Fix enabling services we specify by specific options.
120 * Mon Oct 27 2008 Chris Lumens <clumens@redhat.com> - 1.46-1
121 - Add support for firewall --service (#467005).
123 * Tue Oct 14 2008 Chris Lumens <clumens@redhat.com> - 1.45-1
124 - Lots of translation updates.
125 - Remove use of string.partition for python2.4 (atodorov).
127 * Mon Sep 22 2008 Chris Lumens <clumens@redhat.com> - 1.44-1
128 - Add support for reverse CHAP to the kickstart iscsi command (hans)
129 - Fix typo (katzj)
131 * Wed Sep 03 2008 Chris Lumens <clumens@redhat.com> - 1.43-1
132 - Revert "Do not include passphrases for encrypted block devices in
133 anaconda-ks.cfg." (dlehman)
134 - yum doesn't like when mirrorlist is "". (clumens)
136 * Mon Aug 11 2008 Chris Lumens <clumens@redhat.com> - 1.42-1
137 - Add rescue command to pykickstart (atodorov)
138 - Sort %packages output (katzj)
139 - Fix a typo (atodorov).
141 * Fri Aug 01 2008 Chris Lumens <clumens@redhat.com> - 1.41-1
142 - RHEL5 supports ignoredisk --only-use now too. (clumens)
143 - Do not include passphrases for encrypted block devices in
144 anaconda-ks.cfg. (dlehman)
145 - Fix F9,F10,RHEL5 "part" commands to use the same class as
146 "partition". (dlehman)
147 - Add an apply method() for commands and implement for lang (katzj)
149 * Tue Jul 15 2008 Chris Lumens <clumens@redhat.com> - 1.40-1
150 - RHEL5_LogVolData should inherit from FC4, not FC3.
151 Also fix FC9->F9 typo. (dlehman)
152 - Support creation of encrypted block devices in RHEL5. (#449830) (dlehman)
153 - Use the right LogVolData objects for RHEL3 and 4 (jlaska). (clumens)
154 - We no longer use rhpl for translations. (clumens)
155 - All the base classes should derive from object. (clumens)
157 * Fri Jun 13 2008 Chris Lumens <clumens@redhat.com> - 1.39-1
158 - It's helpful to return the parser object. (clumens)
160 * Tue Jun 10 2008 Chris Lumens <clumens@redhat.com> - 1.38-1
161 - Fix loading the Handler object by looking for a more specific
162 name (#450740). (clumens)
164 * Sun Jun 08 2008 Chris Lumens <clumens@redhat.com> - 1.37-1
165 - XConfig is still used by other projects, so just deprecate some
166 options. (clumens)
168 * Thu May 29 2008 Chris Lumens <clumens@redhat.com> - 1.36-1
169 - It should be repo --cost, not repo --priority. (clumens)
171 * Fri May 23 2008 Chris Lumens <clumens@redhat.com> - 1.35-1
172 - Bring driverdisk command in line with the docs. (clumens)
173 - Change RAID command print priorities (jlaska).
174 - According to docs, physvols are space delimited. (jlaska)
175 - Don't write the label out twice (jlaska).
176 - Deprecate monitor and xconfig commands. (clumens)
178 * Wed May 07 2008 Chris Lumens <clumens@redhat.com> - 1.34-1
179 - Load the handler module automatically. (clumens)
180 - Add support for F10. (clumens)
181 - Initialize cmd.handler earlier; fixes repo.methodToRepo() (markmc)
182 - Don't shadow builtin function names. (clumens)
183 - Running check is now required before pykickstart can be packaged. (clumens)
184 - Reorganize code a little bit to pass pychecker. (clumens)
186 * Tue Apr 08 2008 Chris Lumens <clumens@redhat.com> - 1.33-1
187 - Fix whitespace when printing out the bootloader command (pmeyers).
188 - Fix the type on bootloader --timeout processing. (clumens)
190 * Wed Apr 02 2008 Chris Lumens <clumens@redhat.com> - 1.32-1
191 - Make the string reader act like the file reader upon EOF. (clumens)
192 - Add syntax for encrypted logical volumes. (clumens)
194 * Tue Mar 25 2008 Chris Lumens <clumens@redhat.com> - 1.31-1
195 - Support end-of-line comments. (clumens)
196 - Lots of translation updates.
198 * Tue Feb 26 2008 Chris Lumens <clumens@redhat.com> - 1.30-1
199 - Reverse writePriorities of iscsi and iscsname (#434965, jlaska).
200 - Fix printing of iscsiname command (#434945, jlaska).
201 - Don't traceback on ENOENT. (pnasrat)
202 - Store the mouse name as a string, not a list. (clumens)
203 - Update translations.
205 * Wed Jan 30 2008 Chris Lumens <clumens@redhat.com> - 1.29-1
206 - Renamed bootproto=ask to bootproto=query, add to RHEL5 as well. (clumens)
208 * Wed Jan 23 2008 Chris Lumens <clumens@redhat.com> - 1.28-1
209 - Fix traceback on volgroup command. (clumens)
211 * Thu Jan 17 2008 Chris Lumens <clumens@redhat.com> - 1.27-1
212 - The bootprotoList needs to be defined before it's used. (clumens)
214 * Thu Jan 17 2008 Chris Lumens <clumens@redhat.com> - 1.26-1
215 - Add support for network --bootproto=ask. (clumens)
217 * Tue Jan 15 2008 Chris Lumens <clumens@redhat.com> - 1.25-1
218 - Add the version to the output ks file. (clumens)
219 - Add syntax for encrypted partitions and raid devices. (clumens)
221 * Thu Jan 10 2008 Chris Lumens <clumens@redhat.com> - 1.24-1
222 - Make inheritance and overriding of %packages work (#427768). (clumens)
223 - Add an option for which languages should be installed. (katzj)
224 - Use the right name for the iscsi --target variable (#418781). (clumens)
226 * Mon Dec 10 2007 Chris Lumens <clumens@redhat.com> - 1.23-1
227 - Take Makefile improvements from anaconda.
228 - Fix a traceback on F9 zerombr command (#395431).
229 - Update to handle new Python eggs packaging.
231 * Tue Nov 20 2007 Chris Lumens <clumens@redhat.com> 1.22-1
232 - Don't process or write out vnc --enabled (jlaska AT redhat DOT com).
233 - Fix a traceback in the clearpart command.
235 * Tue Nov 06 2007 Chris Lumens <clumens@redhat.com> 1.21-1
236 - Save script line numbers for debugging.
237 - More internal cleanups.
239 * Wed Oct 31 2007 Chris Lumens <clumens@redhat.com> 1.20-1
240 - Pull wiki docs from the new location.
241 - Fix error messages for options that have been removed after having been
242 previously deprecated.
243 - zerombr no longer takes any arguments.
244 - %packages --ignoredeps --resolvedeps have been removed.
245 - firewall --high --medium have been removed.
246 - vnc --connect has been removed.
247 - xconfig options from monitor have now been removed.
248 - --bytes-per-inode has been marked as deprecated.
249 - Fix typos.
250 - Add --fsprofile option to disk commands (pjones).
251 - Add F9 support (pjones).
252 - Lots of internal fixes (clumens, pjones).
254 * Tue Oct 23 2007 Chris Lumens <clumens@redhat.com> 1.19-1
255 - Fix a traceback on the cdrom method.
257 * Thu Oct 18 2007 Chris Lumens <clumens@redhat.com> 1.18-1
258 - Don't write out %end to packages and scripts if the syntax version doesn't
259 support it.
260 - Remove obsolete translation (#332221).
262 * Thu Oct 04 2007 Chris Lumens <clumens@redhat.com> 1.17-1
263 - Simplify argument processing and printing.
265 * Wed Oct 03 2007 Chris Lumens <clumens@redhat.com> 1.16-1
266 - Undeprecate %packages --excludedocs.
267 - Fix a traceback in the device command handling.
268 - Add bootloader --timeout (katzj).
270 * Tue Oct 02 2007 Chris Lumens <clumens@redhat.com> 1.15-1
271 - Update translations (#259121).
272 - The device command no longer takes a type argument.
274 * Fri Sep 28 2007 Chris Lumens <clumens@redhat.com> 1.14-1
275 - Fix output formatting for packages section header (#310211).
276 - Add a script to flatten kickstart files containing includes (katzj).
278 * Wed Sep 12 2007 Chris Lumens <clumens@redhat.com> 1.13-1
279 - Add a function to convert URL method strings into repo objects
280 (jkeating).
281 - Writer formatting fixes.
282 - Add kickstart documentation from the Fedora Wiki.
284 * Tue Sep 04 2007 Chris Lumens <clumens@redhat.com> 1.12-1
285 - Fix lots of problems in processing the bootloader, device, network, and
286 raid commands.
287 - Add %end when writing out scripts and packages.
288 - Add a makefile target to run pychecker to cut down on errors in
289 releases.
291 * Mon Sep 3 2007 Jeremy Katz <katzj@redhat.com> - 1.11-1
292 - fix a few tracebacks
294 * Fri Aug 31 2007 Chris Lumens <clumens@redhat.com> 1.10-1
295 - Add network --ipv6=.
297 * Fri Aug 24 2007 Chris Lumens <clumens@redhat.com> 1.9-1
298 - Add support for the %end directive to be placed at the end of scripts
299 and packages sections. Deprecate old syntax.
300 - Clean up after ksvalidator if pykickstart issues a traceback.
301 - Add support for repo --priority --includepkgs --excludepkgs.
302 - Fix newline at end of reboot --eject output (#253562).
304 * Mon Aug 13 2007 Chris Lumens <clumens@redhat.com> 1.8-1
305 - Fix type checking of string values.
307 * Thu Aug 09 2007 Chris Lumens <clumens@redhat.com> 1.7-1
308 - Clarify license in spec file and all source files.
309 - Check string values to options to make sure they're not other options
310 (#251318).
312 * Thu Aug 02 2007 Chris Lumens <clumens@redhat.com> 1.6-1
313 - Fix a couple tracebacks in ksvalidator.
314 - Change --class to --dhcpclass (#248912).
316 * Thu Jul 19 2007 Chris Lumens <clumens@redhat.com> 1.5-2
317 - Require rhpl (#248953).
319 * Tue Jul 17 2007 Chris Lumens <clumens@redhat.com> 1.5-1
320 - Fix traceback when calling preprocessKickstart.
322 * Tue Jul 17 2007 Chris Lumens <clumens@redhat.com> 1.4-1
323 - Add methods to handle the %ksappend directive.
324 - Fix ignoredisk --disks.
326 * Wed Jul 11 2007 Chris Lumens <clumens@redhat.com> - 1.3-1
327 - Add support for ignoredisk --only-use.
328 - Fix traceback in raid command printing method (#246709).
330 * Fri Jun 08 2007 Chris Lumens <clumens@redhat.com> - 1.2-2
331 - Fix package review problems (#226334).
333 * Mon Jun 04 2007 Chris Lumens <clumens@redhat.com> - 1.2-1
334 - Fix harddrive install method error checking (#232492).
335 - Set authentication information from the input line to preserve quoting
336 (#241657).
337 - Allow included files to be given by URL.
338 - Fix typo in user --iscrypted option.
340 * Mon May 14 2007 Chris Lumens <clumens@redhat.com> - 1.1-1
341 - Better regexes for splitting version strings into family and version.
342 - Add basic support for RHEL3.
343 - Update translations.
345 * Fri Apr 13 2007 Chris Lumens <clumens@redhat.com> - 1.0-1
346 - Update documentation.
347 - Update translations.
349 * Mon Mar 19 2007 Chris Lumens <clumens@redhat.com> - 0.100-1
350 - bootloader should be written out after upgrade/install.
351 - Treat class names as unicode strings (#231053).
353 * Wed Mar 07 2007 Chris Lumens <clumens@redhat.com> - 0.99-1
354 - The timezone command didn't recognize --isUtc before FC6 (#231189).
355 - Recognize %ksappend lines in ksvalidator.
356 - Don't set default values in some command __init__ methods.
357 - Added an updates command.
358 - Add support for RAID10.
360 * Mon Feb 26 2007 Chris Lumens <clumens@redhat.com> - 0.98-1
361 - Fix device command syntax to match anaconda.
362 - Fix __call__ on method command.
364 * Wed Feb 21 2007 Chris Lumens <clumens@redhat.com> - 0.97-1
365 - Fix traceback when not overriding default mappings (#229505).
367 * Tue Feb 20 2007 Chris Lumens <clumens@redhat.com> - 0.96-1
368 - Fix __str__ methods for langsupport and reboot commands.
369 - Renamed BaseHandler.empty to BaseHandler.maskAllExcept.
370 - Split command objects out into their own files in commands/.
371 - Rename command objects to start with Version_.
372 - Support extended group selection syntax.
374 * Wed Feb 14 2007 Chris Lumens <clumens@redhat.com> - 0.95-1
375 - KickstartParser no longer takes a version argument.
376 - Be more lenient in what strings stringToVersion accepts.
377 - Allow setting state on one data object from multiple files.
379 * Wed Feb 07 2007 Chris Lumens <clumens@redhat.com> - 0.94-1
380 - Add a newline to the end of the key command output.
381 - Use network bootproto constants (#197694).
382 - Fix tracebacks in subclass __str__ methods (#226734).
384 * Wed Jan 31 2007 Chris Lumens <clumens@redhat.com> - 0.93-2
385 - Make some minor spec file changes to get closer to the extras guidelines.
387 * Thu Jan 25 2007 Chris Lumens <clumens@redhat.com> - 0.93-1
388 - Add support for FC3, RHEL4, and RHEL5.
389 - The key command was not supported until after FC6.
390 - Accept more strings in stringToVersion.
392 * Fri Jan 19 2007 Chris Lumens <clumens@redhat.com> - 0.92-1
393 - Fix KickstartVersionError reporting.
394 - Add a version attribute to handler objects.
395 - Fix line number reporting on lots of commands.
396 - Add initial support for Fedora 7 and remove deprecated commands.
397 - Accept a --default argument to the %%packages header (#221305).
399 * Wed Jan 17 2007 Chris Lumens <clumens@redhat.com> - 0.91-1
400 - Add a method to read kickstart files from strings.
402 * Tue Jan 16 2007 Chris Lumens <clumens@redhat.com> - 0.90-1
403 - Support multiple versions of kickstart syntax from one code base
404 (#189348).
405 - Fix inconsistency between Script parser and writer (#222877).
407 * Fri Dec 15 2006 Chris Lumens <clumens@redhat.com> - 0.43-1
408 - Pull in new translations (#216620).
410 * Thu Dec 7 2006 Jeremy Katz <katzj@redhat.com> - 0.42-2
411 - rebuild against python 2.5
413 * Tue Dec 05 2006 Chris Lumens <clumens@redhat.com> - 0.42-1
414 - Fix traceback when writing out repo command (#218274).
416 * Fri Dec 01 2006 Chris Lumens <clumens@redhat.com> - 0.41-1
417 - Fix traceback when using deprecated commands (#218047, #218059).
419 * Thu Nov 30 2006 Chris Lumens <clumens@redhat.com> - 0.40-1
420 - Pull in new translations (#216620).
421 - Add --level argument to logging command writer.
423 * Tue Oct 24 2006 Chris Lumens <clumens@redhat.com> - 0.39-2
424 - Fix release number.
426 * Tue Oct 24 2006 Chris Lumens <clumens@redhat.com> - 0.39-1
427 - Add writer for --key (#211997).
429 * Tue Oct 17 2006 Jeremy Katz <katzj@redhat.com> - 0.38-1
430 - allow --skip for installation number as well (#207029)
432 * Mon Oct 16 2006 Jeremy Katz <katzj@redhat.com> - 0.37-1
433 - support for installation numbers (#207029)
435 * Fri Oct 13 2006 Bill Nottingham <notting@redhat.com> - 0.36-1
436 - use valid charsets in translations (#210720)
438 * Fri Sep 29 2006 Chris Lumens <clumens@redhat.com> - 0.35-1
439 - Fix traceback in harddrive command (#208557).
441 * Mon Sep 25 2006 Chris Lumens <clumens@redhat.com> - 0.34-1
442 - Add support for --biospart option to harddrive (#207585).
443 - Update writer for syntax changes.
445 * Wed Sep 20 2006 Jeremy Katz <katzj@redhat.com> - 0.33-1
446 - improved iscsi syntax
447 - allow multiple zfcp devs
449 * Thu Jul 20 2006 Chris Lumens <clumens@redhat.com> 0.32-1
450 - Limit --bootproto to what anaconda supports.
451 - Add --noipv4 and --noipv6 network options.
453 * Tue Jun 20 2006 Chris Lumens <clumens@redhat.com> 0.31-1
454 - Handle nfs --opts (katzj).
455 - RAID devices should be integers instead of strings (#176537).
456 - Add initial support for iscsi (katzj).
458 * Tue Jun 06 2006 Chris Lumens <clumens@redhat.com> 0.30-2
459 - Add BuildRequires to fix building under mock (#194156, Joost Soeterbroek
460 <fedora AT soeterbroek.com>).
462 * Thu May 25 2006 Chris Lumens <clumens@redhat.com> 0.30-1
463 - Change order of LVM-related writing functions (#193073).
464 - Require urlgrabber.
465 - Return a more useful error message on unknown commands.
466 - Fix logvol writing typo.
467 - Make ksvalidator validate from a URL in addition to a file.
468 - Don't write out an empty packages section (#192851).
470 * Tue May 23 2006 Chris Lumens <clumens@redhat.com> 0.29-1
471 - Add multipath command, handlers, and data objects (pjones).
472 - Rename --ports to --port in writer.
474 * Mon May 15 2006 Chris Lumens <clumens@redhat.com> 0.28-1
475 - Support --mtu for the network command (#191328).
476 - Accept --isUtc for backwards compatibility.
478 * Wed May 04 2006 Chris Lumens <clumens@redhat.com> 0.27-1
479 - Output formatting fixes.
480 - Added commands for managing users and services.
482 * Mon Apr 17 2006 Chris Lumens <clumens@redhat.com> 0.26-1
483 - Ignore spaces before group names (#188095).
484 - Added some translations.
485 - Add options for repo command.
486 - Reorder %%packages section output.
487 - Output %%packages header options.
488 - Initialize RAID and volume group members to empty lists.
490 * Mon Mar 27 2006 Chris Lumens <clumens@redhat.com> 0.25-1
491 - Add support for the logging command.
493 * Mon Mar 27 2006 Chris Lumens <clumens@redhat.com> 0.24-1
494 - Don't write out a blank xconfig line.
495 - Reorder output handlers to group like commands together.
496 - Mark strings for translation.
498 * Tue Mar 07 2006 Chris Lumens <clumens@redhat.com> 0.23-1
499 - Backwards compatibility support for options to zerombr.
501 * Fri Feb 24 2006 Chris Lumens <clumens@redhat.com> 0.22-1
502 - Get ignoredisk working again (#182934).
504 * Fri Feb 17 2006 Chris Lumens <clumens@redhat.com> 0.21-1
505 - Provide an option to not traceback on missing include files (#181760).
506 - Update programming documentation.
508 * Mon Feb 13 2006 Chris Lumens <clumens@redhat.com> 0.20-1
509 - Correctly set --noformat and --useexisting on lvm and raid.
511 * Mon Feb 13 2006 Chris Lumens <clumens@redhat.com> 0.19-1
512 - --onboot requires a value (#180987).
513 - Be more strict about commands that don't take arguments.
515 * Thu Feb 09 2006 Chris Lumens <clumens@redhat.com> 0.18-1
516 - Fix some errors pychecker caught.
517 - Allow exceptions to not be fatal so ksvalidator can spot more errors in
518 a single pass (#179894).
520 * Wed Feb 01 2006 Chris Lumens <clumens@redhat.com> 0.17-1
521 - Don't set a default port for vnc.
523 * Tue Jan 31 2006 Chris Lumens <clumens@redhat.com> 0.16-1
524 - Give dmraid string an initial value.
525 - Handle None on partition size.
527 * Tue Jan 31 2006 Peter Jones <pjones@redhat.com> 0.15-1
528 - Add dmraid support
530 * Mon Jan 30 2006 Chris Lumens <clumens@redhat.com> 0.14-1
531 - Fix VNC parameter parsing (#179209).
532 - Deprecate --connect. Add --host and --port instead.
534 * Thu Jan 19 2006 Chris Lumens <clumens@redhat.com> 0.13-1
535 - Recognize the --eject parameter to shutdown/halt.
536 - Store the exact post-installation action in ksdata.
538 * Mon Jan 09 2006 Chris Lumens <clumens@redhat.com> 0.12-1
539 - Clean up output quoting.
540 - Finish removing monitor-related stuff from xconfig.
542 * Mon Dec 12 2005 Chris Lumens <clumens@redhat.com> 0.11-1
543 - Deprecate monitor-related options to xconfig.
545 * Thu Dec 08 2005 Chris Lumens <clumens@redhat.com> 0.10-1
546 - Support --bytes-per-inode on raid
547 (Curtis Doty <Curtis at GreenKey.net> #175288).
549 * Wed Nov 16 2005 Jeremy Katz <katzj@redhat.com> - 0.9-1
550 - fixup network --onboot
552 * Thu Nov 03 2005 Chris Lumens <clumens@redhat.com> 0.8-1
553 - Default to SELINUX_ENFORCING.
554 - Default partition sizes to None for anaconda (#172378).
555 - Don't call shlex.split on anything inside a script (#172313).
557 * Tue Nov 01 2005 Chris Lumens <clumens@redhat.com> 0.7-1
558 - Fix clearpart --all.
559 - vnc command does not require --connect option (#172192).
560 - network --onboot does not take any option.
561 - Remove extra spaces from firewall --ports and --trust.
562 - Write out network --<service> options.
564 * Fri Oct 28 2005 Chris Lumens <clumens@redhat.com> 0.6-1
565 - Add --resolvedeps and --ignoredeps as deprecated options.
566 - Pass line number to header functions.
568 * Mon Oct 24 2005 Chris Lumens <clumens@redhat.com> 0.5-1
569 - Add line numbers to exception reporting.
570 - Added ksvalidator.
572 * Wed Oct 19 2005 Chris Lumens <clumens@redhat.com> 0.4-1
573 - Correct deprecated attribute on options.
574 - Added programming documentation.
576 * Thu Oct 13 2005 Chris Lumens <clumens@redhat.com> 0.3-2
577 - Correct python lib directory on 64-bit archs (#170621).
579 * Fri Oct 07 2005 Chris Lumens <clumens@redhat.com> 0.3-1
580 - Add a deprecated attribute to options.
581 - Add --card option back to xconfig and mark as deprecated.
582 - Throw a deprecation warning on mouse and langsupport commands.
583 - Rename Writer to KickstartWriter for consistency.
584 - Collapse scripts into a single list and add an attribute on Script to
585 differentiate.
587 * Wed Oct 05 2005 Chris Lumens <clumens@redhat.com> 0.2-1
588 - Rename module to pykickstart to avoid conflicts in anaconda.
589 - Rename data classes for consistency.
590 - Add default bytesPerInode settings.
592 * Wed Oct 05 2005 Chris Lumens <clumens@redhat.com> 0.1-1
593 - Created package from anaconda.