Add a new version of the device command that does not take a type argument.
[pykickstart.git] / pykickstart.spec
blob0586eb688628c4e76aa509c5114e4dc39d346d8d
1 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
3 Summary: A python library for manipulating kickstart files
4 Name: pykickstart
5 Url: http://fedoraproject.org/wiki/pykickstart
6 Version: 1.14
7 Release: 1%{?dist}
8 # This is a Red Hat maintained package which is specific to
9 # our distribution. Thus the source is only available from
10 # within this srpm.
11 Source0: %{name}-%{version}.tar.gz
13 License: GPLv2
14 Group: System Environment/Libraries
15 BuildArch: noarch
16 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
17 BuildRequires: python-devel, gettext
18 Requires: python, python-urlgrabber, rhpl
20 %description
21 The pykickstart package is a python library for manipulating kickstart
22 files.
24 %prep
25 %setup -q
26 make
28 %build
30 %install
31 rm -rf %{buildroot}
32 make DESTDIR=%{buildroot} install
33 %find_lang %{name}
35 %clean
36 rm -rf %{buildroot}
38 %files -f %{name}.lang
39 %defattr(-,root,root,-)
40 %doc README ChangeLog COPYING docs/programmers-guide
41 %doc docs/kickstart-docs.txt
42 %{python_sitelib}/pykickstart
43 %{_bindir}/ksvalidator
44 %{_bindir}/ksflatten
46 %changelog
47 * Fri Sep 28 2007 Chris Lumens <clumens@redhat.com> 1.14-1
48 - Fix output formatting for packages section header (#310211).
49 - Add a script to flatten kickstart files containing includes (katzj).
51 * Wed Sep 12 2007 Chris Lumens <clumens@redhat.com> 1.13-1
52 - Add a function to convert URL method strings into repo objects
53 (jkeating).
54 - Writer formatting fixes.
55 - Add kickstart documentation from the Fedora Wiki.
57 * Tue Sep 04 2007 Chris Lumens <clumens@redhat.com> 1.12-1
58 - Fix lots of problems in processing the bootloader, device, network, and
59 raid commands.
60 - Add %end when writing out scripts and packages.
61 - Add a makefile target to run pychecker to cut down on errors in
62 releases.
64 * Mon Sep 3 2007 Jeremy Katz <katzj@redhat.com> - 1.11-1
65 - fix a few tracebacks
67 * Fri Aug 31 2007 Chris Lumens <clumens@redhat.com> 1.10-1
68 - Add network --ipv6=.
70 * Fri Aug 24 2007 Chris Lumens <clumens@redhat.com> 1.9-1
71 - Add support for the %end directive to be placed at the end of scripts
72 and packages sections. Deprecate old syntax.
73 - Clean up after ksvalidator if pykickstart issues a traceback.
74 - Add support for repo --priority --includepkgs --excludepkgs.
75 - Fix newline at end of reboot --eject output (#253562).
77 * Mon Aug 13 2007 Chris Lumens <clumens@redhat.com> 1.8-1
78 - Fix type checking of string values.
80 * Thu Aug 09 2007 Chris Lumens <clumens@redhat.com> 1.7-1
81 - Clarify license in spec file and all source files.
82 - Check string values to options to make sure they're not other options
83 (#251318).
85 * Thu Aug 02 2007 Chris Lumens <clumens@redhat.com> 1.6-1
86 - Fix a couple tracebacks in ksvalidator.
87 - Change --class to --dhcpclass (#248912).
89 * Thu Jul 19 2007 Chris Lumens <clumens@redhat.com> 1.5-2
90 - Require rhpl (#248953).
92 * Tue Jul 17 2007 Chris Lumens <clumens@redhat.com> 1.5-1
93 - Fix traceback when calling preprocessKickstart.
95 * Tue Jul 17 2007 Chris Lumens <clumens@redhat.com> 1.4-1
96 - Add methods to handle the %ksappend directive.
97 - Fix ignoredisk --disks.
99 * Wed Jul 11 2007 Chris Lumens <clumens@redhat.com> - 1.3-1
100 - Add support for ignoredisk --only-use.
101 - Fix traceback in raid command printing method (#246709).
103 * Fri Jun 08 2007 Chris Lumens <clumens@redhat.com> - 1.2-2
104 - Fix package review problems (#226334).
106 * Mon Jun 04 2007 Chris Lumens <clumens@redhat.com> - 1.2-1
107 - Fix harddrive install method error checking (#232492).
108 - Set authentication information from the input line to preserve quoting
109 (#241657).
110 - Allow included files to be given by URL.
111 - Fix typo in user --iscrypted option.
113 * Mon May 14 2007 Chris Lumens <clumens@redhat.com> - 1.1-1
114 - Better regexes for splitting version strings into family and version.
115 - Add basic support for RHEL3.
116 - Update translations.
118 * Fri Apr 13 2007 Chris Lumens <clumens@redhat.com> - 1.0-1
119 - Update documentation.
120 - Update translations.
122 * Mon Mar 19 2007 Chris Lumens <clumens@redhat.com> - 0.100-1
123 - bootloader should be written out after upgrade/install.
124 - Treat class names as unicode strings (#231053).
126 * Wed Mar 07 2007 Chris Lumens <clumens@redhat.com> - 0.99-1
127 - The timezone command didn't recognize --isUtc before FC6 (#231189).
128 - Recognize %ksappend lines in ksvalidator.
129 - Don't set default values in some command __init__ methods.
130 - Added an updates command.
131 - Add support for RAID10.
133 * Mon Feb 26 2007 Chris Lumens <clumens@redhat.com> - 0.98-1
134 - Fix device command syntax to match anaconda.
135 - Fix __call__ on method command.
137 * Wed Feb 21 2007 Chris Lumens <clumens@redhat.com> - 0.97-1
138 - Fix traceback when not overriding default mappings (#229505).
140 * Tue Feb 20 2007 Chris Lumens <clumens@redhat.com> - 0.96-1
141 - Fix __str__ methods for langsupport and reboot commands.
142 - Renamed BaseHandler.empty to BaseHandler.maskAllExcept.
143 - Split command objects out into their own files in commands/.
144 - Rename command objects to start with Version_.
145 - Support extended group selection syntax.
147 * Wed Feb 14 2007 Chris Lumens <clumens@redhat.com> - 0.95-1
148 - KickstartParser no longer takes a version argument.
149 - Be more lenient in what strings stringToVersion accepts.
150 - Allow setting state on one data object from multiple files.
152 * Wed Feb 07 2007 Chris Lumens <clumens@redhat.com> - 0.94-1
153 - Add a newline to the end of the key command output.
154 - Use network bootproto constants (#197694).
155 - Fix tracebacks in subclass __str__ methods (#226734).
157 * Wed Jan 31 2007 Chris Lumens <clumens@redhat.com> - 0.93-2
158 - Make some minor spec file changes to get closer to the extras guidelines.
160 * Thu Jan 25 2007 Chris Lumens <clumens@redhat.com> - 0.93-1
161 - Add support for FC3, RHEL4, and RHEL5.
162 - The key command was not supported until after FC6.
163 - Accept more strings in stringToVersion.
165 * Fri Jan 19 2007 Chris Lumens <clumens@redhat.com> - 0.92-1
166 - Fix KickstartVersionError reporting.
167 - Add a version attribute to handler objects.
168 - Fix line number reporting on lots of commands.
169 - Add initial support for Fedora 7 and remove deprecated commands.
170 - Accept a --default argument to the %%packages header (#221305).
172 * Wed Jan 17 2007 Chris Lumens <clumens@redhat.com> - 0.91-1
173 - Add a method to read kickstart files from strings.
175 * Tue Jan 16 2007 Chris Lumens <clumens@redhat.com> - 0.90-1
176 - Support multiple versions of kickstart syntax from one code base
177 (#189348).
178 - Fix inconsistency between Script parser and writer (#222877).
180 * Fri Dec 15 2006 Chris Lumens <clumens@redhat.com> - 0.43-1
181 - Pull in new translations (#216620).
183 * Thu Dec 7 2006 Jeremy Katz <katzj@redhat.com> - 0.42-2
184 - rebuild against python 2.5
186 * Tue Dec 05 2006 Chris Lumens <clumens@redhat.com> - 0.42-1
187 - Fix traceback when writing out repo command (#218274).
189 * Fri Dec 01 2006 Chris Lumens <clumens@redhat.com> - 0.41-1
190 - Fix traceback when using deprecated commands (#218047, #218059).
192 * Thu Nov 30 2006 Chris Lumens <clumens@redhat.com> - 0.40-1
193 - Pull in new translations (#216620).
194 - Add --level argument to logging command writer.
196 * Tue Oct 24 2006 Chris Lumens <clumens@redhat.com> - 0.39-2
197 - Fix release number.
199 * Tue Oct 24 2006 Chris Lumens <clumens@redhat.com> - 0.39-1
200 - Add writer for --key (#211997).
202 * Tue Oct 17 2006 Jeremy Katz <katzj@redhat.com> - 0.38-1
203 - allow --skip for installation number as well (#207029)
205 * Mon Oct 16 2006 Jeremy Katz <katzj@redhat.com> - 0.37-1
206 - support for installation numbers (#207029)
208 * Fri Oct 13 2006 Bill Nottingham <notting@redhat.com> - 0.36-1
209 - use valid charsets in translations (#210720)
211 * Fri Sep 29 2006 Chris Lumens <clumens@redhat.com> - 0.35-1
212 - Fix traceback in harddrive command (#208557).
214 * Mon Sep 25 2006 Chris Lumens <clumens@redhat.com> - 0.34-1
215 - Add support for --biospart option to harddrive (#207585).
216 - Update writer for syntax changes.
218 * Wed Sep 20 2006 Jeremy Katz <katzj@redhat.com> - 0.33-1
219 - improved iscsi syntax
220 - allow multiple zfcp devs
222 * Thu Jul 20 2006 Chris Lumens <clumens@redhat.com> 0.32-1
223 - Limit --bootproto to what anaconda supports.
224 - Add --noipv4 and --noipv6 network options.
226 * Tue Jun 20 2006 Chris Lumens <clumens@redhat.com> 0.31-1
227 - Handle nfs --opts (katzj).
228 - RAID devices should be integers instead of strings (#176537).
229 - Add initial support for iscsi (katzj).
231 * Tue Jun 06 2006 Chris Lumens <clumens@redhat.com> 0.30-2
232 - Add BuildRequires to fix building under mock (#194156, Joost Soeterbroek
233 <fedora AT soeterbroek.com>).
235 * Thu May 25 2006 Chris Lumens <clumens@redhat.com> 0.30-1
236 - Change order of LVM-related writing functions (#193073).
237 - Require urlgrabber.
238 - Return a more useful error message on unknown commands.
239 - Fix logvol writing typo.
240 - Make ksvalidator validate from a URL in addition to a file.
241 - Don't write out an empty packages section (#192851).
243 * Tue May 23 2006 Chris Lumens <clumens@redhat.com> 0.29-1
244 - Add multipath command, handlers, and data objects (pjones).
245 - Rename --ports to --port in writer.
247 * Mon May 15 2006 Chris Lumens <clumens@redhat.com> 0.28-1
248 - Support --mtu for the network command (#191328).
249 - Accept --isUtc for backwards compatibility.
251 * Wed May 04 2006 Chris Lumens <clumens@redhat.com> 0.27-1
252 - Output formatting fixes.
253 - Added commands for managing users and services.
255 * Mon Apr 17 2006 Chris Lumens <clumens@redhat.com> 0.26-1
256 - Ignore spaces before group names (#188095).
257 - Added some translations.
258 - Add options for repo command.
259 - Reorder %%packages section output.
260 - Output %%packages header options.
261 - Initialize RAID and volume group members to empty lists.
263 * Mon Mar 27 2006 Chris Lumens <clumens@redhat.com> 0.25-1
264 - Add support for the logging command.
266 * Mon Mar 27 2006 Chris Lumens <clumens@redhat.com> 0.24-1
267 - Don't write out a blank xconfig line.
268 - Reorder output handlers to group like commands together.
269 - Mark strings for translation.
271 * Tue Mar 07 2006 Chris Lumens <clumens@redhat.com> 0.23-1
272 - Backwards compatibility support for options to zerombr.
274 * Fri Feb 24 2006 Chris Lumens <clumens@redhat.com> 0.22-1
275 - Get ignoredisk working again (#182934).
277 * Fri Feb 17 2006 Chris Lumens <clumens@redhat.com> 0.21-1
278 - Provide an option to not traceback on missing include files (#181760).
279 - Update programming documentation.
281 * Mon Feb 13 2006 Chris Lumens <clumens@redhat.com> 0.20-1
282 - Correctly set --noformat and --useexisting on lvm and raid.
284 * Mon Feb 13 2006 Chris Lumens <clumens@redhat.com> 0.19-1
285 - --onboot requires a value (#180987).
286 - Be more strict about commands that don't take arguments.
288 * Thu Feb 09 2006 Chris Lumens <clumens@redhat.com> 0.18-1
289 - Fix some errors pychecker caught.
290 - Allow exceptions to not be fatal so ksvalidator can spot more errors in
291 a single pass (#179894).
293 * Wed Feb 01 2006 Chris Lumens <clumens@redhat.com> 0.17-1
294 - Don't set a default port for vnc.
296 * Tue Jan 31 2006 Chris Lumens <clumens@redhat.com> 0.16-1
297 - Give dmraid string an initial value.
298 - Handle None on partition size.
300 * Tue Jan 31 2006 Peter Jones <pjones@redhat.com> 0.15-1
301 - Add dmraid support
303 * Mon Jan 30 2006 Chris Lumens <clumens@redhat.com> 0.14-1
304 - Fix VNC parameter parsing (#179209).
305 - Deprecate --connect. Add --host and --port instead.
307 * Thu Jan 19 2006 Chris Lumens <clumens@redhat.com> 0.13-1
308 - Recognize the --eject parameter to shutdown/halt.
309 - Store the exact post-installation action in ksdata.
311 * Mon Jan 09 2006 Chris Lumens <clumens@redhat.com> 0.12-1
312 - Clean up output quoting.
313 - Finish removing monitor-related stuff from xconfig.
315 * Mon Dec 12 2005 Chris Lumens <clumens@redhat.com> 0.11-1
316 - Deprecate monitor-related options to xconfig.
318 * Thu Dec 08 2005 Chris Lumens <clumens@redhat.com> 0.10-1
319 - Support --bytes-per-inode on raid
320 (Curtis Doty <Curtis at GreenKey.net> #175288).
322 * Wed Nov 16 2005 Jeremy Katz <katzj@redhat.com> - 0.9-1
323 - fixup network --onboot
325 * Thu Nov 03 2005 Chris Lumens <clumens@redhat.com> 0.8-1
326 - Default to SELINUX_ENFORCING.
327 - Default partition sizes to None for anaconda (#172378).
328 - Don't call shlex.split on anything inside a script (#172313).
330 * Tue Nov 01 2005 Chris Lumens <clumens@redhat.com> 0.7-1
331 - Fix clearpart --all.
332 - vnc command does not require --connect option (#172192).
333 - network --onboot does not take any option.
334 - Remove extra spaces from firewall --ports and --trust.
335 - Write out network --<service> options.
337 * Fri Oct 28 2005 Chris Lumens <clumens@redhat.com> 0.6-1
338 - Add --resolvedeps and --ignoredeps as deprecated options.
339 - Pass line number to header functions.
341 * Mon Oct 24 2005 Chris Lumens <clumens@redhat.com> 0.5-1
342 - Add line numbers to exception reporting.
343 - Added ksvalidator.
345 * Wed Oct 19 2005 Chris Lumens <clumens@redhat.com> 0.4-1
346 - Correct deprecated attribute on options.
347 - Added programming documentation.
349 * Thu Oct 13 2005 Chris Lumens <clumens@redhat.com> 0.3-2
350 - Correct python lib directory on 64-bit archs (#170621).
352 * Fri Oct 07 2005 Chris Lumens <clumens@redhat.com> 0.3-1
353 - Add a deprecated attribute to options.
354 - Add --card option back to xconfig and mark as deprecated.
355 - Throw a deprecation warning on mouse and langsupport commands.
356 - Rename Writer to KickstartWriter for consistency.
357 - Collapse scripts into a single list and add an attribute on Script to
358 differentiate.
360 * Wed Oct 05 2005 Chris Lumens <clumens@redhat.com> 0.2-1
361 - Rename module to pykickstart to avoid conflicts in anaconda.
362 - Rename data classes for consistency.
363 - Add default bytesPerInode settings.
365 * Wed Oct 05 2005 Chris Lumens <clumens@redhat.com> 0.1-1
366 - Created package from anaconda.