Another patch to make the bootloader test work (jlaska).
[pykickstart.git] / pykickstart.spec
blob212ae3c62935777eca6a9ef6fd1f7e57cb8eedc0
1 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
3 Summary: A python library for manipulating kickstart files
4 Name: pykickstart
5 Url: http://fedoraproject.org/wiki/pykickstart
6 Version: 1.56
7 Release: 1%{?dist}
8 # This is a Red Hat maintained package which is specific to
9 # our distribution. Thus the source is only available from
10 # within this srpm.
11 Source0: %{name}-%{version}.tar.gz
13 License: GPLv2
14 Group: System Environment/Libraries
15 BuildArch: noarch
16 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
17 BuildRequires: python-devel, gettext, python-setuptools-devel
18 Requires: python, python-urlgrabber
20 %description
21 The pykickstart package is a python library for manipulating kickstart
22 files.
24 %prep
25 %setup -q
26 make
28 %build
30 %install
31 rm -rf %{buildroot}
32 make DESTDIR=%{buildroot} install
33 %find_lang %{name}
35 %clean
36 rm -rf %{buildroot}
38 %files -f %{name}.lang
39 %defattr(-,root,root,-)
40 %doc README ChangeLog COPYING docs/programmers-guide
41 %doc docs/kickstart-docs.txt
42 %{python_sitelib}/*
43 %{_bindir}/ksvalidator
44 %{_bindir}/ksflatten
45 %{_bindir}/ksverdiff
47 %changelog
48 * Thu Jul 09 2009 Chris Lumens <clumens@redhat.com> - 1.56-1
49 - Make sure to import the gettext stuff in fcoe. (clumens)
50 - Correctly deprecate bootloader --lba32 (jlaska).
51 - pykickstart: fix zfcp command writepriority (hdegoede)
52 - pykickstart: Add fcoe command (take 2) (hdegoede)
53 - Add a test case for RAID (jlaska).
55 * Thu Jul 02 2009 Chris Lumens <clumens@redhat.com> - 1.55-1
56 - Add support for the group command to F12 (#509119).
57 - RHEL5 now supports RAID 10.
58 - The f12 hander class should be called F12Handler. (jgranado)
59 - Remove bootloader --lba32.
60 - Add a new version of the driverdisk command without --type=.
61 - Add initial support for F12.
62 - Fetch the programmers-guide from the wiki now.
64 * Mon May 18 2009 Chris Lumens <clumens@redhat.com> - 1.54-1
65 - Make sure the F11 handler gets used for "partition" and "part" (#501020).
67 * Wed Apr 29 2009 Chris Lumens <clumens@redhat.com> - 1.53-1
68 - Move lineno= from KSOptionParser.__init__ to parse_args (#497149). (clumens)
69 - Use the F11 version of the partition command. (clumens)
70 - Remove the --start and --end options since anaconda no longer uses them. (clumens)
71 - Remove a broken test case. (clumens)
73 * Wed Feb 18 2009 Chris Lumens <clumens@redhat.com> - 1.52-1
74 - Add lots more test cases (alindebe, mgracik, stickster).
75 - Add a skip attribute on key to shut up pychecker.
76 - Only show autostep command when requested (jlaska)
77 - Strip spaces from service names, and require an option to be provided.
78 - Surround services lists in double quotes.
79 - Remove the extra space from the services __str__ method.
80 - Fix output formatting bugs in firewall, partition, and repo (mgracik).
81 - Specifying both or neither of --drives and --only-use should be an error.
82 - Corrected newline char in return value of FC6_Method. (mgracik)
83 - Make --drives a required option for FC3, and catch no args on F8.
84 - Fix final printing of the rescue command (mgracik).
85 - Surround output strings in double quotes.
86 - Fix a typo in the deviceprobe command.
87 - Revert the more strict option processing on displaymode.
88 - Properly handle erroring on extra args, not just extra options.
89 - Don't use the logging class since it interferes with the logging test.
90 - port without host should raise KickstartParseError, not kickstartValueError.
91 - Add the --key option to option processing, since it's a valid argument.
92 - Fix test cases that were failing due to the new use of KSOptionParser.
93 - Teach driverdisk.py command to reject extra partitions (stickster).
94 - Add KSOptionParser to all commands ... enables more strick option checking (jlaska).
95 - Use KSOptionParser so we can catch bad command options (jlaska).
97 * Thu Jan 29 2009 Chris Lumens <clumens@redhat.com> - 1.51-1
98 - Make a couple changes to how the logging command is handled.
99 - Add a lot of test cases (clumens, alindebe, jlaska, fcami, adamwill, pfrields).
100 - Fix output formatting for the rootpw command.
101 - For commands that take exactly one argument, check and error correctly.
102 - Surround module options in quotes on the output side (jlaska).
103 - Set module opts in the FC3 handler correctly.
104 - Fix newlines on the device command output (jlaska).
105 - If --autoscreenshot is not specified, still output "autostep".
106 - Move the currentCmd and currentLine into getParser(). (jlaska)
107 - Write out an selinux line if set to disabled, but not if None.
108 - F9_LogVolData should inherit from FC4_LogVolData, not FC3_LogVolData (jlaska).
109 - Add unittest framework along with logvol and vnc unittests. (jlaska)
110 - Don't set the KSOption.required attribute in the constructor (jlaska).
112 * Sat Jan 10 2009 Chris Lumens <clumens@redhat.com> - 1.50-1
113 - Add a script to diff two versions of kickstart syntax.
114 - Add an option to ksvalidator to list all available syntax versions.
115 - Remove a couple extra newlines in output formatting.
116 - Add documentation for the new %include representation.
117 - Add support %include to the pykickstart data objects.
119 * Thu Jan 08 2009 Chris Lumens <clumens@redhat.com> - 1.49-1
120 - Add upgrade --root-device (atodorov, #471232).
121 - Use python's builtin set rather than the Sets module (#477836, dcantrell).
123 * Tue Dec 23 2008 Chris Lumens <clumens@redhat.com> - 1.48-1
124 - Allow ignoring group metadata from repos, using a '--ignoregroups'
125 boolean. (notting)
126 - Add initial support for F11.
127 - Specify the command versions in the handlers instead of making copies.
128 - Remove empty and pointless __init__ methods.
129 - Pass arguments to superclasses via *args and **kwargs, all the way up.
130 - Add removedKeywords and removedAttrs lists on Commands and Data.
131 - Fix version regexes to handle double digits and minor releases (jlaska).
133 * Thu Oct 30 2008 Chris Lumens <clumens@redhat.com> - 1.47-1
134 - Fix enabling services we specify by specific options.
136 * Mon Oct 27 2008 Chris Lumens <clumens@redhat.com> - 1.46-1
137 - Add support for firewall --service (#467005).
139 * Tue Oct 14 2008 Chris Lumens <clumens@redhat.com> - 1.45-1
140 - Lots of translation updates.
141 - Remove use of string.partition for python2.4 (atodorov).
143 * Mon Sep 22 2008 Chris Lumens <clumens@redhat.com> - 1.44-1
144 - Add support for reverse CHAP to the kickstart iscsi command (hans)
145 - Fix typo (katzj)
147 * Wed Sep 03 2008 Chris Lumens <clumens@redhat.com> - 1.43-1
148 - Revert "Do not include passphrases for encrypted block devices in
149 anaconda-ks.cfg." (dlehman)
150 - yum doesn't like when mirrorlist is "". (clumens)
152 * Mon Aug 11 2008 Chris Lumens <clumens@redhat.com> - 1.42-1
153 - Add rescue command to pykickstart (atodorov)
154 - Sort %packages output (katzj)
155 - Fix a typo (atodorov).
157 * Fri Aug 01 2008 Chris Lumens <clumens@redhat.com> - 1.41-1
158 - RHEL5 supports ignoredisk --only-use now too. (clumens)
159 - Do not include passphrases for encrypted block devices in
160 anaconda-ks.cfg. (dlehman)
161 - Fix F9,F10,RHEL5 "part" commands to use the same class as
162 "partition". (dlehman)
163 - Add an apply method() for commands and implement for lang (katzj)
165 * Tue Jul 15 2008 Chris Lumens <clumens@redhat.com> - 1.40-1
166 - RHEL5_LogVolData should inherit from FC4, not FC3.
167 Also fix FC9->F9 typo. (dlehman)
168 - Support creation of encrypted block devices in RHEL5. (#449830) (dlehman)
169 - Use the right LogVolData objects for RHEL3 and 4 (jlaska). (clumens)
170 - We no longer use rhpl for translations. (clumens)
171 - All the base classes should derive from object. (clumens)
173 * Fri Jun 13 2008 Chris Lumens <clumens@redhat.com> - 1.39-1
174 - It's helpful to return the parser object. (clumens)
176 * Tue Jun 10 2008 Chris Lumens <clumens@redhat.com> - 1.38-1
177 - Fix loading the Handler object by looking for a more specific
178 name (#450740). (clumens)
180 * Sun Jun 08 2008 Chris Lumens <clumens@redhat.com> - 1.37-1
181 - XConfig is still used by other projects, so just deprecate some
182 options. (clumens)
184 * Thu May 29 2008 Chris Lumens <clumens@redhat.com> - 1.36-1
185 - It should be repo --cost, not repo --priority. (clumens)
187 * Fri May 23 2008 Chris Lumens <clumens@redhat.com> - 1.35-1
188 - Bring driverdisk command in line with the docs. (clumens)
189 - Change RAID command print priorities (jlaska).
190 - According to docs, physvols are space delimited. (jlaska)
191 - Don't write the label out twice (jlaska).
192 - Deprecate monitor and xconfig commands. (clumens)
194 * Wed May 07 2008 Chris Lumens <clumens@redhat.com> - 1.34-1
195 - Load the handler module automatically. (clumens)
196 - Add support for F10. (clumens)
197 - Initialize cmd.handler earlier; fixes repo.methodToRepo() (markmc)
198 - Don't shadow builtin function names. (clumens)
199 - Running check is now required before pykickstart can be packaged. (clumens)
200 - Reorganize code a little bit to pass pychecker. (clumens)
202 * Tue Apr 08 2008 Chris Lumens <clumens@redhat.com> - 1.33-1
203 - Fix whitespace when printing out the bootloader command (pmeyers).
204 - Fix the type on bootloader --timeout processing. (clumens)
206 * Wed Apr 02 2008 Chris Lumens <clumens@redhat.com> - 1.32-1
207 - Make the string reader act like the file reader upon EOF. (clumens)
208 - Add syntax for encrypted logical volumes. (clumens)
210 * Tue Mar 25 2008 Chris Lumens <clumens@redhat.com> - 1.31-1
211 - Support end-of-line comments. (clumens)
212 - Lots of translation updates.
214 * Tue Feb 26 2008 Chris Lumens <clumens@redhat.com> - 1.30-1
215 - Reverse writePriorities of iscsi and iscsname (#434965, jlaska).
216 - Fix printing of iscsiname command (#434945, jlaska).
217 - Don't traceback on ENOENT. (pnasrat)
218 - Store the mouse name as a string, not a list. (clumens)
219 - Update translations.
221 * Wed Jan 30 2008 Chris Lumens <clumens@redhat.com> - 1.29-1
222 - Renamed bootproto=ask to bootproto=query, add to RHEL5 as well. (clumens)
224 * Wed Jan 23 2008 Chris Lumens <clumens@redhat.com> - 1.28-1
225 - Fix traceback on volgroup command. (clumens)
227 * Thu Jan 17 2008 Chris Lumens <clumens@redhat.com> - 1.27-1
228 - The bootprotoList needs to be defined before it's used. (clumens)
230 * Thu Jan 17 2008 Chris Lumens <clumens@redhat.com> - 1.26-1
231 - Add support for network --bootproto=ask. (clumens)
233 * Tue Jan 15 2008 Chris Lumens <clumens@redhat.com> - 1.25-1
234 - Add the version to the output ks file. (clumens)
235 - Add syntax for encrypted partitions and raid devices. (clumens)
237 * Thu Jan 10 2008 Chris Lumens <clumens@redhat.com> - 1.24-1
238 - Make inheritance and overriding of %packages work (#427768). (clumens)
239 - Add an option for which languages should be installed. (katzj)
240 - Use the right name for the iscsi --target variable (#418781). (clumens)
242 * Mon Dec 10 2007 Chris Lumens <clumens@redhat.com> - 1.23-1
243 - Take Makefile improvements from anaconda.
244 - Fix a traceback on F9 zerombr command (#395431).
245 - Update to handle new Python eggs packaging.
247 * Tue Nov 20 2007 Chris Lumens <clumens@redhat.com> 1.22-1
248 - Don't process or write out vnc --enabled (jlaska AT redhat DOT com).
249 - Fix a traceback in the clearpart command.
251 * Tue Nov 06 2007 Chris Lumens <clumens@redhat.com> 1.21-1
252 - Save script line numbers for debugging.
253 - More internal cleanups.
255 * Wed Oct 31 2007 Chris Lumens <clumens@redhat.com> 1.20-1
256 - Pull wiki docs from the new location.
257 - Fix error messages for options that have been removed after having been
258 previously deprecated.
259 - zerombr no longer takes any arguments.
260 - %packages --ignoredeps --resolvedeps have been removed.
261 - firewall --high --medium have been removed.
262 - vnc --connect has been removed.
263 - xconfig options from monitor have now been removed.
264 - --bytes-per-inode has been marked as deprecated.
265 - Fix typos.
266 - Add --fsprofile option to disk commands (pjones).
267 - Add F9 support (pjones).
268 - Lots of internal fixes (clumens, pjones).
270 * Tue Oct 23 2007 Chris Lumens <clumens@redhat.com> 1.19-1
271 - Fix a traceback on the cdrom method.
273 * Thu Oct 18 2007 Chris Lumens <clumens@redhat.com> 1.18-1
274 - Don't write out %end to packages and scripts if the syntax version doesn't
275 support it.
276 - Remove obsolete translation (#332221).
278 * Thu Oct 04 2007 Chris Lumens <clumens@redhat.com> 1.17-1
279 - Simplify argument processing and printing.
281 * Wed Oct 03 2007 Chris Lumens <clumens@redhat.com> 1.16-1
282 - Undeprecate %packages --excludedocs.
283 - Fix a traceback in the device command handling.
284 - Add bootloader --timeout (katzj).
286 * Tue Oct 02 2007 Chris Lumens <clumens@redhat.com> 1.15-1
287 - Update translations (#259121).
288 - The device command no longer takes a type argument.
290 * Fri Sep 28 2007 Chris Lumens <clumens@redhat.com> 1.14-1
291 - Fix output formatting for packages section header (#310211).
292 - Add a script to flatten kickstart files containing includes (katzj).
294 * Wed Sep 12 2007 Chris Lumens <clumens@redhat.com> 1.13-1
295 - Add a function to convert URL method strings into repo objects
296 (jkeating).
297 - Writer formatting fixes.
298 - Add kickstart documentation from the Fedora Wiki.
300 * Tue Sep 04 2007 Chris Lumens <clumens@redhat.com> 1.12-1
301 - Fix lots of problems in processing the bootloader, device, network, and
302 raid commands.
303 - Add %end when writing out scripts and packages.
304 - Add a makefile target to run pychecker to cut down on errors in
305 releases.
307 * Mon Sep 3 2007 Jeremy Katz <katzj@redhat.com> - 1.11-1
308 - fix a few tracebacks
310 * Fri Aug 31 2007 Chris Lumens <clumens@redhat.com> 1.10-1
311 - Add network --ipv6=.
313 * Fri Aug 24 2007 Chris Lumens <clumens@redhat.com> 1.9-1
314 - Add support for the %end directive to be placed at the end of scripts
315 and packages sections. Deprecate old syntax.
316 - Clean up after ksvalidator if pykickstart issues a traceback.
317 - Add support for repo --priority --includepkgs --excludepkgs.
318 - Fix newline at end of reboot --eject output (#253562).
320 * Mon Aug 13 2007 Chris Lumens <clumens@redhat.com> 1.8-1
321 - Fix type checking of string values.
323 * Thu Aug 09 2007 Chris Lumens <clumens@redhat.com> 1.7-1
324 - Clarify license in spec file and all source files.
325 - Check string values to options to make sure they're not other options
326 (#251318).
328 * Thu Aug 02 2007 Chris Lumens <clumens@redhat.com> 1.6-1
329 - Fix a couple tracebacks in ksvalidator.
330 - Change --class to --dhcpclass (#248912).
332 * Thu Jul 19 2007 Chris Lumens <clumens@redhat.com> 1.5-2
333 - Require rhpl (#248953).
335 * Tue Jul 17 2007 Chris Lumens <clumens@redhat.com> 1.5-1
336 - Fix traceback when calling preprocessKickstart.
338 * Tue Jul 17 2007 Chris Lumens <clumens@redhat.com> 1.4-1
339 - Add methods to handle the %ksappend directive.
340 - Fix ignoredisk --disks.
342 * Wed Jul 11 2007 Chris Lumens <clumens@redhat.com> - 1.3-1
343 - Add support for ignoredisk --only-use.
344 - Fix traceback in raid command printing method (#246709).
346 * Fri Jun 08 2007 Chris Lumens <clumens@redhat.com> - 1.2-2
347 - Fix package review problems (#226334).
349 * Mon Jun 04 2007 Chris Lumens <clumens@redhat.com> - 1.2-1
350 - Fix harddrive install method error checking (#232492).
351 - Set authentication information from the input line to preserve quoting
352 (#241657).
353 - Allow included files to be given by URL.
354 - Fix typo in user --iscrypted option.
356 * Mon May 14 2007 Chris Lumens <clumens@redhat.com> - 1.1-1
357 - Better regexes for splitting version strings into family and version.
358 - Add basic support for RHEL3.
359 - Update translations.
361 * Fri Apr 13 2007 Chris Lumens <clumens@redhat.com> - 1.0-1
362 - Update documentation.
363 - Update translations.
365 * Mon Mar 19 2007 Chris Lumens <clumens@redhat.com> - 0.100-1
366 - bootloader should be written out after upgrade/install.
367 - Treat class names as unicode strings (#231053).
369 * Wed Mar 07 2007 Chris Lumens <clumens@redhat.com> - 0.99-1
370 - The timezone command didn't recognize --isUtc before FC6 (#231189).
371 - Recognize %ksappend lines in ksvalidator.
372 - Don't set default values in some command __init__ methods.
373 - Added an updates command.
374 - Add support for RAID10.
376 * Mon Feb 26 2007 Chris Lumens <clumens@redhat.com> - 0.98-1
377 - Fix device command syntax to match anaconda.
378 - Fix __call__ on method command.
380 * Wed Feb 21 2007 Chris Lumens <clumens@redhat.com> - 0.97-1
381 - Fix traceback when not overriding default mappings (#229505).
383 * Tue Feb 20 2007 Chris Lumens <clumens@redhat.com> - 0.96-1
384 - Fix __str__ methods for langsupport and reboot commands.
385 - Renamed BaseHandler.empty to BaseHandler.maskAllExcept.
386 - Split command objects out into their own files in commands/.
387 - Rename command objects to start with Version_.
388 - Support extended group selection syntax.
390 * Wed Feb 14 2007 Chris Lumens <clumens@redhat.com> - 0.95-1
391 - KickstartParser no longer takes a version argument.
392 - Be more lenient in what strings stringToVersion accepts.
393 - Allow setting state on one data object from multiple files.
395 * Wed Feb 07 2007 Chris Lumens <clumens@redhat.com> - 0.94-1
396 - Add a newline to the end of the key command output.
397 - Use network bootproto constants (#197694).
398 - Fix tracebacks in subclass __str__ methods (#226734).
400 * Wed Jan 31 2007 Chris Lumens <clumens@redhat.com> - 0.93-2
401 - Make some minor spec file changes to get closer to the extras guidelines.
403 * Thu Jan 25 2007 Chris Lumens <clumens@redhat.com> - 0.93-1
404 - Add support for FC3, RHEL4, and RHEL5.
405 - The key command was not supported until after FC6.
406 - Accept more strings in stringToVersion.
408 * Fri Jan 19 2007 Chris Lumens <clumens@redhat.com> - 0.92-1
409 - Fix KickstartVersionError reporting.
410 - Add a version attribute to handler objects.
411 - Fix line number reporting on lots of commands.
412 - Add initial support for Fedora 7 and remove deprecated commands.
413 - Accept a --default argument to the %%packages header (#221305).
415 * Wed Jan 17 2007 Chris Lumens <clumens@redhat.com> - 0.91-1
416 - Add a method to read kickstart files from strings.
418 * Tue Jan 16 2007 Chris Lumens <clumens@redhat.com> - 0.90-1
419 - Support multiple versions of kickstart syntax from one code base
420 (#189348).
421 - Fix inconsistency between Script parser and writer (#222877).
423 * Fri Dec 15 2006 Chris Lumens <clumens@redhat.com> - 0.43-1
424 - Pull in new translations (#216620).
426 * Thu Dec 7 2006 Jeremy Katz <katzj@redhat.com> - 0.42-2
427 - rebuild against python 2.5
429 * Tue Dec 05 2006 Chris Lumens <clumens@redhat.com> - 0.42-1
430 - Fix traceback when writing out repo command (#218274).
432 * Fri Dec 01 2006 Chris Lumens <clumens@redhat.com> - 0.41-1
433 - Fix traceback when using deprecated commands (#218047, #218059).
435 * Thu Nov 30 2006 Chris Lumens <clumens@redhat.com> - 0.40-1
436 - Pull in new translations (#216620).
437 - Add --level argument to logging command writer.
439 * Tue Oct 24 2006 Chris Lumens <clumens@redhat.com> - 0.39-2
440 - Fix release number.
442 * Tue Oct 24 2006 Chris Lumens <clumens@redhat.com> - 0.39-1
443 - Add writer for --key (#211997).
445 * Tue Oct 17 2006 Jeremy Katz <katzj@redhat.com> - 0.38-1
446 - allow --skip for installation number as well (#207029)
448 * Mon Oct 16 2006 Jeremy Katz <katzj@redhat.com> - 0.37-1
449 - support for installation numbers (#207029)
451 * Fri Oct 13 2006 Bill Nottingham <notting@redhat.com> - 0.36-1
452 - use valid charsets in translations (#210720)
454 * Fri Sep 29 2006 Chris Lumens <clumens@redhat.com> - 0.35-1
455 - Fix traceback in harddrive command (#208557).
457 * Mon Sep 25 2006 Chris Lumens <clumens@redhat.com> - 0.34-1
458 - Add support for --biospart option to harddrive (#207585).
459 - Update writer for syntax changes.
461 * Wed Sep 20 2006 Jeremy Katz <katzj@redhat.com> - 0.33-1
462 - improved iscsi syntax
463 - allow multiple zfcp devs
465 * Thu Jul 20 2006 Chris Lumens <clumens@redhat.com> 0.32-1
466 - Limit --bootproto to what anaconda supports.
467 - Add --noipv4 and --noipv6 network options.
469 * Tue Jun 20 2006 Chris Lumens <clumens@redhat.com> 0.31-1
470 - Handle nfs --opts (katzj).
471 - RAID devices should be integers instead of strings (#176537).
472 - Add initial support for iscsi (katzj).
474 * Tue Jun 06 2006 Chris Lumens <clumens@redhat.com> 0.30-2
475 - Add BuildRequires to fix building under mock (#194156, Joost Soeterbroek
476 <fedora AT soeterbroek.com>).
478 * Thu May 25 2006 Chris Lumens <clumens@redhat.com> 0.30-1
479 - Change order of LVM-related writing functions (#193073).
480 - Require urlgrabber.
481 - Return a more useful error message on unknown commands.
482 - Fix logvol writing typo.
483 - Make ksvalidator validate from a URL in addition to a file.
484 - Don't write out an empty packages section (#192851).
486 * Tue May 23 2006 Chris Lumens <clumens@redhat.com> 0.29-1
487 - Add multipath command, handlers, and data objects (pjones).
488 - Rename --ports to --port in writer.
490 * Mon May 15 2006 Chris Lumens <clumens@redhat.com> 0.28-1
491 - Support --mtu for the network command (#191328).
492 - Accept --isUtc for backwards compatibility.
494 * Wed May 04 2006 Chris Lumens <clumens@redhat.com> 0.27-1
495 - Output formatting fixes.
496 - Added commands for managing users and services.
498 * Mon Apr 17 2006 Chris Lumens <clumens@redhat.com> 0.26-1
499 - Ignore spaces before group names (#188095).
500 - Added some translations.
501 - Add options for repo command.
502 - Reorder %%packages section output.
503 - Output %%packages header options.
504 - Initialize RAID and volume group members to empty lists.
506 * Mon Mar 27 2006 Chris Lumens <clumens@redhat.com> 0.25-1
507 - Add support for the logging command.
509 * Mon Mar 27 2006 Chris Lumens <clumens@redhat.com> 0.24-1
510 - Don't write out a blank xconfig line.
511 - Reorder output handlers to group like commands together.
512 - Mark strings for translation.
514 * Tue Mar 07 2006 Chris Lumens <clumens@redhat.com> 0.23-1
515 - Backwards compatibility support for options to zerombr.
517 * Fri Feb 24 2006 Chris Lumens <clumens@redhat.com> 0.22-1
518 - Get ignoredisk working again (#182934).
520 * Fri Feb 17 2006 Chris Lumens <clumens@redhat.com> 0.21-1
521 - Provide an option to not traceback on missing include files (#181760).
522 - Update programming documentation.
524 * Mon Feb 13 2006 Chris Lumens <clumens@redhat.com> 0.20-1
525 - Correctly set --noformat and --useexisting on lvm and raid.
527 * Mon Feb 13 2006 Chris Lumens <clumens@redhat.com> 0.19-1
528 - --onboot requires a value (#180987).
529 - Be more strict about commands that don't take arguments.
531 * Thu Feb 09 2006 Chris Lumens <clumens@redhat.com> 0.18-1
532 - Fix some errors pychecker caught.
533 - Allow exceptions to not be fatal so ksvalidator can spot more errors in
534 a single pass (#179894).
536 * Wed Feb 01 2006 Chris Lumens <clumens@redhat.com> 0.17-1
537 - Don't set a default port for vnc.
539 * Tue Jan 31 2006 Chris Lumens <clumens@redhat.com> 0.16-1
540 - Give dmraid string an initial value.
541 - Handle None on partition size.
543 * Tue Jan 31 2006 Peter Jones <pjones@redhat.com> 0.15-1
544 - Add dmraid support
546 * Mon Jan 30 2006 Chris Lumens <clumens@redhat.com> 0.14-1
547 - Fix VNC parameter parsing (#179209).
548 - Deprecate --connect. Add --host and --port instead.
550 * Thu Jan 19 2006 Chris Lumens <clumens@redhat.com> 0.13-1
551 - Recognize the --eject parameter to shutdown/halt.
552 - Store the exact post-installation action in ksdata.
554 * Mon Jan 09 2006 Chris Lumens <clumens@redhat.com> 0.12-1
555 - Clean up output quoting.
556 - Finish removing monitor-related stuff from xconfig.
558 * Mon Dec 12 2005 Chris Lumens <clumens@redhat.com> 0.11-1
559 - Deprecate monitor-related options to xconfig.
561 * Thu Dec 08 2005 Chris Lumens <clumens@redhat.com> 0.10-1
562 - Support --bytes-per-inode on raid
563 (Curtis Doty <Curtis at GreenKey.net> #175288).
565 * Wed Nov 16 2005 Jeremy Katz <katzj@redhat.com> - 0.9-1
566 - fixup network --onboot
568 * Thu Nov 03 2005 Chris Lumens <clumens@redhat.com> 0.8-1
569 - Default to SELINUX_ENFORCING.
570 - Default partition sizes to None for anaconda (#172378).
571 - Don't call shlex.split on anything inside a script (#172313).
573 * Tue Nov 01 2005 Chris Lumens <clumens@redhat.com> 0.7-1
574 - Fix clearpart --all.
575 - vnc command does not require --connect option (#172192).
576 - network --onboot does not take any option.
577 - Remove extra spaces from firewall --ports and --trust.
578 - Write out network --<service> options.
580 * Fri Oct 28 2005 Chris Lumens <clumens@redhat.com> 0.6-1
581 - Add --resolvedeps and --ignoredeps as deprecated options.
582 - Pass line number to header functions.
584 * Mon Oct 24 2005 Chris Lumens <clumens@redhat.com> 0.5-1
585 - Add line numbers to exception reporting.
586 - Added ksvalidator.
588 * Wed Oct 19 2005 Chris Lumens <clumens@redhat.com> 0.4-1
589 - Correct deprecated attribute on options.
590 - Added programming documentation.
592 * Thu Oct 13 2005 Chris Lumens <clumens@redhat.com> 0.3-2
593 - Correct python lib directory on 64-bit archs (#170621).
595 * Fri Oct 07 2005 Chris Lumens <clumens@redhat.com> 0.3-1
596 - Add a deprecated attribute to options.
597 - Add --card option back to xconfig and mark as deprecated.
598 - Throw a deprecation warning on mouse and langsupport commands.
599 - Rename Writer to KickstartWriter for consistency.
600 - Collapse scripts into a single list and add an attribute on Script to
601 differentiate.
603 * Wed Oct 05 2005 Chris Lumens <clumens@redhat.com> 0.2-1
604 - Rename module to pykickstart to avoid conflicts in anaconda.
605 - Rename data classes for consistency.
606 - Add default bytesPerInode settings.
608 * Wed Oct 05 2005 Chris Lumens <clumens@redhat.com> 0.1-1
609 - Created package from anaconda.